Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Submodules do not work with staging view and project explorer
Submodules do not work with staging view and project explorer [message #934979] Sat, 06 October 2012 14:33 Go to next message
Sasa Djugum is currently offline Sasa Djugum
Messages: 2
Registered: October 2012
Junior Member
At my work we have a repo with submodules. When I have the entire repo cloned locally, submodules do not have .git folder but only .git file. Project explorer and staging view do not really recognize this so when I select submodule in repository view, it is not shown in staging view (but superrepo instead). Similar thing happens in project explorer view, shows only branches and info for superrepo.

Is this some bug in Egit or?
Re: Submodules do not work with staging view and project explorer [message #935027 is a reply to message #934979] Sat, 06 October 2012 15:41 Go to previous messageGo to next message
R Shapiro is currently offline R Shapiro
Messages: 386
Registered: June 2011
Senior Member
If you don't provide version info for Eclipse and, especially, for EGit, it's very hard for anyone to help with questions like this.


Re: Submodules do not work with staging view and project explorer [message #937666 is a reply to message #934979] Tue, 09 October 2012 06:51 Go to previous messageGo to next message
Annamalai Chockalingam is currently offline Annamalai Chockalingam
Messages: 68
Registered: July 2009
Member
Hello

This feature isnt supported in EGIT yet. Support for submodule is available only to the level that you can add submodules to parentrepos. But for modifying the submodule it should have been checked out seperately into the repo and changes can be refreshed in submodules.

Staging View doesnt work on Submodules at the moment. Please correct me if my understanding is wrong as i have been trying to fix this problem. Do let us know if EGIT team already has a solution in place for this so that i dnt have to break my head and resolve it.

Regards
Malai
Re: Submodules do not work with staging view and project explorer [message #946739 is a reply to message #934979] Tue, 16 October 2012 13:01 Go to previous message
Maxmelbin Neson is currently offline Maxmelbin Neson
Messages: 3
Registered: October 2012
Junior Member
Did you get any solution for your problem which apparently is our problem too.. Smile
Previous Topic:configure display of latest branch commit?
Next Topic:show in repositories view, show in history broken
Goto Forum:
  


Current Time: Thu Oct 02 10:43:50 GMT 2014

Powered by FUDForum. Page generated in 0.02657 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software