Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » NoClassDefFoundError: org.eclipse.hyades.test.common...?
NoClassDefFoundError: org.eclipse.hyades.test.common...? [message #128253] Wed, 09 April 2008 20:10 Go to next message
Young-Soo Roh is currently offline Young-Soo RohFriend
Messages: 4
Registered: July 2009
Junior Member
Hi.

I am trying to create a simple test using Automated GUI Recorder, but I am
getting java.lang.NoClassDefFoundError error.

Am I missing a dependency? Where can I find
org.eclipse.hyades.test.common....?
Any help would be appreciated.

java.lang.NoClassDefFoundError:
org.eclipse.hyades.test.common.runner.internal.util.AgentCon soleStream


org.eclipse.core.runtime.CoreException: Plug-in
"org.eclipse.tptp.test.auto.gui" was unable to instantiate class
" org.eclipse.tptp.test.auto.gui.internal.runner.AutoGUIRunner ".
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .throwException(Unknown
Source)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(Unknown
Source)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(Unknown
Source)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(Unknown
Source)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(Unknown
Source)
at org.eclipse.ui.internal.WorkbenchPlugin$1.run(Unknown Source)
at org.eclipse.swt.custom.BusyIndicator.showWhile(Unknown Source)
at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(Unkn own Source)
at
org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableEx tension(Unknown
Source)
at org.eclipse.ui.internal.EarlyStartupRunnable.run(Unknown Source)
at org.eclipse.core.runtime.SafeRunner.run(Unknown Source)
at org.eclipse.ui.internal.Workbench$54.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
org.eclipse.core.runtime.CoreException[1]: java.lang.NoClassDefFoundError:
org.eclipse.hyades.test.common.runner.internal.util.AgentCon soleStream
at java.lang.J9VMInternals.verifyImpl(Native Method)
at java.lang.J9VMInternals.verify(Unknown Source)
at java.lang.J9VMInternals.initialize(Unknown Source)
at java.lang.Class.newInstanceImpl(Native Method)
at java.lang.Class.newInstance(Unknown Source)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(Unknown
Source)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(Unknown
Source)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(Unknown
Source)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(Unknown
Source)
at org.eclipse.ui.internal.WorkbenchPlugin$1.run(Unknown Source)
at org.eclipse.swt.custom.BusyIndicator.showWhile(Unknown Source)
at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(Unkn own Source)
at
org.eclipse.ui.internal.EarlyStartupRunnable.getExecutableEx tension(Unknown
Source)
at org.eclipse.ui.internal.EarlyStartupRunnable.run(Unknown Source)
at org.eclipse.core.runtime.SafeRunner.run(Unknown Source)
at org.eclipse.ui.internal.Workbench$54.run(Unknown Source)
at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)
Re: NoClassDefFoundError: org.eclipse.hyades.test.common...? [message #128293 is a reply to message #128253] Thu, 10 April 2008 20:33 Go to previous messageGo to next message
Young-Soo Roh is currently offline Young-Soo RohFriend
Messages: 4
Registered: July 2009
Junior Member
I found out that the class AgentConsoleStream is in
org.eclipse.hyades.test.tools.core which I already have in my pluggin
directory, but I am not sure why it complains about this class. I am using
RSM 7.0.5 and I copied AGR pluggin under IBM\SDP\. Note that TPTP is under
IBM\SDPShare directory because it is part of RSM package.
Re: NoClassDefFoundError: org.eclipse.hyades.test.common...? [message #131855 is a reply to message #128293] Fri, 27 June 2008 14:52 Go to previous message
DuWayne Morris is currently offline DuWayne MorrisFriend
Messages: 36
Registered: July 2009
Member
Sorry for the late reply.

I'm not 100% sure on RSM, but for the most part, Rational product
installers create an install configuration that is managed for faster
loading. What this means is that plugins added after the install do not
get scanned and registered.

The solution is to create an extension location (Help->Software
Updates->ManageConfiguration). Under a chosen folder, create the
following directory structure:

Export_Plugin
eclipse
features
plugins

Create an empty file named .eclipseextension directly under the eclipse
directory. Add desired plugins to the extension plugin directory. In
this case, unzip the AGR plugin to the Export_Plugin directory.

Each time the product is started, this extension location will be scanned
if -clean is specified and the added plugins will be registered.

I recommend checking the list in Window->Preferences->Plug-in
Development->Target Platform to make sure your added plugins installed.
Previous Topic:How to develop an agent implementation which can be started by Agent Controller
Next Topic:How does the Eclipse project test it's GUI?
Goto Forum:
  


Current Time: Thu Nov 27 04:58:06 GMT 2014

Powered by FUDForum. Page generated in 0.06514 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software