Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Creating a new file ending in .orig.(Looking for a way to create a new file called file.orig.)
Creating a new file ending in .orig. [message #930743] Tue, 02 October 2012 15:45 Go to next message
Phil Rau is currently offline Phil Rau
Messages: 2
Registered: October 2012
Junior Member
Hello,

I am currently working on an existing Git repository. So, I opened up EGit and started to make the changes to a few files that I needed. All of the files that I modified were properly listed in the "Git Staging" area, under the "Unstaged Changes" box. However, I did create a new file called "MyFile.xml.orig", which was not listed. So, I right clicked on that file and chose "Team"->"Add to Index", but nothing happened.

Next, I headed to Git Command line. I did a "git status" and saw all of the files that I changed (properly) under the "Changes not staged for commit:" section, and the new file that I created (MyFile.xml.orig) listed under the "Untracked Files:" section. At this point, I did a "git add MyFile.xml.orig". Next, I did a "git status" again and it (properly) showed up in the "Changes to be committed:" section.

Heading back to EGit, I now see the the new file (properly) listed in the "Staged Changes" section of "Git Staging" screen.

I'm guessing that EGit has a problem with the .orig extension. So, my question is this: Is there any way that I can add .orig files to the index in EGit, without having to go through the command line.

Thanks in advance for any help that you can offer!
Re: Creating a new file ending in .orig. [message #930912 is a reply to message #930743] Tue, 02 October 2012 19:04 Go to previous messageGo to next message
Manuel Doninger is currently offline Manuel Doninger
Messages: 119
Registered: October 2010
Senior Member
In Eclipse you can configure ignored resources, which is valid for all Team providers, not just EGit. You find that configuration in Window -> Preferences -> Team -> Ignored Resources.
*.orig is ignored by default, but you can disable that.
Re: Creating a new file ending in .orig. [message #930916 is a reply to message #930912] Tue, 02 October 2012 19:06 Go to previous message
Phil Rau is currently offline Phil Rau
Messages: 2
Registered: October 2012
Junior Member
Thanks, Manuel! As timing would have it, I *just* stumbled onto this solution myself. And, I'm happy to say that it works. I'm worried about other potential fall out, but I'll be careful when I'm pushing my changes for the next few days. Smile

Thanks again!
Previous Topic:Unstaging changes during a merge
Next Topic:Fetch is asking for Source?
Goto Forum:
  


Current Time: Thu Oct 02 02:33:27 GMT 2014

Powered by FUDForum. Page generated in 0.01617 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software