Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Unmarshalling through eclipselink moxy and jaxb(Unmarshalling multiple many to one relationship)
Unmarshalling through eclipselink moxy and jaxb [message #930509] Tue, 02 October 2012 11:38 Go to next message
Mitesh Pandey is currently offline Mitesh PandeyFriend
Messages: 7
Registered: March 2012
Junior Member
Hello ,

I am trying to unmarshal a XML into a class whose design are as below

Class A

Class B

Class C Class D

The relationship between Class A and Class B is one to one bidirectional.
The relationship between Class B and Class C is many to one unidirectional
The relationship between Class B and Class D is many to one unidirectional

Class A is root element of my xml schema which is generated through schema gen.

While unmarshalling a xml file with this relaionship, it is giving an array out of bound exception.

But if I unmarshal a xml with only Class C or Class D, it is able to unmarshal it.

I think because of multiple many to one relationship in Class B, unmarshalling is trying to create every combination between Class C and Class D. But I am not very sure of my understanding.

Please suggest some solution

[Updated on: Tue, 02 October 2012 12:20]

Report message to a moderator

Re: Unmarshalling through eclipselink moxy and jaxb [message #930639 is a reply to message #930509] Tue, 02 October 2012 14:00 Go to previous messageGo to next message
Blaise Doughan is currently offline Blaise DoughanFriend
Messages: 163
Registered: July 2009
Senior Member

Hi Mitesh,

Could you post more information about your object model (attach model if possible)? With your many-to-one relationships I'm not sure how you are currently applying your tree structure on the XML. Also could you post your stack trace?

-Blaise
Re: Unmarshalling through eclipselink moxy and jaxb [message #940064 is a reply to message #930639] Thu, 11 October 2012 09:22 Go to previous message
Mitesh Pandey is currently offline Mitesh PandeyFriend
Messages: 7
Registered: March 2012
Junior Member
Hello Blaise,

Thanks for your reply. The issue was with the weblogic server xml transformation factory implementation. I have changed the xml transformation of weblogic server to a xalan, and issue got resolved.
Previous Topic:WebSphere Application Server 7.0.0.7 Local JNDI Name
Next Topic:scalar subqueries in select supported?
Goto Forum:
  


Current Time: Fri Dec 19 23:36:58 GMT 2014

Powered by FUDForum. Page generated in 0.01816 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software