Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Cannot execute Junit Plug-in tests anymore
Cannot execute Junit Plug-in tests anymore [message #929047] Mon, 01 October 2012 07:02 Go to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1418
Registered: July 2009
Senior Member
Hi

suddenly I cannot seem to execute Junit Plug-in tests with Buckminster
and Jenkins anymore... the jobs that used to work now fail executing
such tests... in the log I see these exceptions (see below)

any clue please?
thanks in advance
Lorenzo

!SESSION 2012-09-30 03:47:30.955
-----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_26
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments: -version 3 -port 57712 -testLoaderClass
org.eclipse.jdt.internal.junit4.runner.JUnit4TestLoader
-loaderpluginname org.eclipse.jdt.junit4.runtime -classNames
it.xsemantics.example.lambda.tests.ui.LambdaAllUiTests -application
org.eclipse.pde.junit.runtime.uitestapplication -product
org.eclipse.sdk.ide -testpluginname it.xsemantics.example.lambda.tests
Command-line arguments: -os linux -ws gtk -arch x86 -consoleLog
-version 3 -port 57712 -testLoaderClass
org.eclipse.jdt.internal.junit4.runner.JUnit4TestLoader
-loaderpluginname org.eclipse.jdt.junit4.runtime -classNames
it.xsemantics.example.lambda.tests.ui.LambdaAllUiTests -application
org.eclipse.pde.junit.runtime.uitestapplication -product
org.eclipse.sdk.ide -data
/usr/share/tomcat6/.jenkins/workspace/Xsemantics-Nightly/../junit-workspace
-dev
file:/usr/share/tomcat6/.jenkins/workspace/Xsemantics-Nightly/.metadata/.plugins/org.eclipse.pde.core/pde-junit/dev.properties
-os linux -ws gtk -arch x86 -consoleLog -testpluginname
it.xsemantics.example.lambda.tests

!ENTRY org.eclipse.equinox.simpleconfigurator 4 0 2012-09-30 03:47:32.703
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in
org.eclipse.equinox.internal.simpleconfigurator.Activator.start() of
bundle org.eclipse.equinox.simpleconfigurator.
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1177)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Caused by: java.lang.IllegalStateException: The System Bundle was
updated. The framework must be restarted to finalize the configuration
change
at
org.eclipse.equinox.internal.simpleconfigurator.ConfigApplier.install(ConfigApplier.java:71)
at
org.eclipse.equinox.internal.simpleconfigurator.SimpleConfiguratorImpl.applyConfiguration(SimpleConfiguratorImpl.java:129)
at
org.eclipse.equinox.internal.simpleconfigurator.SimpleConfiguratorImpl.applyConfiguration(SimpleConfiguratorImpl.java:143)
at
org.eclipse.equinox.internal.simpleconfigurator.Activator.start(Activator.java:48)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
... 12 more
Root exception:
java.lang.IllegalStateException: The System Bundle was updated. The
framework must be restarted to finalize the configuration change
at
org.eclipse.equinox.internal.simpleconfigurator.ConfigApplier.install(ConfigApplier.java:71)
at
org.eclipse.equinox.internal.simpleconfigurator.SimpleConfiguratorImpl.applyConfiguration(SimpleConfiguratorImpl.java:129)
at
org.eclipse.equinox.internal.simpleconfigurator.SimpleConfiguratorImpl.applyConfiguration(SimpleConfiguratorImpl.java:143)
at
org.eclipse.equinox.internal.simpleconfigurator.Activator.start(Activator.java:48)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1177)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.osgi 4 0 2012-09-30 03:47:32.710
!MESSAGE Bundle
org.eclipse.equinox.simpleconfigurator_1.0.300.v20110815-1744 [1] is not
active.

!ENTRY org.eclipse.osgi 4 0 2012-09-30 03:47:32.722
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service.
Ensure that the org.eclipse.core.runtime bundle is resolved and started
(see config.ini).
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)


--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Re: Cannot execute Junit Plug-in tests anymore [message #929066 is a reply to message #929047] Mon, 01 October 2012 07:30 Go to previous messageGo to next message
Dennis Huebner is currently offline Dennis HuebnerFriend
Messages: 221
Registered: July 2009
Senior Member

Hi Lorenzo,
maybe this bug report helps:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=326682

Regards,
Dennis.


Re: Cannot execute Junit Plug-in tests anymore [message #929825 is a reply to message #929066] Mon, 01 October 2012 20:15 Go to previous message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1418
Registered: July 2009
Senior Member
On 10/01/2012 09:30 AM, Dennis Hübner wrote:
> Hi Lorenzo,
> maybe this bug report helps:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=326682
>

I don't know whether that's related... I don't have an .eclipse folder
in jenkins...

apparently the problem went away by turning those Junit Plug-in Launch
configurations to be based on features... but I really don't understand
what changed that made this problem show up: nothing had changed in my
code nor in the job configurations...

cheers
Lorenzo


--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
ICQ# lbetto, 16080134 (GNU/Linux User # 158233)
HOME: http://www.lorenzobettini.it MUSIC: http://www.purplesucker.com
http://www.myspace.com/supertrouperabba
BLOGS: http://tronprog.blogspot.com http://longlivemusic.blogspot.com
http://www.gnu.org/software/src-highlite
http://www.gnu.org/software/gengetopt
http://www.gnu.org/software/gengen http://doublecpp.sourceforge.net
Previous Topic:Rebuilding plugin
Next Topic:svn-git and buckminster - can I pull this off somehow?
Goto Forum:
  


Current Time: Sun Dec 21 18:58:11 GMT 2014

Powered by FUDForum. Page generated in 0.01782 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software