Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Execution of any testsuite fails - InactiveProcessException
Execution of any testsuite fails - InactiveProcessException [message #126511] Mon, 17 March 2008 04:15 Go to next message
Bobby is currently offline Bobby
Messages: 3
Registered: July 2009
Junior Member
Steps To Reproduce:
1. Install tptp.runtime.allInOne-4.5.0M5 (on Win XP SP2)
2. Install cosmos-sdk-incubation-COSMOS-1.0.0-200802131535
3. Checkout
org.eclipse.cosmos/tests/data-collection/org.eclipse.cosmos. dc.cmdbf.services.tests
from dev.eclipse.org, /cvsroot/technology
4. Right click any testsuite (eg: TestQueryInputTransformer.testsuite) in
junits folder
5. Runs as -> Test
6. Hangs at 36% and fails with the error:
IWAT4039E The Test Execution Harness reported the following
problems:org.eclipse.hyades.internal.execution.local.control .InactiveProcessException

Note: org.eclipse.cosmos.dc.cmdbf.services.tests plug-in has a dependency
on
org.eclipse.cosmos.common.tests. Please checkout the same from
org.eclipse.cosmos/tests/common in same repository



More information:
Tried with both Sun & IBM java 1.5. Also tried cleaning and refreshing the
workspace and restarting eclipse/OS. Also tried with
tptp.runtime.allInOne.win32.win32.x86-TPTP-4.4.1, but same error.



But the junit can be executed successfully by right clicking and running
the
java file in src folder.


I have also reported a bug for the same
https://bugs.eclipse.org/bugs/show_bug.cgi?id=222382

Has anyone come across a similar situation before? Is this a setup
problem? For eg: a dependency missing, something has to be running while
executing test suite, firewall is blocking something etc...
Re: Execution of any testsuite fails - InactiveProcessException [message #126616 is a reply to message #126511] Mon, 17 March 2008 14:09 Go to previous messageGo to next message
DuWayne Morris is currently offline DuWayne Morris
Messages: 36
Registered: July 2009
Member
Hi,

In general, the InactiveProcessException means that the session JVM kicked
off the test runner java process, which then immediately died.

Typically, this problem is due to missing items in the classpath for the
test to execute such that the runner failed to start. I have existing
defects to improve the error messages to the user.

DuWayne
Re: Execution of any testsuite fails - InactiveProcessException [message #127283 is a reply to message #126616] Tue, 25 March 2008 05:37 Go to previous messageGo to next message
Bobby is currently offline Bobby
Messages: 3
Registered: July 2009
Junior Member
Thanks DuWayne.

I tried setting up tptp.runtime.allInOne.win32.win32.x86-TPTP-4.5.0M5 on
another machine, and it is now working from eclipse with no problems.
I don't remember doing anything different though.

Anyway, I am trying to execute the same testsuite now from command line
using the automation-client-adapter.bat and got stuck with the following
error:

C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\eclipse\plugins\org.eclipse.hyad
es.execution_4.4.100.v200801150400>java -cp ./bin;tptp-automation-client.jar
org.eclipse.hyades.auto
mation.client.adapters.shell.AutomationClientAdapter -configfile
cosmos.config
org.eclipse.hyades.test.tools.core.execute
java.lang.Exception
at
org.eclipse.hyades.automation.server.ServiceProxy.<init>(ServiceProxy.java:100)
at
org.eclipse.hyades.automation.server.AutomationServer.run(Au tomationServer.java:254)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:85)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:58)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:60)
at java.lang.reflect.Method.invoke(Method.java:391)
at
org.eclipse.equinox.internal.app.EclipseAppContainer.callMet hod(EclipseAppContainer.java:547)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:195)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:362)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:85)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:58)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:60)
at java.lang.reflect.Method.invoke(Method.java:391)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 564)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1251)

This is the content of the config file (cosmos.config):
eclipse =
C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\eclipse
workspace =
C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\new_workspace
suite =
C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\workspace\org.eclipse.cosmos.dc.cmdbf.services.tests \junits\TestQueryInputTransformer.testsuite
classpath =
C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\workspace\org.eclipse.cosmos.common.tests;C:\Bobz\wo rkarea\tptp.runtime.allInOne.win32.win32.x86-TPTP-4.5.0M5\wo rkspace\org.eclipse.cosmos.dc.cmdbf.services.tests;..\org.ec lipse.hyades.logging.core_4.3.200.v200801240400/common.runne r.jar;..\org.eclipse.hyades.logging.core_4.3.200.v2008012404 00/http.hexrecr.jar;..\org.eclipse.hyades.logging.core_4.3.2 00.v200801240400/http.hextgen.jar;..\org.eclipse.hyades.logg ing.core_4.3.200.v200801240400/http.runner.jar;..\org.eclips e.hyades.logging.core_4.3.200.v200801240400/java.runner.jar; ..\org.eclipse.hyades.logging.core_4.3.200.v200801240400/man ual.runner.jar;.\org.eclipse.hyades.logging.core_4.3.200.v20 0801240400/tools-core.jar;
vmargs = -Xquickstart

Any pointers would be really helpful. How do I find more information about
the error? Is there any log I can look for more info?

Thanks in advance...
Bobby



"DuWayne Morris" <dmorris@us.ibm.com> wrote in message
news:67685c6febec2ecdb57d0756eeffabf9$1@www.eclipse.org...
> Hi,
>
> In general, the InactiveProcessException means that the session JVM kicked
> off the test runner java process, which then immediately died.
>
> Typically, this problem is due to missing items in the classpath for the
> test to execute such that the runner failed to start. I have existing
> defects to improve the error messages to the user.
>
> DuWayne
>
Re: Execution of any testsuite fails - InactiveProcessException [message #128927 is a reply to message #127283] Wed, 23 April 2008 06:33 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Bobby,
Are you still have problems running your test suite from the command
line?

Paul
"Bobby" <bobbyjoseph@in.ibm.com> wrote in message
news:fsah1v$5nl$1@build.eclipse.org...
> Thanks DuWayne.
>
> I tried setting up tptp.runtime.allInOne.win32.win32.x86-TPTP-4.5.0M5 on
> another machine, and it is now working from eclipse with no problems.
> I don't remember doing anything different though.
>
> Anyway, I am trying to execute the same testsuite now from command line
> using the automation-client-adapter.bat and got stuck with the following
> error:
>
> C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\eclipse\plugins\org.eclipse.hyad
> es.execution_4.4.100.v200801150400>java -cp
> ./bin;tptp-automation-client.jar org.eclipse.hyades.auto
> mation.client.adapters.shell.AutomationClientAdapter -configfile
> cosmos.config
> org.eclipse.hyades.test.tools.core.execute
> java.lang.Exception
> at
> org.eclipse.hyades.automation.server.ServiceProxy.<init>(ServiceProxy.java:100)
> at
> org.eclipse.hyades.automation.server.AutomationServer.run(Au tomationServer.java:254)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:85)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:58)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:60)
> at java.lang.reflect.Method.invoke(Method.java:391)
> at
> org.eclipse.equinox.internal.app.EclipseAppContainer.callMet hod(EclipseAppContainer.java:547)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:195)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:362)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:175)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:85)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:58)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:60)
> at java.lang.reflect.Method.invoke(Method.java:391)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 564)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1251)
>
> This is the content of the config file (cosmos.config):
> eclipse =
> C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\eclipse
> workspace =
> C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\new_workspace
> suite =
> C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\workspace\org.eclipse.cosmos.dc.cmdbf.services.tests \junits\TestQueryInputTransformer.testsuite
> classpath =
> C:\Bobz\workarea\tptp.runtime.allInOne.win32.win32.x86-TPTP- 4.5.0M5\workspace\org.eclipse.cosmos.common.tests;C:\Bobz\wo rkarea\tptp.runtime.allInOne.win32.win32.x86-TPTP-4.5.0M5\wo rkspace\org.eclipse.cosmos.dc.cmdbf.services.tests;..\org.ec lipse.hyades.logging.core_4.3.200.v200801240400/common.runne r.jar;..\org.eclipse.hyades.logging.core_4.3.200.v2008012404 00/http.hexrecr.jar;..\org.eclipse.hyades.logging.core_4.3.2 00.v200801240400/http.hextgen.jar;..\org.eclipse.hyades.logg ing.core_4.3.200.v200801240400/http.runner.jar;..\org.eclips e.hyades.logging.core_4.3.200.v200801240400/java.runner.jar; ..\org.eclipse.hyades.logging.core_4.3.200.v200801240400/man ual.runner.jar;.\org.eclipse.hyades.logging.core_4.3.200.v20 0801240400/tools-core.jar;
> vmargs = -Xquickstart
>
> Any pointers would be really helpful. How do I find more information about
> the error? Is there any log I can look for more info?
>
> Thanks in advance...
> Bobby
>
>
>
> "DuWayne Morris" <dmorris@us.ibm.com> wrote in message
> news:67685c6febec2ecdb57d0756eeffabf9$1@www.eclipse.org...
>> Hi,
>>
>> In general, the InactiveProcessException means that the session JVM
>> kicked off the test runner java process, which then immediately died.
>>
>> Typically, this problem is due to missing items in the classpath for the
>> test to execute such that the runner failed to start. I have existing
>> defects to improve the error messages to the user.
>>
>> DuWayne
>>
>
>
Previous Topic:Problem in runnig testcase
Next Topic:Commandline Property
Goto Forum:
  


Current Time: Fri Jul 25 18:19:50 EDT 2014

Powered by FUDForum. Page generated in 0.07984 seconds