Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Profiling Tomcat and WTP project
Profiling Tomcat and WTP project [message #126167] Wed, 12 March 2008 19:10 Go to next message
Eclipse User
Originally posted by: footh.yahoo.com

Greetings,

I installed the latest TPTP (4.4) and the Remote Agent on my eclipse
platform (3.3.2) and I believe I got it right as I can easily profile a
simple Java application.

However, I am now trying to profile a Tomcat 5.5 server. I simply have my
WTP project deployed to the server, and instead of starting the server, I
run the "Profile" option. The "Profile on Server" dialog shows up, I
select my options and click finish. Then the server starts and upon
starting, it connects the the already running Remote Agent (if I don't
start the remote agent manually beforehand, it complains - I assume this
is normal).

Two things to note:

1) I receive this error in the console as Tomcat starts:
[ERROR][load ] Could not load library JPIBootLoader

2) There doesn't seem to be any profiling going on. The UI doesn't switch
to the profiling view and as I click around pages nothing happens.

I assume these two are related but I can't seem to find any good info that
suits my case. It seems like I'm so close but can't get over the final
hump.

Any help is greatly appreciated.

Regards,

Jeff
Re: Profiling Tomcat and WTP project [message #126765 is a reply to message #126167] Tue, 18 March 2008 11:31 Go to previous message
Eugene Chan is currently offline Eugene Chan
Messages: 287
Registered: July 2009
Senior Member
Jeff,

Does the server startup successfully in profile mode given the error
message shown in console as you mentioned? It sounds like the environment
variables were not setup as expected, please see the following doc on how
to setup the variables on your machine >
http://www.eclipse.org/tptp/platform/documents/tutorials/jvm ti/Java_Application_Profiling_using_TPTP-v2.0.html#3.3
The manual setup of environment variables is no longer required since TPTP
4.4.1 so you may want to try with a more update version of TPTP.

Eugene
Previous Topic:ARM data collection not working
Next Topic:ARM Java and C bindings
Goto Forum:
  


Current Time: Sat Aug 30 10:23:53 EDT 2014

Powered by FUDForum. Page generated in 0.02546 seconds