Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » getting started -- Agent Controller is unavailable under port 10002
getting started -- Agent Controller is unavailable under port 10002 [message #126090] Tue, 11 March 2008 18:02 Go to next message
Eclipse UserFriend
Originally posted by: chris.stoughton.gmail.com

Please let me know what I need to get profiling to work. I installed from
the Europa discovery site and restarted eclipse after that installation.
Thanks for your help. Please let me know if I should post this to a
different newsgroup or mailing list.


I start the RAServer like this:
~/tptpdc/bin$ ./RAStart.sh
Starting Agent Controller
RAServer started successfully

and it shows up in the process list.

Here is the version information for RAServer
~tptpdc/bin$ ./RAServer -v
4.2.0.0

Then in eclipse, in the Profiling and Logging Perspective:
profile as -> open profiling dialog; Attach to Agent, right click --> new

The list of default hosts does NOT show "Local Direct Connection" (as
I expected to see, based on
http://www.eclipse.org/tptp/home/documents/tutorials/viewlet s/v4.1/EW-profile/EW-profile/EW-profile_viewlet_swf.html.
This is why I install and run the RAServer)

This is what I have in the list of hosts:
localhost:10002
t43:100002

(The machine is named t43 in /etc/hosts, and I have tried both of
these names along with the current ip address for the machine. All of
these options behave the same way, described below)

The test Connection button pops up a window with OK in it for all three connections.

Then I select a JUnit test method; in the Profile window, select the Monitor tab and select "Execution Time Analysis"

Click on "Profile"; it takes a while to launch, then the warning window pops up: "One of the selected launch delegates has failed" and the
details say this:

org.eclipse.core.runtime.CoreException
Agent Controller is unavailable under port 10002. Make sure that the service is started and the port number is correct under preferences.
org.eclipse.tptp.platform.execution.exceptions.AgentControll erUnavailableException: Error: Unable to connect to the Agent Controller.Read timed out
at org.eclipse.tptp.platform.execution.client.core.internal.Nod eImpl.connect(NodeImpl.java:128)
at org.eclipse.tptp.platform.execution.util.internal.AgentContr ollerFactory$EstablishConnection.run(AgentControllerFactory. java:126)
at java.lang.Thread.run(Thread.java:619)


Some more information about the configuration:

I'm running Ubuntu 7.04 (Feisty Fawn)

$ uname -a
Linux t43 2.6.20-16-generic #2 SMP Tue Feb 12 05:41:34 UTC 2008 i686 GNU/Linux

$ java -version
java version "1.6.0"
Java(TM) SE Runtime Environment (build 1.6.0-b105)
Java HotSpot(TM) Client VM (build 1.6.0-b105, mixed mode, sharing)



Eclipse Platform

Version: 3.3.2
Build id: M20080221-1800


And here are the *tptp*.jar files located in the eclipse/plugins directory

org.eclipse.tptp.platform.agentcontroller.doc.user_4.2.300.v 200709030100.jar
org.eclipse.tptp.platform.analysis_4.1.300.v200709030100.jar
org.eclipse.tptp.platform.analysis.codereview.java_4.4.2.v20 0802080100.jar
org.eclipse.tptp.platform.analysis.codereview.java.rules_4.4 .2.v200802080100.jar
org.eclipse.tptp.platform.analysis.core_4.4.2.v200802080100. jar
org.eclipse.tptp.platform.analysis.core.ui_4.4.2.v2008020801 00.jar
org.eclipse.tptp.platform.analysis.core.ui.doc_4.2.202.v2008 02080100.jar
org.eclipse.tptp.platform.analysis.engine_4.1.300.v200709030 100.jar
org.eclipse.tptp.platform.common_4.3.102.v200802080100.jar
org.eclipse.tptp.platform.common.ui_4.4.2.v200802080100.jar
org.eclipse.tptp.platform.common.ui.trace_4.3.102.v200802080 100.jar
org.eclipse.tptp.platform.core_4.1.300.v200709030100.jar
org.eclipse.tptp.platform.doc.user_4.2.200.v200801190100.jar
org.eclipse.tptp.platform.examples_4.3.200.v200709030100.jar
org.eclipse.tptp.platform.iac.administrator_4.4.100.v2008020 20100.jar
org.eclipse.tptp.platform.instrumentation.ui_4.3.2.v20080208 0100.jar
org.eclipse.tptp.platform.integration.pde_4.4.1.v20080205010 0.jar
org.eclipse.tptp.platform.jvmti.client_4.4.100.v200802221314 .jar
org.eclipse.tptp.platform.la.core_4.3.102.v200802080100.jar
org.eclipse.tptp.platform.log.doc.user_4.3.200.v200709030100 .jar
org.eclipse.tptp.platform.log.views_4.3.102.v200802221314.ja r
org.eclipse.tptp.platform.lta_4.1.300.v200709030100.jar
org.eclipse.tptp.platform.probekit_4.1.300.v200709030100.jar
org.eclipse.tptp.platform.probekit.launch_4.4.100.v200709030 100.jar
org.eclipse.tptp.platform.report_4.1.300.v200709030100.jar
org.eclipse.tptp.platform.samples_4.1.300.v200709030100.jar
org.eclipse.tptp.platform.statistical.ui_4.1.300.v2007090301 00.jar
org.eclipse.tptp.platform.trace_4.1.300.v200709030100.jar
org.eclipse.tptp.trace_4.1.400.v200709070956.jar
org.eclipse.tptp.trace.arm.doc.user_4.3.1.v200802050100.jar
org.eclipse.tptp.trace.arm.ui_4.3.100.v200801190100.jar
org.eclipse.tptp.trace.jvmti.client_4.4.100.v200709030100.ja r
Re: getting started -- Agent Controller is unavailable under port 10002 [message #126118 is a reply to message #126090] Wed, 12 March 2008 06:22 Go to previous message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Chris,
I'd recommend to use latest 4.5 M5 Agent Controller instead of 4.2.0 you
are using.
After AC get started please ensure that it listens on thre ports: 10002,
10006 and 10005. You can do it with the command "netstat -an | grep 1000".
Regards,
Igor
Previous Topic:static analysis custom rulesets
Next Topic:probe targets and filters
Goto Forum:
  


Current Time: Fri Nov 28 12:47:10 GMT 2014

Powered by FUDForum. Page generated in 0.06465 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software