Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » [POSSIBLE BUG] Eclipse 4.2.1 mess in toolbars
icon4.gif  [POSSIBLE BUG] Eclipse 4.2.1 mess in toolbars [message #927260] Sat, 29 September 2012 08:51 Go to next message
Bartosz Cichecki is currently offline Bartosz Cichecki
Messages: 2
Registered: August 2012
Junior Member
Hello,

I think I may have found a bug in Eclipse 4.2.1. Follow steps to reproduce (based on fresh copy of Eclipse 4.2.1 64 bit for Windows):
1. Run eclipse.exe
2. Go to Window -> Preferences -> General -> Appearence
3. Change theme to Classic, Apply, OK
4. Close eclipse and run it again
5. When started you will see a gap in toolbar

What is more when you go to:
1. Go to Window -> Customize perspective
2. You will see that Execute group is greyed out, and if you want to tick it again, you will get a message: "Execute" cannot be mage visible because it is in the unavailable "null" command group. Would you like to switch to the Command Group Availability tab?".

It looks like toolbar is messed up when changing theme, and there is no way to fix that, Restoring perspectives defaults does not fix the problem.

[Updated on: Sat, 29 September 2012 08:55]

Report message to a moderator

Re: [POSSIBLE BUG] Eclipse 4.2.1 mess in toolbars [message #927282 is a reply to message #927260] Sat, 29 September 2012 09:22 Go to previous messageGo to next message
Sopot Cela is currently offline Sopot Cela
Messages: 596
Registered: December 2010
Senior Member

Please file a bug on https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform in the UI component.
Re: [POSSIBLE BUG] Eclipse 4.2.1 mess in toolbars [message #929421 is a reply to message #927282] Mon, 01 October 2012 08:52 Go to previous messageGo to next message
Karen Butzke is currently offline Karen Butzke
Messages: 220
Registered: July 2009
Senior Member
This is the same thing I was seeing after the partial fix for bug 340695. See comment 27
Re: [POSSIBLE BUG] Eclipse 4.2.1 mess in toolbars [message #929458 is a reply to message #929421] Mon, 01 October 2012 09:24 Go to previous messageGo to next message
Sopot Cela is currently offline Sopot Cela
Messages: 596
Registered: December 2010
Senior Member

I see. The fix didn't make it to 421. There is a possible workaround in https://bugs.eclipse.org/bugs/show_bug.cgi?id=389594#c4
Re: [POSSIBLE BUG] Eclipse 4.2.1 mess in toolbars [message #933201 is a reply to message #927260] Thu, 04 October 2012 16:47 Go to previous message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

It looks like the "toolbar problem" is fixed in the maintenance build (M20121003-1200)

update-site: http://download.eclipse.org/eclipse/updates/4.2-M-builds

Thanks! Smile
Previous Topic:how can I make this editor using RCP?
Next Topic:Graduate XWT
Goto Forum:
  


Current Time: Wed Jul 23 18:22:29 EDT 2014

Powered by FUDForum. Page generated in 0.09158 seconds