Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » CDT Plugin build (prereq version requirements )
CDT Plugin build [message #925544] Thu, 27 September 2012 20:41
Eric Spencer is currently offline Eric SpencerFriend
Messages: 1
Registered: September 2012
Junior Member
I'm running fedore 17 with gcc 4.7

trying to build the CDT from source (checked out from git).

it builds but the link fails with the following -

Buildfile: /home/eric/cdtworking/org.eclipse.cdt/dsf-gdb/org.eclipse.cdt.tests.dsf.gdb/TestAppBuilder.xml

makeTestApps:
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.so when searching for -lstdc++
[exec] /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/libstdc++.a when searching for -lstdc++
[exec] /usr/bin/ld: cannot find -lstdc++
[exec] collect2: error: ld returned 1 exit status
[exec] make: *** [all] Error 1
[exec] Result: 2
BUILD SUCCESSFUL


so - I've been searching for a document that lists the required versions but cannot locate... any help would be appreciated.

Eric
Previous Topic:Unable to Load DLL
Next Topic:Include library is not getting listed under Project Explorer for C/C++ project in Juno with CDT 8.1
Goto Forum:
  


Current Time: Fri Nov 28 05:59:11 GMT 2014

Powered by FUDForum. Page generated in 0.01574 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software