Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Cannot install PDT as plugin in Eclipse Classic 4.2(I get a dependency error)
Cannot install PDT as plugin in Eclipse Classic 4.2 [message #925234] Thu, 27 September 2012 10:16 Go to next message
Luis Martin is currently offline Luis Martin
Messages: 6
Registered: September 2012
Junior Member
Hello, I'm new to Eclipse, just played a little in the past, but I generally used: Dreamweaver on my first years, next Netbeans, finally PHPDesigner. I'd like to try Eclipse PDT seriously, but I opted to install the classic app and then install PDT and Aptana as plugins.

So, I've just installed Eclipse Classic 4.2 (Juno) on Windows 7 (32-bits), and next tried to download and install PDT (PHP Development Tools (PDT) Runtime Feature 3.1.1.201209241501) through Help/Install New Software... getting this error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: PHP Development Tools (PDT) Runtime Feature 3.1.1.201209241501 (org.eclipse.php.feature.group 3.1.1.201209241501)
  Missing requirement: PDT UI Plug-in 3.1.1.201209241501 (org.eclipse.php.ui 3.1.1.201209241501) requires 'bundle org.eclipse.dltk.core.manipulation 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: PHP Development Tools (PDT) Runtime Feature 3.1.1.201209241501 (org.eclipse.php.feature.group 3.1.1.201209241501)
    To: org.eclipse.php.ui [3.1.1.201209241501]


Could you please help me solve this problem?
Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #925963 is a reply to message #925234] Fri, 28 September 2012 03:18 Go to previous messageGo to next message
Robert Gruendler is currently offline Robert Gruendler
Messages: 66
Registered: June 2011
Member
Hi Luis,


which updatesite are you using to install PDT? The version 3.1.1 is not available yet in the built-in updatesite, so i assume you are using some different updatesite which might not be able to resolve the PDT dependency to the Dynamic Language Toolkit (DLTK).
Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #926276 is a reply to message #925963] Fri, 28 September 2012 09:35 Go to previous messageGo to next message
Jacek Pospychala is currently offline Jacek Pospychala
Messages: 159
Registered: July 2009
Senior Member
DLTK is available in Juno repository. When installing PDT, please make sure that you have this checkbox checked "Contact all update sites during install to find required software"
thanks!
Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #926566 is a reply to message #925234] Fri, 28 September 2012 15:36 Go to previous messageGo to next message
Luis Martin is currently offline Luis Martin
Messages: 6
Registered: September 2012
Junior Member
Hello Jacek and Robert, and thanks for replying!

I'm using this repo:
http://download.eclipse.org/tools/pdt/updates/release

just as specified here:
http://www.eclipse.org/pdt/downloads/

I'm also checking "Contact all update sites during install to find required software". But no success.
Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #929835 is a reply to message #926566] Mon, 01 October 2012 16:27 Go to previous messageGo to next message
Robert Gruendler is currently offline Robert Gruendler
Messages: 66
Registered: June 2011
Member
can you list all updatesite which are available in your installation? seems to me like the juno release repository is missing.
Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #948037 is a reply to message #929835] Wed, 17 October 2012 13:39 Go to previous messageGo to next message
Luis Martin is currently offline Luis Martin
Messages: 6
Registered: September 2012
Junior Member
Hello Robert, excuse the delay. I didn't notice your message and I'm using another IDE meanwhile.

After seeing I might need the juno repository I added it to the update list:
Eclipse Juno	http://download.eclipse.org/releases/juno/	Enabled


Since I installed the Juno package I didn't think it was necessary to specifically add it.

Well, having done this, I could install the PDT plugin, and this is what I get in the Installation History:
PHP Development Tools (PDT) Runtime Feature	3.1.1.201209101312
  Dynamic Languages Toolkit - Core Frameworks	4.0.0.201206120848
  Dynamic Languages Toolkit - Core H2 Index Frameworks	4.0.0.201206120848
PHP Development Tools (PDT) Source Feature	3.1.1.201209241501


However I'm not sure if everything was ok. There is no PHP perspective. There is no PHP tab when I click on New. Just the default settings: PHP Project option, and a Web tab. I mean Eclipse still doesn't make you easy to create PHP files, classes, PHP templates, etc. It's still mainly aimed at Java.

Is this what I must expect or did anything go wrong?
Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #953661 is a reply to message #948037] Mon, 22 October 2012 08:30 Go to previous messageGo to next message
Luis Martin is currently offline Luis Martin
Messages: 6
Registered: September 2012
Junior Member
No idea about this issue? It would be a pity not to be able to properly use Eclipse for PHP, since I like it a lot how the GUI looks. Sad
Now I'm using Netbeans, which is very powerful, but I don't like its GUI somewhat.
I also used phpDesigner 8 trial and I liked it a lot in the way that it provides plenty of code assistance, but I found it a bit buggy to purchase it. And Nusphere phpEd is extremely powerful but I consider it too expensive.

[Updated on: Mon, 22 October 2012 08:30]

Report message to a moderator

Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #956143 is a reply to message #953661] Wed, 24 October 2012 05:18 Go to previous messageGo to next message
stephane guedon is currently offline stephane guedon
Messages: 3
Registered: October 2012
Junior Member
Don't know but I'm under Kubuntu and I use Eclipse Indigo Baisc + PDT 3.1.1. and it works very well ... could you downgrade your eclipse ?

Feirfeu !
Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #962683 is a reply to message #956143] Mon, 29 October 2012 04:47 Go to previous messageGo to next message
Robert Gruendler is currently offline Robert Gruendler
Messages: 66
Registered: June 2011
Member
Hi Luis,

i'm 100% sure that the regular updatesite works, no need to manually add anything to eclipse.

Simply download "Eclipse Classic 4.2.1" "http://www.eclipse.org/downloads/

Then open up eclipse, go to "Help -> Install New Software", select the "Juno - http://download.eclipse.org/releases/juno" entry from the "Work with" dropdown.

Under the "Web, XML, Java EE and OSGi Enterprise Developmet" category, select "PHP Development Tools (PDT) SDK Feature 3.1.1.201209101312".

This will install PDT, and everything should work out of the box. I'm so sure about that because i've started with a PDT tutorial this weekend, where i tested
the whole install process multiple times: http://blog.dubture.com/2012/10/improving-your-productivity-with.html Wink

If you still have troubles, you can get live-help by joining the #pdt irc channel on freenode, i'm around most of the time (pulse00).

Re: Cannot install PDT as plugin in Eclipse Classic 4.2 [message #995564 is a reply to message #962683] Sun, 30 December 2012 08:35 Go to previous message
Luis Martin is currently offline Luis Martin
Messages: 6
Registered: September 2012
Junior Member
Hello again. Sorry for the delay. I was using PHPDesigner meanwhile, but I'm going to give it a try again.

Robert: I did what you said in your last message, and everything went smooth. Thanks for you help!

So you mean that doing so (fetching from the Juno repo instead of the PDT repo) will completely install PDT? I don't need to load anything from the PDT repo afterwards?
Previous Topic:Is it possible to specify resource filters for the entire workspace (not just individual projects)?
Next Topic:how to use WSDL editor in Indigo
Goto Forum:
  


Current Time: Tue Jul 29 06:47:11 EDT 2014

Powered by FUDForum. Page generated in 0.02534 seconds