Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Arabic(How to dispaly arabic)
Arabic [message #922889] Tue, 25 September 2012 08:33 Go to next message
Jason Ajo is currently offline Jason Ajo
Messages: 6
Registered: September 2012
Junior Member
Hi,

I am new to BIRT and I am using BIRT 4.2 All in One version.

My problem is viewing arabic characaters.

Here are my process of creating the report
1.) I have report oreintation defined RIGHT to LEFT

2.) My system is WINDOWS xp with arabic support.

3.) I have a resource myresource_ar_SA.properties , I have a value pair in inside. This was primarly for the labels, no problem here.

4.) I have a column of type datetime value(ENGLISH) and it also renders the arabic datatime value correctly. I define the Format Date time section for the Properties tab to be arabic(Saudi Arabia), preview format secion is arabic. No problem here

5.) I have a column of type DECIMAL(ENGLISH), I define the Format Section of the Properties Tab to be arabic(Saudi Arabia) . It did not render the arabic numbers. Even the Preview format section is in english.

When I click preview tab only the labels and date time value are arabic.

I am lost of how to enable / display alpha numeric for arabic.

Any help is highly appreciated.

Thank you in advance.


Re: Arabic [message #923298 is a reply to message #922889] Tue, 25 September 2012 16:03 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you post a screenshot of what it looks like?

Jason
Re: Arabic [message #923677 is a reply to message #923298] Wed, 26 September 2012 01:16 Go to previous messageGo to next message
Jason Ajo is currently offline Jason Ajo
Messages: 6
Registered: September 2012
Junior Member
Hi Jason

Thank you for the quick reply.

Here is the screenshot as requested. Let me know if you still more information.
index.php/fa/11628/0/
  • Attachment: arabic.JPG
    (Size: 63.18KB, Downloaded 292 times)
Re: Arabic [message #924399 is a reply to message #923677] Wed, 26 September 2012 16:22 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

What data type is APP_AAD_Id in the binding tab for the table?

Jason
Re: Arabic [message #925988 is a reply to message #924399] Fri, 28 September 2012 03:46 Go to previous messageGo to next message
Jason Ajo is currently offline Jason Ajo
Messages: 6
Registered: September 2012
Junior Member
Hi Jason,

The APP_AAD_ID type is decimal.
Re: Arabic [message #926568 is a reply to message #925988] Fri, 28 September 2012 15:38 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

If you change the locale to something like German does it work?

Jason
Re: Arabic [message #926971 is a reply to message #926568] Sat, 29 September 2012 01:47 Go to previous messageGo to next message
Jason Ajo is currently offline Jason Ajo
Messages: 6
Registered: September 2012
Junior Member
I have attached here a screenshot for German I also tried the Hindi.

index.php/fa/11660/0/


  • Attachment: arabic2.JPG
    (Size: 113.75KB, Downloaded 319 times)
Re: Arabic [message #929610 is a reply to message #926971] Mon, 01 October 2012 11:58 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Those look correct. Am I missing something?

Jason
Re: Arabic [message #930269 is a reply to message #929610] Tue, 02 October 2012 02:53 Go to previous messageGo to next message
Jason Ajo is currently offline Jason Ajo
Messages: 6
Registered: September 2012
Junior Member
Hi Jason,

Thank you for the answers you have provided.

Today I got another xp machine and installed the same BIRT(JUNO) 4.2.1 on it. I also installed the ARABIC language pack.The the same result the number are in english.

I use the eclipse.exe -nl ar switch , the same result the numbers are in english. I attache here a screenshot

Here is my setup

windows xp sp2, sp3
BIRT 4.2.1 (JUNO), one with arabic language pack


Could there be something on fonts...xml file to tweak

index.php/fa/11683/0/
  • Attachment: arabic.bmp
    (Size: 1.21MB, Downloaded 332 times)
Re: Arabic [message #930571 is a reply to message #929610] Tue, 02 October 2012 08:49 Go to previous messageGo to next message
Jason Ajo is currently offline Jason Ajo
Messages: 6
Registered: September 2012
Junior Member
Hi Jason,

At last I arrived with the dose to my headache.

It has something to do with windows xp settings.

Windows xp settings
1.) Control panel regional setting->Regional Options->Numbers tab . On the Digit substitution field = Context value
2.) Control panel regional setting->Regional Options tab , beside customize button choose entry Arabic(Saudi Arabia).

and whala , you get arabic numbers rendered correctly, this is in preview tab.


If you run in the View report in Web viewer, english number are displayed.

What could be the problem?
Re: Arabic [message #930871 is a reply to message #930571] Tue, 02 October 2012 14:16 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you open a bugzilla entry for this? I am not certain this is supported in the viewer.

Jason
Previous Topic:Problem accessing 'params' in scripted data source
Next Topic:IE8 SVG Graph tooltip cut off
Goto Forum:
  


Current Time: Mon Jul 28 04:27:34 EDT 2014

Powered by FUDForum. Page generated in 0.02904 seconds