Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Open view in new browser window
Open view in new browser window [message #922867] Tue, 25 September 2012 12:10 Go to next message
r k is currently offline r k
Messages: 20
Registered: June 2012
Junior Member
Hello everybody,

is it possible to open a view in RAP in a new browserwindow? (Need it to show supportcontent independently available at any time).

Tried it with the ExternalBrowser but it only accepts URLs (is there a way to retrieve a direct url to a view and open it in there?).

Thanks for helping,
Ron
Re: Open view in new browser window [message #923837 is a reply to message #922867] Wed, 26 September 2012 08:31 Go to previous message
Tim Buschtoens is currently offline Tim Buschtoens
Messages: 386
Registered: July 2009
Senior Member
Hi.

If you want to have parts of your application in an external browser,
there is no other way than creating another entrypoint to load in that
browser. You then also have to deal with updating both browser windows
at the same time (unless they can run completely independent from another).

In my opinion such a scenario could and should be solved within the same
window. Even if what you describe were possible, most browser now either
block pop-ups or force them into another tab. As a result the user would
have to deal with two different tabs within the same browser window.

Greetings,
Tim


> Hello everybody,
> is it possible to open a view in RAP in a new browserwindow? (Need it to
> show supportcontent independently available at any time).
>
> Tried it with the ExternalBrowser but it only accepts URLs (is there a
> way to retrieve a direct url to a view and open it in there?).
>
> Thanks for helping, Ron

--
Tim Buschtöns

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:Application freezes occasionally
Next Topic:Tooltip not displaying correctly in IE8
Goto Forum:
  


Current Time: Wed Oct 22 15:45:59 GMT 2014

Powered by FUDForum. Page generated in 0.03350 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software