Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Crash of Eclipse on Ubuntu 12.04 platform and a fix(temporary workaround for SWT-GTK libraries - copy them)
Crash of Eclipse on Ubuntu 12.04 platform and a fix [message #922294] Mon, 24 September 2012 22:58
Randall Rathbun is currently offline Randall RathbunFriend
Messages: 1
Registered: September 2012
Junior Member
I could not even get Eclipse to run, as the application crashed with only the log file telling me some type of problem with the SWT-GTK java code. I checked with the Synaptics Software Manager, only to be puzzled why the currently installed libraries were not working.

Eventually I found the workaround from Googling for users with the same problem:

Quote

I was having a very similar error in 12.04:
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-gtk-3740 in java.library.path
...

Duane's work around worked for me also, with the following minor variation since I have a 32 bit machine:
$ cp /usr/lib/jni/libswt-*3740.so ~/.swt/lib/linux/x86

End Quote

This solution worked for me on my own 32-bit machine and Eclipse came up fully functional.
Previous Topic:preprocess only
Next Topic:Indexer statistic
Goto Forum:
  


Current Time: Fri Nov 21 18:08:02 GMT 2014

Powered by FUDForum. Page generated in 0.01761 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software