Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Aggregation with filter in question
Aggregation with filter in question [message #921906] Mon, 24 September 2012 14:41 Go to next message
SHENG HUANG is currently offline SHENG HUANGFriend
Messages: 17
Registered: August 2012
Junior Member
I've tried to use an aggregation to count the data in a grouped table with a filter of the information "date".
I counted the number of data in a month with this filter expression: BirtDateTime.month(row["date"]) == 1

The version of the BIRT I used is 2.3.2 .

My problem is that if there's no data for the month (data that verifies the filter condition expression), the table shows nothing instead of 0.

Is this something configurable and how to configure it?
If else, is this a bug known of the version I used? (I've done some reaserch but I don't find a similar topic.) In this case, is there any possible script solution for my problem?

Thank you in advance.


HUANG Sheng
Re: Aggregation with filter in question [message #922224 is a reply to message #921906] Mon, 24 September 2012 21:17 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Add an oncreate script on the aggregation element that has this value:
if( this.getValue() == null ){
this.setDisplayValue(0);
}

Jason
Re: Aggregation with filter in question [message #922710 is a reply to message #922224] Tue, 25 September 2012 08:58 Go to previous messageGo to next message
SHENG HUANG is currently offline SHENG HUANGFriend
Messages: 17
Registered: August 2012
Junior Member
It works nice ! Thank you Very Happy

HUANG Sheng
Re: Aggregation with filter in question [message #939269 is a reply to message #921906] Wed, 10 October 2012 15:34 Go to previous messageGo to next message
SHENG HUANG is currently offline SHENG HUANGFriend
Messages: 17
Registered: August 2012
Junior Member
The solution works well in my local environnement, when I imported my report on the server. The script doesn't work any more.
Do you have any idea what could be the cause of the problem? It this possibly configuable somehow?

Thanks in advance.


HUANG Sheng
Re: Aggregation with filter in question [message #939858 is a reply to message #939269] Thu, 11 October 2012 05:07 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

What server are you using? Do you get an error?

Jason
Re: Aggregation with filter in question [message #940256 is a reply to message #939858] Thu, 11 October 2012 13:16 Go to previous messageGo to next message
SHENG HUANG is currently offline SHENG HUANGFriend
Messages: 17
Registered: August 2012
Junior Member
It's the application Maximo 7 with the server Webshpere which runs the reports.
I think that it calls a applet java to run the reports, but I'm not sure.
I don't have the error in the log of the server.


HUANG Sheng
Re: Aggregation with filter in question [message #941684 is a reply to message #940256] Fri, 12 October 2012 19:18 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

You do not get any errors? It just does not set the value? Does it matter if you move it to the onrender script instead of oncreate?

Jason
Re: Aggregation with filter in question [message #948733 is a reply to message #941684] Thu, 18 October 2012 10:12 Go to previous messageGo to next message
SHENG HUANG is currently offline SHENG HUANGFriend
Messages: 17
Registered: August 2012
Junior Member
Thanks again, it works on the two sides when i move the script to the "onRender" event.
It's although strange to have a different behavior for the "onCreate" event in the viewer and in the server.
The point is that it works now. Very Happy


HUANG Sheng
Re: Aggregation with filter in question [message #949367 is a reply to message #948733] Thu, 18 October 2012 23:46 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

My guess would be one is using a runandrender task and the other is using a run task followed by a render task which changes the event order.

Jason
Previous Topic:What designed version for BIRT 4.2.1?
Next Topic:[Chart] AutoScaling and y-Labels
Goto Forum:
  


Current Time: Sat Nov 22 03:05:52 GMT 2014

Powered by FUDForum. Page generated in 0.01885 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software