Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » preDelete and postDelete not called for patterns
preDelete and postDelete not called for patterns [message #921897] Mon, 24 September 2012 10:34 Go to next message
Cedric Moonen is currently offline Cedric Moonen
Messages: 269
Registered: August 2009
Senior Member
I think I've found a bug when using pattern and the delete feature. When using standalone feature, you have the option to override the preDelete and postDelete methods but when using a pattern, those methods are not called. This is because the preDelete and postDelete methods are called inside the delete method of the DefaultDeleteFeature and thus simply redirect to the methods of the DefaultDeleteFeature (which do nothing).
The difference with the delete method is that this one is called from the DeleteFeatureForPattern class.

Am I correct in thinking that this is a bug ?
Re: preDelete and postDelete not called for patterns [message #922829 is a reply to message #921897] Tue, 25 September 2012 07:23 Go to previous messageGo to next message
Michael Wenz is currently offline Michael Wenz
Messages: 1577
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Yes, seems you are right. Probably this would affect preRemove and
postRemove functionality as well...

Would you please open a bugzilla to track that?

Thanks,
Michael
Re: preDelete and postDelete not called for patterns [message #922926 is a reply to message #922829] Tue, 25 September 2012 09:10 Go to previous message
Cedric Moonen is currently offline Cedric Moonen
Messages: 269
Registered: August 2009
Senior Member
Ok done.
Previous Topic:DirectEditing field position
Next Topic:Create connection that is not linked to a BO
Goto Forum:
  


Current Time: Wed Aug 20 10:56:42 EDT 2014

Powered by FUDForum. Page generated in 0.06281 seconds