Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Updating the GCC on OSX 10.8 (New to programming. New to Eclipse. Lost.)
Updating the GCC on OSX 10.8 [message #919447] Sat, 22 September 2012 01:49
K. S. is currently offline K. S.
Messages: 2
Registered: September 2012
Junior Member
Hello. I'm not 100% sure if this is the best place to put this, but what the heck...

I'm running OSX 10.8 Mountain Lion on my Macbook Pro, and I'm trying to learn C/C++. The tutorial I've been looking at tells me that first, I should upgrade the GCC to at least 4.7 (now 4.8 is out) so that I can work with some of the new additions found in C++11 and C11, or whatever. I already have Xcode 4.5 installed (just updated today) and have the GCC 4.2 that comes with Command Line Tools, but that's outdated and I've been trying to find out how to upgrade the GCC so that I can use C11/C++11 commands and such in Eclipse.

Does anyone know a simple way to do this?

Btw, I downloaded the GCC 4.8 files from hpc.sourceforge.net, if that means anything.
Previous Topic:shared_ptr dereferencing again
Next Topic:Unresolved Symbols
Goto Forum:
  


Current Time: Sat Oct 25 04:34:52 GMT 2014

Powered by FUDForum. Page generated in 0.03992 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software