Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't open Eclipse Juno
Can't open Eclipse Juno [message #919183] Fri, 21 September 2012 19:16 Go to next message
Crystal Pavis is currently offline Crystal Pavis
Messages: 4
Registered: September 2012
Junior Member
I can't get Eclipse Juno to open.
Here is my eclipse.ini file
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120522-1813
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
C:\Java\jre6\bin\javaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-Xms40m
-Xmx512m


When trying to open Eclipse it says:
An error has occurred see log..
The log says:

!SESSION 2012-09-21 15:10:42.111 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_34
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

!ENTRY org.eclipse.osgi 4 0 2012-09-21 15:10:42.611
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)



---------------------------
I appreciate your help!
~Crystal
Re: Can't open Eclipse Juno [message #919923 is a reply to message #919183] Sat, 22 September 2012 14:04 Go to previous messageGo to next message
Eliseo Ocampos is currently offline Eliseo Ocampos
Messages: 15
Registered: September 2012
Junior Member
Hey Crystal,

Would you try to run Eclipse with -debug flag? Just open a command line window, go to Eclipse installation directory and enter: eclipse -debug
Re: Can't open Eclipse Juno [message #920078 is a reply to message #919183] Sat, 22 September 2012 18:04 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2308
Registered: July 2009
Senior Member
How did you unpack the Juno Java EE download? What did you use to unzip it? Did you extract it into a clean directory? Is that also a 64-bit JRE you have installed?

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Can't open Eclipse Juno [message #921841 is a reply to message #919923] Mon, 24 September 2012 13:31 Go to previous messageGo to next message
Crystal Pavis is currently offline Crystal Pavis
Messages: 4
Registered: September 2012
Junior Member
I ran eclipse -debug
The popup said:
An error occurred. See the log file.
The log file says:

!SESSION 2012-09-24 09:30:29.632 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_34
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product -debug

!ENTRY org.eclipse.osgi 4 0 2012-09-24 09:30:30.078
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
Re: Can't open Eclipse Juno [message #921847 is a reply to message #920078] Mon, 24 September 2012 13:37 Go to previous messageGo to next message
Crystal Pavis is currently offline Crystal Pavis
Messages: 4
Registered: September 2012
Junior Member
I had right clicked the eclipse Juno zip file and used the windows 7 extract all option. I extracted it to a clean directory.
Yes, I am using a 64 bit JRE.
The eclipse I am using is 64 bit as well.

I appreciate your help!

~Crystal
Re: Can't open Eclipse Juno [message #922032 is a reply to message #921847] Mon, 24 September 2012 17:12 Go to previous messageGo to next message
Eliseo Ocampos is currently offline Eliseo Ocampos
Messages: 15
Registered: September 2012
Junior Member
I did a search on Google with the text:
"Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started"

Apparently there is an issue with config.ini file, maybe the first result of the search (the one that points to StackOverflow) could help you.
Re: Can't open Eclipse Juno [message #922147 is a reply to message #922032] Mon, 24 September 2012 19:44 Go to previous message
Crystal Pavis is currently offline Crystal Pavis
Messages: 4
Registered: September 2012
Junior Member
Thanks for your suggestion. I had also seen that on StackOverflow before I posted here. I had tried it by pasting
Dosgi.bundles=org.eclipse.equinox.common@2:start,org.eclipse.update.configurator@3:start,org.eclipse.core.runtime@


to the bottom of the eclipse.ini file and I receive this error:
Could not find the main class:
Dosgi.bundles=org.eclipse.equinox.common@2:start,org.eclipse.update.configurator@3:start,org.eclipse.core.runtime@
Program will exit. 


When I close that I get a popup that says
Java was started but returned exit code=1
C:\Java\jre\bin\javaw.exe
-Dosgi.requiredJavaVersion=1.5

and more text but I can't copy and paste it.

So I pointed it to a different JDK I have on my computer and it went back to the original error message:
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).

[Updated on: Mon, 24 September 2012 19:57]

Report message to a moderator

Previous Topic:SDK manager
Next Topic:again (No suitable driver found for jdbc:sqlserver) error !
Goto Forum:
  


Current Time: Tue Oct 21 07:08:58 GMT 2014

Powered by FUDForum. Page generated in 0.09153 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software