Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » After "Build Complete", process takes 3 seconds to finish
After "Build Complete", process takes 3 seconds to finish [message #917022] Wed, 19 September 2012 18:40 Go to next message
Darryl Drudge is currently offline Darryl Drudge
Messages: 2
Registered: September 2012
Junior Member
When I build my c++ module, the "Build Complete" notification shows up but it still takes a few seconds for the process to go away. I often look at the console output and fix compile errors before the build finishes and I can't rebuild until this is done (saving and running certain external tools also block) so it is a bit annoying. What is eclipse doing in this time and can I disable it?
Re: After "Build Complete", process takes 3 seconds to finish [message #917166 is a reply to message #917022] Wed, 19 September 2012 21:55 Go to previous messageGo to next message
Andrew Gvozdev is currently offline Andrew Gvozdev
Messages: 255
Registered: July 2009
Senior Member
Most likely eclipse is busy refreshing the project (searching for new files and files modified by build). If it is big it could take noticeable time. You can define refresh policy in project properties->C/C++ Build->[Refresh Policy] tab.

Andrew
Re: After "Build Complete", process takes 3 seconds to finish [message #918040 is a reply to message #917166] Thu, 20 September 2012 17:26 Go to previous message
Darryl Drudge is currently offline Darryl Drudge
Messages: 2
Registered: September 2012
Junior Member
It works! I've reduced the time now to under a second. Too bad it is a blocking operation though. Thanks for your help.
Previous Topic:Eclipse and FFTW
Next Topic:Managed Build Associate ProjectType with Existing General Category
Goto Forum:
  


Current Time: Fri Oct 31 17:58:53 GMT 2014

Powered by FUDForum. Page generated in 0.01722 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software