Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGL Development Tools » DataGrid is broken?
DataGrid is broken? [message #915306] Sun, 16 September 2012 23:13 Go to next message
Dan Darnell is currently offline Dan Darnell
Messages: 145
Registered: November 2011
Location: Arkansas
Senior Member
I may have missed something but when I create a new project and drop a DataGrid on my form I get errors. This is in EDT 0.8.1.

Code looks right to me but the following...

	grid DataGrid{
		behaviors = [ ],
		headerBehaviors = [ ],
		columns = [
			new DataGridColumn{name = "field1", displayName = "Column 1 Header", width=120},
			new DataGridColumn{name = "field2", displayName = "Column 2 Header", width=120}
		],
		data = [
			new Dictionary { field1 = "Row 1, Column 1", field2 = "Row 1, Column 2"},
			new Dictionary { field1 = "Row 2, Column 1", field2 = "Row 2, Column 2"}
		]
	};


...reports errors on the "new DataGridColumn" column lines:

IWN.VAL.6653.e 52/13 scoresDialog - DataGridColumn[] and DataGridColumn[] are not compatible
types in the expression columns = [new DataGridColumn,new DataGridColumn].

Same thing on other working code that I have ported over from RBD.

I'm hoping that someone can offer some guidance and, if this is a bug, perhaps a code fix. Kind of a big deal to not have data grids...

--Dan


Re: DataGrid is broken? [message #915362 is a reply to message #915306] Mon, 17 September 2012 02:19 Go to previous messageGo to next message
Trond Einar Nilsen is currently offline Trond Einar Nilsen
Messages: 33
Registered: December 2011
Member
Seems to me that this started after some nightly build, I went back to "clean" 8.1
/Trond
Re: DataGrid is broken? [message #915494 is a reply to message #915362] Mon, 17 September 2012 08:08 Go to previous messageGo to next message
Richard Moulton is currently offline Richard Moulton
Messages: 92
Registered: August 2011
Location: Devon, UK
Member
I too tried this on a clean 0.8.1 without a problem.

I did have a similar problem a while back but could never replicate it. I modified a library part that already included an array variable declaration; an array declaration based on one of my own record parts. After making the modification that array declaration came up with, from memory, the same, or certainly similar message you received. I didn't actually change the array declaration, so I was surprised when the line came up with in error. I spent a good while trying to work out what the problem was and never could, out of desperation I then re-typed the array declaration and all was good.

Richard
Re: DataGrid is broken? [message #915533 is a reply to message #915306] Mon, 17 September 2012 09:27 Go to previous messageGo to next message
Paul Harmon is currently offline Paul Harmon
Messages: 11
Registered: July 2009
Junior Member
I am very interested in understanding what is causing this problem If you have a recreatable testcase, could you open a Bugzilla bug and attach the test (I cannot recreate the problem with a simple test).
Re: DataGrid is broken? [message #915617 is a reply to message #915533] Mon, 17 September 2012 12:39 Go to previous messageGo to next message
Dan Darnell is currently offline Dan Darnell
Messages: 145
Registered: November 2011
Location: Arkansas
Senior Member

I don't pull in nightly builds so I don't think it is a nightly that is causing the problem in my case.

I'll try a new workspace but the one I am using was created when I did a clean install of 0.8.1 not long ago.

Very odd.

--Dan
Re: DataGrid is broken? [message #916161 is a reply to message #915533] Tue, 18 September 2012 12:28 Go to previous message
Dan Darnell is currently offline Dan Darnell
Messages: 145
Registered: November 2011
Location: Arkansas
Senior Member
Paul,

I couldn't recreate the issue but it went away when I connected to a new workspace and then connected back to the original workspace.

Now that I have a functioning DataGrid I encountered a new issue ... perhaps you could validate that this is a bug and I will submit the report...

I get an error in the IDE when I try to create a behavior function. Below is a simple case, using the tooling to create the grid and generate the stub behavior function:

    grid DataGrid{
		behaviors = [ format ],
		headerBehaviors = [ ],
		columns = [
			new DataGridColumn{name = "field1", displayName = "Column 1 Header", width=120},
			new DataGridColumn{name = "field2", displayName = "Column 2 Header", width=120}
		],
		data = [
			new Dictionary { field1 = "Row 1, Column 1", field2 = "Row 1, Column 2"},
			new Dictionary { field1 = "Row 2, Column 1", field2 = "Row 2, Column 2"}

 function format(grid DataGrid in, cell Widget in, rowData any in, dataIndex int in, column DataGridColumn in) 
    	//Auto-generated method stub
    end

		]
	};


Error:
IWN.VAL.6653.e 18/15 testrui - DataCellBehavior[] and format[] are not compatible types in the
expression behaviors = [format]. At line 18 in file \TestRUI\EGLSource\client\TestRUI.egl

--Dan
Previous Topic:Dojo Samples
Next Topic:"Cannot create PoolableConnectionFactory" error in "RUI with Database" tutorial
Goto Forum:
  


Current Time: Sun Aug 31 02:28:32 EDT 2014

Powered by FUDForum. Page generated in 0.01994 seconds