Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » disabling preprocessor
disabling preprocessor [message #912481] Thu, 13 September 2012 16:46 Go to next message
Carlos Pereira is currently offline Carlos Pereira
Messages: 1
Registered: September 2012
Junior Member
I am using eclipse cdt just for editing my code (the compilation is made by scripts manually run). Thus, eclipse don't found the preprocessor symbols and grayed the code! I dont want to put ALL the symbols manually. So, is there any way to disable the preprocessor and do the eclipse consider ALL the code?


Tks.
Re: disabling preprocessor [message #1270593 is a reply to message #912481] Thu, 13 March 2014 07:34 Go to previous messageGo to next message
Mikha Atmaja is currently offline Mikha Atmaja
Messages: 1
Registered: March 2014
Junior Member
Hey i have same problem too,
Sometime i don't need to activate the effect of preprocessor,
Because in embedded programing we have the stand alone compiler.
Re: disabling preprocessor [message #1277758 is a reply to message #1270593] Wed, 26 March 2014 12:33 Go to previous message
Axel Mueller is currently offline Axel Mueller
Messages: 1964
Registered: July 2009
Senior Member
In Preferences->C/C++->Editor you can disable "Highlight inactive code".

Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Previous Topic:undefined reference to _kill, _getpid and _sbrk
Next Topic:Eclipse console behaving differently compared to cmd.exe
Goto Forum:
  


Current Time: Thu Oct 30 12:23:26 GMT 2014

Powered by FUDForum. Page generated in 0.11230 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software