Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » Using OCL MDT sources from git
Using OCL MDT sources from git [message #911898] Wed, 12 September 2012 14:46 Go to next message
Fi Fi is currently offline Fi FiFriend
Messages: 133
Registered: March 2010
Senior Member
Dear all,
I try to reuse MDT OCL sources from
https://github.com/eclipse/ocl.git

I try to resolve all dependencies and errors.
I managed to solve many dependencies and errors.
However, some ones are still not solved like for example
Description	Resource	Path	Location	Type
Name clash: The method getPivotOf(MetaModelManager, Class<T>, EObject) of type CompleteOCLCS2Pivot.Factory has the same erasure as getPivotOf(MetaModelManager, Class, EObject) of type MetaModelManager.Factory but does not override it	CompleteOCLCS2Pivot.java	/org.eclipse.ocl.examples.xtext.completeocl/src/org/eclipse/ocl/examples/xtext/completeocl/cs2pivot	line 59	Java Problem


,
Description	Resource	Path	Location	Type
Package 'org.eclipse.imp.editor' does not exist in this plug-in	MANIFEST.MF	/org.eclipse.ocl.examples.editor.ui/META-INF	line 24	Plug-in Problem


and many of
Description	Resource	Path	Location	Type
The annotation @NonNull is disallowed for this location	AbstractBaseCSVisitor.java	/org.eclipse.ocl.examples.xtext.base/emf-gen/org/eclipse/ocl/examples/xtext/base/util	line 38	Java Problem


I use the master branch and I don't know if it is the good one to use.
Can you please tell me what is the required configurations of Eclipse, java, and EMF
and the required branch to use.

Please Help me
Thanks
Re: Using OCL MDT sources from git [message #911974 is a reply to message #911898] Wed, 12 September 2012 17:22 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

You need to install from
http://www.eclipse.org/jdt/core/beta-null-annotations-for-fields as
described in http://wiki.eclipse.org/JDT_Core/Null_Analysis/Beta.

Regards

Ed Willink


On 12/09/2012 15:47, Fy Za wrote:
> Dear all,
> I try to reuse MDT OCL sources from https://github.com/eclipse/ocl.git
>
> I try to resolve all dependencies and errors.
> I managed to solve many dependencies and errors.
> However, some ones are still not solved like for example
> Description Resource Path Location Type
> Name clash: The method getPivotOf(MetaModelManager, Class<T>, EObject)
> of type CompleteOCLCS2Pivot.Factory has the same erasure as
> getPivotOf(MetaModelManager, Class, EObject) of type
> MetaModelManager.Factory but does not override it
> CompleteOCLCS2Pivot.java
> /org.eclipse.ocl.examples.xtext.completeocl/src/org/eclipse/ocl/examples/xtext/completeocl/cs2pivot
> line 59 Java Problem
>
>
> ,
>
> Description Resource Path Location Type
> Package 'org.eclipse.imp.editor' does not exist in this plug-in
> MANIFEST.MF /org.eclipse.ocl.examples.editor.ui/META-INF line 24
> Plug-in Problem
>
>
> and many of
>
> Description Resource Path Location Type
> The annotation @NonNull is disallowed for this location
> AbstractBaseCSVisitor.java
> /org.eclipse.ocl.examples.xtext.base/emf-gen/org/eclipse/ocl/examples/xtext/base/util
> line 38 Java Problem
>
>
> I use the master branch and I don't know if it is the good one to use.
> Can you please tell me what is the required configurations of Eclipse,
> java, and EMF
> and the required branch to use.
>
> Please Help me
> Thanks
Re: Using OCL MDT sources from git [message #912314 is a reply to message #911974] Thu, 13 September 2012 10:25 Go to previous messageGo to next message
Fi Fi is currently offline Fi FiFriend
Messages: 133
Registered: March 2010
Senior Member
Ed...
Thank you very much.
The problem is solved.
However, I have a problem about installing
org.eclipse.emf.examples.

Using EMF update site http://download.eclipse.org/modeling/emf/updates/releases/
I try to install EMF Examples in the EMF SDK 2.5.0 (EMF+SDK),
So I have this message

Cannot complete the install because one or more required items could not be found.
  Software being installed: EMF Examples 2.5.0.v200906151043 (org.eclipse.emf.examples.feature.group 2.5.0.v200906151043)
  Missing requirement: EMF Examples 2.5.0.v200906151043 (org.eclipse.emf.examples.feature.group 2.5.0.v200906151043) requires 'org.eclipse.platform.feature.group [3.3.0.v20061208-Fj22sCYGm0XDWm3,4.0.0)' but it could not be found


NB: I find that all the others packages in EMF SDK 2.5.0 was installed automatically
Can you please help me.
Thanks

[Updated on: Thu, 13 September 2012 10:28]

Report message to a moderator

Re: Using OCL MDT sources from git [message #912431 is a reply to message #912314] Thu, 13 September 2012 15:15 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

Try http://download.eclipse.org/modeling/emf/emf/updates and please
raise a bug against wherever you found
http://download.eclipse.org/modeling/emf/updates/releases/ which is the
old repo before composuitrs came into fashion.

Regards

Ed Willink


On 13/09/2012 11:25, Fy Za wrote:
> Ed...
> Thank you very much.
> The problem is solved.
> However, I have a problem about installing org.eclipse.emf.examples.
>
> Using EMF update site
> http://download.eclipse.org/modeling/emf/updates/releases/
> I try to install EMF Examples in the EMF SDK 2.5.0 (EMF+SDK),
> So I have this message
>
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: EMF Examples 2.5.0.v200906151043
> (org.eclipse.emf.examples.feature.group 2.5.0.v200906151043)
> Missing requirement: EMF Examples 2.5.0.v200906151043
> (org.eclipse.emf.examples.feature.group 2.5.0.v200906151043) requires
> 'org.eclipse.platform.feature.group
> [3.3.0.v20061208-Fj22sCYGm0XDWm3,4.0.0)' but it could not be found
>
>
> Can you please help me.
> Thanks
Re: Using OCL MDT sources from git [message #915496 is a reply to message #912431] Mon, 17 September 2012 12:10 Go to previous messageGo to next message
Fi Fi is currently offline Fi FiFriend
Messages: 133
Registered: March 2010
Senior Member
Dear all,
Using Git, I downloaded OCL sources (maintenance/R4_0 branch) in Eclipse Juno.
I can resolve dependencies but 3 errors still:

1) 'src' folder doesn't finded in the org.eclipse.ocl.examples.xtext2lpg

2) Unsatisfied version constraint: 'org.eclipse.ocl.uml: [3.0.0,4.0.0)' in /org.eclipse.ocl.standalone.tests/META-INF

3) Unsatisfied version constraint: 'org.eclipse.uml2.uml: [3.0.0,4.0.0)' MANIFEST.MF /org.eclipse.ocl.standalone.tests/META-INF


Please help me
Thanks
Re: Using OCL MDT sources from git [message #915522 is a reply to message #915496] Mon, 17 September 2012 12:57 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

As a result of your earlier difficulties I added a missing
http://wiki.eclipse.org/MDT/OCL/Dev/Setup#Getting_the_Sources_from_GIT
section to the wiki.

All three problems should be covered by the final "If you get build
errors ... close any projects that do not seem interesting to you."
comment.

Additionally org.eclipse.ocl.standalone.tests is covered by the only use
"archive" projects for historical research.

org.eclipse.ocl.examples.xtext2lpg is experimental work on using the LPG
parser for enhanced compilation speed and footprint. It is not yet in
use; just close it. I've fixed the src folder warning in a working
branch. Or just delete the src line in the .classpath.

Regards

Ed Willink

On 17/09/2012 13:10, Fy Za wrote:
> Dear all, Using Git, I downloaded OCL sources (maintenance/R4_0
> branch) in Eclipse Juno.
> I can resolve dependencies but 3 errors still:
>
> 1) 'src' folder doesn't finded in the org.eclipse.ocl.examples.xtext2lpg
>
> 2) Unsatisfied version constraint: 'org.eclipse.ocl.uml:
> [3.0.0,4.0.0)' in /org.eclipse.ocl.standalone.tests/META-INF
>
> 3) Unsatisfied version constraint: 'org.eclipse.uml2.uml:
> [3.0.0,4.0.0)' MANIFEST.MF /org.eclipse.ocl.standalone.tests/META-INF
>
>
> Please help me
> Thanks
Re: Using OCL MDT sources from git [message #915527 is a reply to message #915522] Mon, 17 September 2012 13:15 Go to previous messageGo to next message
Fi Fi is currently offline Fi FiFriend
Messages: 133
Registered: March 2010
Senior Member
Thank you Ed,
I resolve all dependencies
Now, I try to generate all editors using
/org.eclipse.ocl.examples.build/src/org/eclipse/ocl/examples/build/GenerateAll.mwe2

I have this error
85854 [Thread-1] ERROR mf.mwe2.launch.runtime.Mwe2Launcher  - Problems running workflow GenerateAll: The type of the first parameter of the main template named 'generate' is a proxy.
java.lang.RuntimeException: Problems running workflow GenerateAll: The type of the first parameter of the main template named 'generate' is a proxy.
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:104)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)
Caused by: org.eclipse.acceleo.engine.AcceleoEvaluationException: The type of the first parameter of the main template named 'generate' is a proxy.
	at org.eclipse.acceleo.engine.service.AcceleoService.doGenerate(AcceleoService.java:566)
	at org.eclipse.acceleo.engine.service.AbstractAcceleoGenerator.generate(AbstractAcceleoGenerator.java:193)
	at org.eclipse.ocl.examples.build.utilities.OCLMetaModelCodeGenerator.invokeInternal(OCLMetaModelCodeGenerator.java:131)
	at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:126)
	at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.invoke(Mwe2Bridge.java:34)
	at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:201)
	at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
	at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
	at org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:19)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
	... 4 more



Can you please help me to resolve these errors?
Thank you
Re: Using OCL MDT sources from git [message #915536 is a reply to message #915527] Mon, 17 September 2012 13:27 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

The Acceleo builder is flaky, particularly on a 'clean' project. As with
many things in Eclipse, sometimes the incremental updates are outwitted
so sometimes you need to refresh and clean some/all projects. I hope
this fixes it.

--- hang on you said GenerateAll -- someone else said this doesn't work.

I never use it, since I know how to sequence the relevant sub-generators

Generate Pivot Models
Generate Xtext Models
Generate All Editors

https://bugs.eclipse.org/bugs/show_bug.cgi?id=389720 raised

Regards

Ed

On 17/09/2012 14:15, Fy Za wrote:
> Thank you Ed,
> I resolve all dependencies Now, I try to generate all editors using
> /org.eclipse.ocl.examples.build/src/org/eclipse/ocl/examples/build/GenerateAll.mwe2
>
>
> I have this error
> 85854 [Thread-1] ERROR mf.mwe2.launch.runtime.Mwe2Launcher - Problems
> running workflow GenerateAll: The type of the first parameter of the
> main template named 'generate' is a proxy.
> java.lang.RuntimeException: Problems running workflow GenerateAll: The
> type of the first parameter of the main template named 'generate' is a
> proxy.
> at
> org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:104)
> at
> org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
> at
> org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
> at
> org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
> at
> org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)
> Caused by: org.eclipse.acceleo.engine.AcceleoEvaluationException: The
> type of the first parameter of the main template named 'generate' is a
> proxy.
> at
> org.eclipse.acceleo.engine.service.AcceleoService.doGenerate(AcceleoService.java:566)
> at
> org.eclipse.acceleo.engine.service.AbstractAcceleoGenerator.generate(AbstractAcceleoGenerator.java:193)
> at
> org.eclipse.ocl.examples.build.utilities.OCLMetaModelCodeGenerator.invokeInternal(OCLMetaModelCodeGenerator.java:131)
> at
> org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:126)
> at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.invoke(Mwe2Bridge.java:34)
> at
> org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:201)
> at
> org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
> at
> org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
> at
> org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:19)
> at
> org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
> ... 4 more
>
>
>
> Can you please help me to resolve these errors?
> Thank you
Re: Using OCL MDT sources from git [message #988497 is a reply to message #915536] Fri, 30 November 2012 09:26 Go to previous messageGo to next message
Fi Fi is currently offline Fi FiFriend
Messages: 133
Registered: March 2010
Senior Member
After resolving all dependencies (0 errors Smile ),
I try to edit org.eclipse.ocl.examples.library/model/OCL-2.4.oclstdlib.
when I open it, 689 errors was generated:
Description: Error executing EValidator
Resource: OCL-2.4.oclstdlib
Path: /org.eclipse.ocl.examples.library/model
Location: /org.eclipse.ocl.examples.library/model/OCL-2.4.oclstdlib
Type: Xtext Check (fast)

Do you know what I should do Please?

Best regards,
Fy Za
Re: Using OCL MDT sources from git [message #988532 is a reply to message #988497] Fri, 30 November 2012 11:40 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

make sure you edit OCL-2.4.oclstdlib with the workspace OCLstdlib
editor, not the Juno editor that you may have installed.

i.e. edit it in a nested workspac.

Regards

Ed Willink


On 30/11/2012 09:26, Fy Za wrote:
> After resolving all dependencies (0 errors :) ),
> I try to edit org.eclipse.ocl.examples.library/model/OCL-2.4.oclstdlib.
> when I open it, 689 errors was generated:
> Description: Error executing EValidator
> Resource: OCL-2.4.oclstdlib
> Path: /org.eclipse.ocl.examples.library/model
> Location: /org.eclipse.ocl.examples.library/model/OCL-2.4.oclstdlib
> Type: Xtext Check (fast)
>
> Do you know what I should do Please?
>
> Best regards,
> Fy Za
>
Previous Topic:how to merge two collections
Next Topic:how to access to association end in code
Goto Forum:
  


Current Time: Sat Dec 20 20:23:22 GMT 2014

Powered by FUDForum. Page generated in 0.02025 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software