Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » update to 3.5.0 failed
update to 3.5.0 failed [message #911877] Wed, 12 September 2012 09:51 Go to next message
jacob hameiri is currently offline jacob hameiri
Messages: 13
Registered: June 2012
Junior Member
we are currently using virgo 3.0.1, when updating to 3.5.0 we are getting many exceptions (
Invocation of init method failed; nested exception is  java.lang.IllegalArgumentException: required property 'bundleContext' has not been set
) for every spring osgi:reference

Any idea why ?


Re: update to 3.5.0 failed [message #911953 is a reply to message #911877] Wed, 12 September 2012 12:36 Go to previous messageGo to next message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
Is this occurring in the runtime or tooling (Virgo IDE)?
Re: update to 3.5.0 failed [message #911979 is a reply to message #911953] Wed, 12 September 2012 13:44 Go to previous messageGo to next message
jacob hameiri is currently offline jacob hameiri
Messages: 13
Registered: June 2012
Junior Member
tooling in sts

[Updated on: Wed, 12 September 2012 13:47]

Report message to a moderator

Re: update to 3.5.0 failed [message #912007 is a reply to message #911979] Wed, 12 September 2012 15:17 Go to previous messageGo to next message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
You should open a bug against Virgo Tooling -- with more context. Smile Where you are seeing this exception (console, etc..)

As a general note, these kind of things can always have runtime or tooling as cause. Probably the first thing that folks should do if they see an issue like this in tooling (Eclipse/STS IDE) is attempt to do the same thing in runtime cmd-line (e.g. starting the server..). If you don't see the same problem there, it's probably tooling, if you do, it's runtime. Smile

[Updated on: Wed, 12 September 2012 15:18]

Report message to a moderator

Re: update to 3.5.0 failed [message #912012 is a reply to message #912007] Wed, 12 September 2012 15:32 Go to previous messageGo to next message
jacob hameiri is currently offline jacob hameiri
Messages: 13
Registered: June 2012
Junior Member
happens also at runtime.

2012-09-12 20:54:41.190 ERROR [region-dm-9] o.e.virgo.medic.eventlog.default - Application context creation failure for bundle 'app.configuration' version '3.1.1.1'.
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'dataSource': Invocation of init method failed; nested exception is java.lang.IllegalArgumentException: Required 'bundleContext' property was not set.
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1420) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:291) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:288) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:190) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:563) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:895) ~[na:na]
	at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecutionApplicationContext.access$1600(AbstractDelegatedExecutionApplicationContext.java:60) ~[org.eclipse.gemini.blueprint.core_1.0.0.RELEASE.jar/:1.0.0.RELEASE]
	at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecutionApplicationContext$4.run(AbstractDelegatedExecutionApplicationContext.java:325) ~[org.eclipse.gemini.blueprint.core_1.0.0.RELEASE.jar/:1.0.0.RELEASE]
	at org.eclipse.gemini.blueprint.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85) ~[na:na]
	at org.eclipse.gemini.blueprint.context.support.AbstractDelegatedExecutionApplicationContext.completeRefresh(AbstractDelegatedExecutionApplicationContext.java:290) ~[org.eclipse.gemini.blueprint.core_1.0.0.RELEASE.jar/:1.0.0.RELEASE]
	at org.eclipse.gemini.blueprint.extender.internal.dependencies.startup.DependencyWaiterApplicationContextExecutor$CompleteRefreshTask.run(DependencyWaiterApplicationContextExecutor.java:137) [org.eclipse.gemini.blueprint.extender_1.0.0.RELEASE.jar/:1.0.0.RELEASE]
	at org.eclipse.virgo.kernel.agent.dm.ContextPropagatingTaskExecutor$2.run(ContextPropagatingTaskExecutor.java:95) [org.eclipse.virgo.kernel.agent.dm_3.5.0.RELEASE.jar/:3.5.0.RELEASE]
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [na:1.6.0_32]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [na:1.6.0_32]
	at java.lang.Thread.run(Thread.java:662) [na:1.6.0_32]
Caused by: java.lang.IllegalArgumentException: Required 'bundleContext' property was not set.
	at org.springframework.util.Assert.notNull(Assert.java:112) ~[org.springframework.core_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.osgi.service.importer.support.AbstractOsgiServiceImportFactoryBean.afterPropertiesSet(AbstractOsgiServiceImportFactoryBean.java:79) ~[na:na]
	at org.springframework.osgi.service.importer.support.AbstractServiceImporterProxyFactoryBean.afterPropertiesSet(AbstractServiceImporterProxyFactoryBean.java:52) ~[na:na]
	at org.springframework.osgi.service.importer.support.OsgiServiceProxyFactoryBean.afterPropertiesSet(OsgiServiceProxyFactoryBean.java:118) ~[na:na]
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1477) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1417) ~[org.springframework.beans_3.0.5.RELEASE.jar:3.0.5.RELEASE]
	... 17 common frames omitted


the bean 'dataSource' which fails to init is created via osgi registry:
<osgi:reference id="dataSource" interface="javax.sql.DataSource"/>


this is the manifest:
Manifest-Version: 1.0
Archiver-Version: Plexus Archiver
Created-By: Maven Integration for Eclipse
Built-By: admin
Build-Jdk: 1.6.0_32
Export-Package: app.configuration;version="3.1.1.1";uses:="jav
 ax.annotation,javax.management,org.apache.commons.configuration,org.a
 pache.commons.configuration.event,org.osgi.framework,org.springframew
 ork.beans.factory,org.springframework.beans.factory.annotation,org.sp
 ringframework.jmx.export.annotation,org.springframework.osgi.context,
 org.springframework.stereotype"
Bundle-Vendor: app Sources
Bundle-Version: 3.1.1.1
Tool: Bundlor 1.0.0.RELEASE
Bundle-Name: app Configuration
Bundle-ManifestVersion: 2
Bundle-SymbolicName: app.configuration
Import-Package: javax.annotation,javax.management,javax.management.rem
 ote,javax.management.remote.rmi,javax.security.auth.login,javax.sql,o
 rg.apache.commons.collections,org.apache.commons.configuration,org.ap
 ache.commons.configuration.event,org.apache.commons.configuration.rel
 oading,org.apache.naming.java,org.eclipse.virgo.web.dm;version="[3.0.
 0, 4.0.0)",org.osgi.framework,org.slf4j,org.springframework.beans.fac
 tory,org.springframework.beans.factory.annotation,org.springframework
 .jmx.export.annotation,org.springframework.osgi.context;version="[1.2
 .1,1.3.0)",org.springframework.stereotype



Any idea whats wrong ?
Thanks for you help
Re: update to 3.5.0 failed [message #912461 is a reply to message #912012] Thu, 13 September 2012 12:10 Go to previous message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
Hi Jacob,

Sorry, this one is outside of my area of expertise. Perhaps someone from Runtime has ideas? Have you tried it with other runtime targets, e.g. 3.5.0?

Miles
Previous Topic:default web.xml in virgo 3.5.0
Next Topic:Using same PersistenceUnit across bundles
Goto Forum:
  


Current Time: Fri Aug 22 10:00:54 EDT 2014

Powered by FUDForum. Page generated in 0.01813 seconds