Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » Problems with targetNamespace(Value of targetNamespace not valid)
Problems with targetNamespace [message #910688] Mon, 10 September 2012 08:12 Go to next message
paco gutierrez is currently offline paco gutierrezFriend
Messages: 7
Registered: September 2012
Junior Member
Hello,


I'n new in BPMN and ATL and I begin working with ATL transformations from BPMN 2.0 to other languages.
I've problems when I run the transformations.
I've an error in the XMI file of the model: "value of TargetNamespace is not legal".
I've tested with several (normally corrects) values and I've always the same error.
I think that's would be related with the issue (16398) in www.omg.org/issues/bpmn2-rtf.open.html:


Issue 16398: XML Schema not valid (bpmn2-rtf)

Nature: Clarification
Severity: Significant
Summary:
The official XML Schema for BPMN 2.0 (www.omg.org/spec/BPMN/20100501/BPMN20.xsd) is not valid.


- It imports a schema with the schemaLocation "www.omg.org/spec/BPMN/20100501/Diagram Interchange.xsd", which does not exist.
Even when using the correct schemaLocation of "www.omg.org/spec/BPMN/20100501/DI.xsd", the namespace does not match (www.omg.com/di/1.0.0 vs. www.omg.org/spec/DD/20100524/DI)
(Note that one uses "omg.com" and the other uses "omg.org".)


- It includes the Schema "www.omg.org/spec/BPMN/20100501/Semantic.xsd", but its targetNamespace www.omg.org/spec/BPMN/20100524/MODEL does not match the including schema's value.



- The website www.omg.org/spec/BPMN/2.0/ has missmatching links for several items:
-- "www.omg.org/spec/BPMN/20100501/DI.xsd" links to "www.omg.org/spec/BPMN/20100501/BPMNDI.xsd"
-- "www.omg.org/spec/BPMN/20100501/Semantic.xsd" links to " www.omg.org/spec/BPMN/20100501/BPMNDI.xsd"


Resolution:
Revised Text:
Actions taken:
July 28, 2011: received issue



I've send a comment on this issue to bpmn2-rtf@omg.org like it's suggested in the site refered above, but no reply still.


Anyone knows if there is a solution for the problem related with this issue or if it's other the problem I have?


Thanks in advance.


Paco.
Re: Problems with targetNamespace [message #910865 is a reply to message #910688] Mon, 10 September 2012 14:24 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo BruneliereFriend
Messages: 612
Registered: July 2009
Senior Member
Hello,

Which BPMN2 metamodel implementation are you using? The one from the MDT-BPMN2 project?

In any case, before any transformation or further handling, you should first check that your input BPMN model is valid by trying to open it with the Sample Reflective Ecore Model Editor for instance.

Best regards,

Hugo


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: Problems with targetNamespace [message #911367 is a reply to message #910865] Tue, 11 September 2012 13:05 Go to previous messageGo to next message
paco gutierrez is currently offline paco gutierrezFriend
Messages: 7
Registered: September 2012
Junior Member
Glubs!
Sorry.


I'm new with MDT, ATL, XMI, ...
I don't think to open the file with this editor.
When I do I get:

org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri 'www.omg.org/spec/BPMN/20100524/MODEL-XMI' not found.



Thanks.
Re: Problems with targetNamespace [message #911372 is a reply to message #911367] Tue, 11 September 2012 13:16 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo BruneliereFriend
Messages: 612
Registered: July 2009
Senior Member
Hello,

No problem Smile

It seems that your input (BPMN) model refers to a (BPMN) metamodel that is not registered in the EMF Registry (i.e. the metamodel registry of your Eclipse instance).
So this model cannot be loaded in memory and then handled by any EMF-based tool.

Is your model actually an EMF model?
Anyway, you first have to make sure that the metamodel you're using (an Ecore file if serialized) is already loaded in this EMF Registry...

I do think your problem is more related to the use of EMF in general, and I encourage you to post your problem directly on the EMF forum.
I hope this will help.

Best regards,

Hugo


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: Problems with targetNamespace [message #911784 is a reply to message #911372] Wed, 12 September 2012 10:08 Go to previous message
paco gutierrez is currently offline paco gutierrezFriend
Messages: 7
Registered: September 2012
Junior Member
Thanks Hugo.


I'll do that.
Previous Topic:Troubles with ATL API
Next Topic:ATL plugin with two IN metamodels
Goto Forum:
  


Current Time: Fri Nov 28 06:13:36 GMT 2014

Powered by FUDForum. Page generated in 0.01740 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software