Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Exception occured while launching eclipse using Agent Controller
Exception occured while launching eclipse using Agent Controller [message #121674] Fri, 01 February 2008 03:51 Go to next message
Eclipse User
Originally posted by: swati_gkd.rediffmail.com

Hello all,

I have following setup:
Eclipse 3.3.0
TPTP 4.4.0
Agent Controller 4.4
I have a set of testcases which are recorded on eclipse
perspective and wanted to use for testing on all platforms using remote
execution. The deployment files are used for remote launching.

When I try to launch the test cases on remote machine (Windows)
from local (Windows) machine it is successful. Launch and test execution
successfully works.
When I try to launch the same set of tests to remote (Linux)
machine, A process for launching remote application starts and continues,
eclipse process also starts and immediately stops. The exception to the
local machine is:

org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException

This is because, the eclipse startup process at remote machine is not
running.
(The ECLIPSE_STARTUP_PATH is the property with the eclipse location of
remote machine and is mentioned in the deployment location) Agent
Controller to remote Linux is up and running. The launching and Deploying
process hangs at 36%.

What can be the reason and solution to overcome this problem.
Please let me know the solution ASAP, If anything is missing.
Thanks in advanced.


Thanks and Regards,
Swati
Re: Exception occured while launching eclipse using Agent Controller [message #121974 is a reply to message #121674] Mon, 04 February 2008 12:50 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Swati,
I believe you are experiencing the inverse of
https://bugs.eclipse.org/bugs/show_bug.cgi?id=214792 (XP -> Linux). Can you
download the latest TPTP 4.5.0 driver (workbench and Agent Controller) and
try your scenario?

In addition, your workbench location file (*.location) must contain
paths and flags (e.g.-nl) for the target platform and not the local
platform. The wizard for creating a workbench location using the latest
TPTP 4.5.0 driver allows the user to specify these flags for the target
platform.

Paul
"Swati" <swati_gkd@rediffmail.com> wrote in message
news:0a73a0c7399e9fc930a0f0dbfb2df405$1@www.eclipse.org...
> Hello all,
>
> I have following setup:
> Eclipse 3.3.0
> TPTP 4.4.0 Agent Controller 4.4
> I have a set of testcases which are recorded on eclipse perspective
> and wanted to use for testing on all platforms using remote execution. The
> deployment files are used for remote launching.
>
> When I try to launch the test cases on remote machine (Windows)
> from local (Windows) machine it is successful. Launch and test execution
> successfully works. When I try to launch the same set of tests to remote
> (Linux) machine, A process for launching remote application starts and
> continues, eclipse process also starts and immediately stops. The
> exception to the local machine is:
>
> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
>
> This is because, the eclipse startup process at remote machine is not
> running.
> (The ECLIPSE_STARTUP_PATH is the property with the eclipse location of
> remote machine and is mentioned in the deployment location) Agent
> Controller to remote Linux is up and running. The launching and Deploying
> process hangs at 36%.
>
> What can be the reason and solution to overcome this problem.
> Please let me know the solution ASAP, If anything is missing.
> Thanks in advanced.
> Thanks and Regards,
> Swati
>
Previous Topic:TPTP Profiler GUI component re-use
Next Topic:Is TPTP AGR capable of performing GUI (functional) Tests on RCP apps?
Goto Forum:
  


Current Time: Thu Apr 17 14:35:55 EDT 2014

Powered by FUDForum. Page generated in 0.01540 seconds