Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Unable to invoke JUnit tests (org.eclipse.hyades.internal.execution.local.control.InactiveProcessExc
Unable to invoke JUnit tests (org.eclipse.hyades.internal.execution.local.control.InactiveProcessExc [message #120985] Thu, 17 January 2008 03:08 Go to next message
Stefan Holzknecht is currently offline Stefan Holzknecht
Messages: 31
Registered: July 2009
Member
Hello,
I'm trying to execute JUnit tests as TPTP test. I'm using the internal
Agent Controller with tptp 4.4.0.3 along with eclipse 3.3.1.
But performing tests fails with an exception:
java.lang.RuntimeException:
org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
at
org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.handleException(TestExecutionHarnessExecutorStub.j ava:347)
at
org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:434)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:2098)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1830)
at
org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:750)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by:
org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
at
org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:422)
... 4 more

!ENTRY org.eclipse.hyades.test.core 4 0 2008-01-17 08:56:22.151
!MESSAGE IWAT4039E The Test Execution Harness reported the following
problems:org.eclipse.hyades.internal.execution.local.control .InactiveProcessException

During a debug session I figured out that
TestExecutionHarnessExecutorStub.waitForProcess() is being called with a
process id -1, which does not exist. Has someone experienced a similar
problem? How can I fix that?
Kind regards,
Stefan
Re: Unable to invoke JUnit tests (org.eclipse.hyades.internal.execution.local.control.InactiveProces [message #121005 is a reply to message #120985] Thu, 17 January 2008 06:46 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Stefan,
Are you converting the JUnit test classes to TPTP JUnit test suites
before running them? Also, how did you install TPTP 4.4.0.3, from a ZIP or
through Update Manager?

Paul
"Stefan Holzknecht" <s.holzknecht@intershop.de> wrote in message
news:fmn2dq$5ot$1@build.eclipse.org...
> Hello,
> I'm trying to execute JUnit tests as TPTP test. I'm using the internal
> Agent Controller with tptp 4.4.0.3 along with eclipse 3.3.1.
> But performing tests fails with an exception:
> java.lang.RuntimeException:
> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.handleException(TestExecutionHarnessExecutorStub.j ava:347)
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:434)
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:2098)
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1830)
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:750)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
> Caused by:
> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
> at
> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:422)
> ... 4 more
>
> !ENTRY org.eclipse.hyades.test.core 4 0 2008-01-17 08:56:22.151
> !MESSAGE IWAT4039E The Test Execution Harness reported the following
> problems:org.eclipse.hyades.internal.execution.local.control .InactiveProcessException
>
> During a debug session I figured out that
> TestExecutionHarnessExecutorStub.waitForProcess() is being called with a
> process id -1, which does not exist. Has someone experienced a similar
> problem? How can I fix that?
> Kind regards,
> Stefan
Re: Unable to invoke JUnit tests (org.eclipse.hyades.internal.execution.local.control.InactiveProces [message #121013 is a reply to message #121005] Thu, 17 January 2008 07:26 Go to previous messageGo to next message
Stefan Holzknecht is currently offline Stefan Holzknecht
Messages: 31
Registered: July 2009
Member
Hi Paul,
I installed it from the ZIP file. The problem occures for 'Regular JUnit
Test's as well as for 'TPTP JUnit Test's. Actually I was able to run
tests, but when the problem occured it doesn't went away, even restarts,
or removing the deployment area did not help. Have you any hints what
I should check or verify? Are there some log files that might be
helpfull (does
eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4.1. v200709261752\agent_controller\config\servicelog.log
provide regarding information)?
Stefan

Paul Slauenwhite wrote:
> Hi Stefan,
> Are you converting the JUnit test classes to TPTP JUnit test suites
> before running them? Also, how did you install TPTP 4.4.0.3, from a ZIP or
> through Update Manager?
>
> Paul
> "Stefan Holzknecht" <s.holzknecht@intershop.de> wrote in message
> news:fmn2dq$5ot$1@build.eclipse.org...
>> Hello,
>> I'm trying to execute JUnit tests as TPTP test. I'm using the internal
>> Agent Controller with tptp 4.4.0.3 along with eclipse 3.3.1.
>> But performing tests fails with an exception:
>> java.lang.RuntimeException:
>> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
>> at
>> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.handleException(TestExecutionHarnessExecutorStub.j ava:347)
>> at
>> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:434)
>> at
>> org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:2098)
>> at
>> org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1830)
>> at
>> org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:750)
>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>> Caused by:
>> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
>> at
>> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:422)
>> ... 4 more
>>
>> !ENTRY org.eclipse.hyades.test.core 4 0 2008-01-17 08:56:22.151
>> !MESSAGE IWAT4039E The Test Execution Harness reported the following
>> problems:org.eclipse.hyades.internal.execution.local.control .InactiveProcessException
>>
>> During a debug session I figured out that
>> TestExecutionHarnessExecutorStub.waitForProcess() is being called with a
>> process id -1, which does not exist. Has someone experienced a similar
>> problem? How can I fix that?
>> Kind regards,
>> Stefan
>
>
Re: Unable to invoke JUnit tests (org.eclipse.hyades.internal.execution.local.control.InactiveProces [message #121022 is a reply to message #121013] Fri, 18 January 2008 06:33 Go to previous message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Stefan,
Very strange. This behavior is usually caused by a bad test deployment,
usually not an issue when running a regular JUnit test suite. Can you
attach the following:

-IAC servicelog.log
-Eclipse .log
-Test suite
-Deployment files (*.deployment, *.artifact, *.location).

In the meantime, can you try with the stand-alone Agent Controller?

Paul
"Stefan Holzknecht" <s.holzknecht@intershop.de> wrote in message
news:fmnhh6$a4p$1@build.eclipse.org...
> Hi Paul,
> I installed it from the ZIP file. The problem occures for 'Regular JUnit
> Test's as well as for 'TPTP JUnit Test's. Actually I was able to run
> tests, but when the problem occured it doesn't went away, even restarts,
> or removing the deployment area did not help. Have you any hints what I
> should check or verify? Are there some log files that might be helpfull
> (does
> eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4.1. v200709261752\agent_controller\config\servicelog.log
> provide regarding information)?
> Stefan
>
> Paul Slauenwhite wrote:
>> Hi Stefan,
>> Are you converting the JUnit test classes to TPTP JUnit test suites
>> before running them? Also, how did you install TPTP 4.4.0.3, from a ZIP
>> or through Update Manager?
>>
>> Paul
>> "Stefan Holzknecht" <s.holzknecht@intershop.de> wrote in message
>> news:fmn2dq$5ot$1@build.eclipse.org...
>>> Hello,
>>> I'm trying to execute JUnit tests as TPTP test. I'm using the internal
>>> Agent Controller with tptp 4.4.0.3 along with eclipse 3.3.1.
>>> But performing tests fails with an exception:
>>> java.lang.RuntimeException:
>>> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
>>> at
>>> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.handleException(TestExecutionHarnessExecutorStub.j ava:347)
>>> at
>>> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:434)
>>> at
>>> org.eclipse.hyades.execution.harness.TestExecutionHarness.la unchTestExecution(TestExecutionHarness.java:2098)
>>> at
>>> org.eclipse.hyades.execution.harness.TestExecutionHarness.ac cess$2(TestExecutionHarness.java:1830)
>>> at
>>> org.eclipse.hyades.execution.harness.TestExecutionHarness$2. run(TestExecutionHarness.java:750)
>>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>>> Caused by:
>>> org.eclipse.hyades.internal.execution.local.control.Inactive ProcessException
>>> at
>>> org.eclipse.hyades.execution.harness.TestExecutionHarnessExe cutorStub.launch(TestExecutionHarnessExecutorStub.java:422)
>>> ... 4 more
>>>
>>> !ENTRY org.eclipse.hyades.test.core 4 0 2008-01-17 08:56:22.151
>>> !MESSAGE IWAT4039E The Test Execution Harness reported the following
>>> problems:org.eclipse.hyades.internal.execution.local.control .InactiveProcessException
>>>
>>> During a debug session I figured out that
>>> TestExecutionHarnessExecutorStub.waitForProcess() is being called with a
>>> process id -1, which does not exist. Has someone experienced a similar
>>> problem? How can I fix that?
>>> Kind regards,
>>> Stefan
>>
Previous Topic:Unable to profile using Agent Controller
Next Topic:How to know full list of TPTP Profiler features.
Goto Forum:
  


Current Time: Sat Apr 19 00:22:47 EDT 2014

Powered by FUDForum. Page generated in 0.01572 seconds