Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » SashForm not adapting to High Contrast Theme(When Windows theme is changed to High Contrast theme, Sash Form doesnot adapt to the color themes)
icon4.gif  SashForm not adapting to High Contrast Theme [message #907018] Mon, 03 September 2012 02:48
Animesh Kumar is currently offline Animesh Kumar
Messages: 79
Registered: September 2010
Location: Bangalore
Member
Hi All,

I am facing some issues when using the High Contrast Theme of Windows 7.

When I change my Windows Theme to High Contrast Black in Windows 7 and restart my workbench, my editor comes as shown in the Image Below:-

index.php/fa/11364/0/

Here the other parts are adapting to High Contrast theme, but the SashForm Part which actually contains the tree part is not adapting to the theme. It still comes as white.
Since, the background as well as the font are both white, nothing is readable till it is selected.

Why is SashForm Not able to adapt to the theme?
Do I have to add some code to handle the theme changes? I haven't added anything specific to handle any theme changes.
  • Attachment: Issue.png
    (Size: 31.58KB, Downloaded 521 times)


Regards,
Animesh
Previous Topic:Image getting shrinked/expanded
Next Topic:How to listen to a IFrame selection object within a Browser
Goto Forum:
  


Current Time: Sat Aug 23 11:33:45 EDT 2014

Powered by FUDForum. Page generated in 0.04301 seconds