Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse failse to start after updating plugins(Eclipse fails to start and gives "Missing required bundle org.eclipse.jdt_0.0.0" in logs)
Eclipse failse to start after updating plugins [message #906402] Sat, 01 September 2012 11:01 Go to next message
Vishal trivedi is currently offline Vishal trivediFriend
Messages: 2
Registered: September 2012
Junior Member
Hello ,

I am an android developer and when i started eclipse today all my projects showed error in Project Explorer.

I tried cleaning the project and building again but all in vain.So i decided may be updating all plugins might solve problem.

However when I updated Eclipse asked me to restart which I did. But after that Eclipse failed to start and showed a dialog saying that logs and stored in configuration folder.

On searching on web i found two solutions to similar problem which I tried.
1. Removing file epp.package.jee_272fc75c0020_74cb291dc405 from Temp
2. updating eclipse-jee-indigo-SR1-win32\eclipse\configuration\.settings\org.eclipse.ui.ide.prefs with changing SHOW_WORKSPACE_SELECTION_DIALOG=true from false.

This is the part of log that I think might be the issue
!ENTRY org.eclipse.osgi 2 0 2012-09-01 12:37:48.757
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-09-01 12:37:48.757
!MESSAGE Bundle reference:file:plugins/org.eclipse.jst.j2ee.ejb.annotations.xdoclet_1.2.200.v201103302125.jar was not resolved.
!SUBENTRY 2 org.eclipse.jst.j2ee.ejb.annotations.xdoclet 2 0 2012-09-01 12:37:48.757
!MESSAGE Missing required bundle org.eclipse.jdt_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-09-01 12:37:48.758
!MESSAGE Bundle reference:file:plugins/com.android.ide.eclipse.adt_20.0.3.v201208082019-427395.jar was not resolved.
!SUBENTRY 2 com.android.ide.eclipse.adt 2 0 2012-09-01 12:37:48.758
!MESSAGE Missing required bundle org.eclipse.jdt_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2012-09-01 12:37:48.769
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-09-01 12:37:48.769
!MESSAGE Bundle org.eclipse.jst.j2ee.ejb.annotations.xdoclet_1.2.200.v201103302125 [391] was not resolved.
!SUBENTRY 2 org.eclipse.jst.j2ee.ejb.annotations.xdoclet 2 0 2012-09-01 12:37:48.769
!MESSAGE Missing required bundle org.eclipse.jdt_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-09-01 12:37:48.769
!MESSAGE Bundle org.eclipse.jst.j2ee.xdoclet.runtime_1.1.300.v201004280700 [400] was not resolved.
!SUBENTRY 2 org.eclipse.jst.j2ee.xdoclet.runtime 2 0 2012-09-01 12:37:48.769
!MESSAGE Missing required bundle org.eclipse.jst.j2ee.ejb.annotations.xdoclet_[1.1.0,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-09-01 12:37:48.769
!MESSAGE Bundle com.android.ide.eclipse.adt_20.0.3.v201208082019-427395 [836] was not resolved.
!SUBENTRY 2 com.android.ide.eclipse.adt 2 0 2012-09-01 12:37:48.769
!MESSAGE Missing required bundle org.eclipse.jdt_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-09-01 12:37:48.769
!MESSAGE Bundle overlay.com.android.ide.eclipse.adt.overlay_20.0.3.v201208082019-427395 [839] was not resolved.
!SUBENTRY 2 overlay.com.android.ide.eclipse.adt.overlay 2 0 2012-09-01 12:37:48.769
!MESSAGE Missing required bundle com.android.ide.eclipse.adt_0.0.0.



I have attached the log file. I had this problem earlier as well but that time I had re-installed Eclipse and Android Plugin but that is not the solution
Re: Eclipse failse to start after updating plugins [message #906437 is a reply to message #906402] Sat, 01 September 2012 13:31 Go to previous messageGo to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1034
Registered: July 2009
Senior Member
The first exception in your logs looks severe:

Caused by: java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError


After seeing this you shouldn't expect anything to work ...

I have no idea what brought you into that state.

Assuming that it would require tremendous efforts trying to reproduce what happened, I suggest: just re-install Eclipse.

best,
Stephan
Re: Eclipse failse to start after updating plugins [message #906530 is a reply to message #906437] Sat, 01 September 2012 19:42 Go to previous message
Vishal trivedi is currently offline Vishal trivediFriend
Messages: 2
Registered: September 2012
Junior Member
Yes was expecting this....
but then how can i have all my present android and other plugins...
how can i configure that...

what i really feel about he issue is that update might have messed up with configs or settings.
can you help me what files does the update process alters...
Previous Topic:mpiJava not building in eclipse - noob
Next Topic:Getting the JDT source code integrated into Eclipse
Goto Forum:
  


Current Time: Mon Nov 24 06:59:48 GMT 2014

Powered by FUDForum. Page generated in 0.02332 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software