Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Additional errors when I click on a source file
Additional errors when I click on a source file [message #905508] Thu, 30 August 2012 14:20 Go to next message
Raheleh N is currently offline Raheleh N
Messages: 6
Registered: August 2012
Junior Member
When i compile a project in eclipse i receive a number of errors. But when i click on individual files in the Project Explorer tab, each file shows more errors and those errors become added to the list of problems.
I appreciate if anyone can tell me the reason and the way i can get rid of them.
tnx.
Re: Additional errors when I click on a source file [message #905513 is a reply to message #905508] Thu, 30 August 2012 14:23 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
The problems that show in the Problems View depend on things like
filters and what you choose to show (via the little triangle in the
right corner of the view. In the end, you get rid of errors by fixing
them, not just by not showing them.

On 30/08/2012 4:20 PM, Raheleh N wrote:
> When i compile a project in eclipse i receive a number of errors. But
> when i click on individual files in the Project Explorer tab, each
> file shows more errors and those errors become added to the list of
> problems. I appreciate if anyone can tell me the reason and the way i
> can get rid of them. tnx.
Re: Additional errors when I click on a source file [message #905515 is a reply to message #905513] Thu, 30 August 2012 14:32 Go to previous messageGo to next message
Raheleh N is currently offline Raheleh N
Messages: 6
Registered: August 2012
Junior Member
Thanks a lot for your quick reply.
my "configure content" item on the triangle list says that it shows errors for all items. so i still wonder why it doesn't show all the errors at once. it seems i have to go through each file individually and see if there is more error.
tnx a lot.
Re: Additional errors when I click on a source file [message #905524 is a reply to message #905515] Thu, 30 August 2012 14:55 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
Comments below.

On 30/08/2012 4:32 PM, Raheleh N wrote:
> Thanks a lot for your quick reply.
> my "configure content" item on the triangle list says that it shows
> errors for all items.
You're saying "Show All" is check marked? That would normally show all
problems independent of any selection. It does for me.
> so i still wonder why it doesn't show all the errors at once. it seems
> i have to go through each file individually and see if there is more
> error. tnx a lot.
Re: Additional errors when I click on a source file [message #905526 is a reply to message #905524] Thu, 30 August 2012 15:00 Go to previous messageGo to next message
Raheleh N is currently offline Raheleh N
Messages: 6
Registered: August 2012
Junior Member
Thant's correct. Now i select all the items in the "configure contents" section individually and everything seems fine.
thanks a lot for your replies.
Re: Additional errors when I click on a source file [message #905682 is a reply to message #905524] Thu, 30 August 2012 21:54 Go to previous messageGo to next message
Raheleh N is currently offline Raheleh N
Messages: 6
Registered: August 2012
Junior Member
Sorry to bother again, but the problem is still there, I tried every combinations of showing errors but still when I compile everything looks fine, but when i click on individual links new errors show up in the problems tab.
Does anyone have a solution? tnx

[Updated on: Thu, 30 August 2012 21:55]

Report message to a moderator

Re: Additional errors when I click on a source file [message #905777 is a reply to message #905682] Fri, 31 August 2012 04:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
What kind of errors?  Are these JDT's Java errors?   Does your
Configure Contents look like this?  I.e., you're showing everything
for any element?<br>
<blockquote><img src="http://www.eclipse.org/forums/index.php?t=getfile&amp;id=11335" alt=""><br>
</blockquote>
<br>
<div class="moz-cite-prefix">On 30/08/2012 11:54 PM, Raheleh N
wrote:<br>
</div>
<blockquote cite="mid:k1onfg$hdb$1@xxxxxxxxe.org" type="cite">Sorry
to bother again, but the problem is still there, I tried every
combinations of showing errors but still when I compile everything
looks fine, but when i click on individual links new errors show
up in the problems tab.
<br>
Does anyone has a solution? tnx
<br>
</blockquote>
<br>
</body>
</html>
  • Attachment: haebbbed.png
    (Size: 58.17KB, Downloaded 58 times)
Re: Additional errors when I click on a source file [message #905779 is a reply to message #905682] Fri, 31 August 2012 04:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
What kind of errors?  Are these JDT's Java errors?   Does your
Configure Contents look like this?  I.e., you're showing everything
for any element?<br>
<blockquote><img src="http://www.eclipse.org/forums/index.php?t=getfile&amp;id=11336" alt=""><br>
</blockquote>
<br>
<div class="moz-cite-prefix">On 30/08/2012 11:54 PM, Raheleh N
wrote:<br>
</div>
<blockquote cite="mid:k1onfg$hdb$1@xxxxxxxxe.org" type="cite">Sorry
to bother again, but the problem is still there, I tried every
combinations of showing errors but still when I compile everything
looks fine, but when i click on individual links new errors show
up in the problems tab.
<br>
Does anyone has a solution? tnx
<br>
</blockquote>
<br>
</body>
</html>
  • Attachment: haebbbed.png
    (Size: 58.17KB, Downloaded 71 times)
Re: Additional errors when I click on a source file [message #905783 is a reply to message #905682] Fri, 31 August 2012 04:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
What kind of errors?  Are these JDT's Java errors?   Does your
Configure Contents look like this?  I.e., you're showing everything
for any element?<br>
<blockquote><img src="http://www.eclipse.org/forums/index.php?t=getfile&amp;id=11337" alt=""><br>
</blockquote>
<br>
<div class="moz-cite-prefix">On 30/08/2012 11:54 PM, Raheleh N
wrote:<br>
</div>
<blockquote cite="mid:k1onfg$hdb$1@xxxxxxxxe.org" type="cite">Sorry
to bother again, but the problem is still there, I tried every
combinations of showing errors but still when I compile everything
looks fine, but when i click on individual links new errors show
up in the problems tab.
<br>
Does anyone has a solution? tnx
<br>
</blockquote>
<br>
</body>
</html>
  • Attachment: haebbbed.png
    (Size: 58.17KB, Downloaded 65 times)
Re: Additional errors when I click on a source file [message #905785 is a reply to message #905682] Fri, 31 August 2012 04:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
What kind of errors?  Are these JDT's Java errors?   Does your
Configure Contents look like this?  I.e., you're showing everything
for any element?<br>
<blockquote><img src="http://www.eclipse.org/forums/index.php?t=getfile&amp;id=11338" alt=""><br>
</blockquote>
<br>
<div class="moz-cite-prefix">On 30/08/2012 11:54 PM, Raheleh N
wrote:<br>
</div>
<blockquote cite="mid:k1onfg$hdb$1@xxxxxxxxe.org" type="cite">Sorry
to bother again, but the problem is still there, I tried every
combinations of showing errors but still when I compile everything
looks fine, but when i click on individual links new errors show
up in the problems tab.
<br>
Does anyone has a solution? tnx
<br>
</blockquote>
<br>
</body>
</html>
  • Attachment: haebbbed.png
    (Size: 58.17KB, Downloaded 60 times)
Re: Additional errors when I click on a source file [message #905788 is a reply to message #905682] Fri, 31 August 2012 04:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
What kind of errors?  Are these JDT's Java errors?   Does your
Configure Contents look like this?  I.e., you're showing everything
for any element?<br>
<blockquote><img src="http://www.eclipse.org/forums/index.php?t=getfile&amp;id=11339" alt=""><br>
</blockquote>
<br>
<div class="moz-cite-prefix">On 30/08/2012 11:54 PM, Raheleh N
wrote:<br>
</div>
<blockquote cite="mid:k1onfg$hdb$1@xxxxxxxxe.org" type="cite">Sorry
to bother again, but the problem is still there, I tried every
combinations of showing errors but still when I compile everything
looks fine, but when i click on individual links new errors show
up in the problems tab.
<br>
Does anyone has a solution? tnx
<br>
</blockquote>
<br>
</body>
</html>
  • Attachment: haebbbed.png
    (Size: 58.17KB, Downloaded 67 times)
Re: Additional errors when I click on a source file [message #905790 is a reply to message #905682] Fri, 31 August 2012 04:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
What kind of errors?  Are these JDT's Java errors?   Does your
Configure Contents look like this?  I.e., you're showing everything
for any element?<br>
<blockquote><img src="http://www.eclipse.org/forums/index.php?t=getfile&amp;id=11340" alt=""><br>
</blockquote>
<br>
<div class="moz-cite-prefix">On 30/08/2012 11:54 PM, Raheleh N
wrote:<br>
</div>
<blockquote cite="mid:k1onfg$hdb$1@xxxxxxxxe.org" type="cite">Sorry
to bother again, but the problem is still there, I tried every
combinations of showing errors but still when I compile everything
looks fine, but when i click on individual links new errors show
up in the problems tab.
<br>
Does anyone has a solution? tnx
<br>
</blockquote>
<br>
</body>
</html>
  • Attachment: haebbbed.png
    (Size: 58.17KB, Downloaded 58 times)
Re: Additional errors when I click on a source file [message #905792 is a reply to message #905682] Fri, 31 August 2012 04:08 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
<html>
<head>
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
What kind of errors?  Are these JDT's Java errors?   Does your
Configure Contents look like this?  I.e., you're showing everything
for any element?<br>
<blockquote><img src="http://www.eclipse.org/forums/index.php?t=getfile&amp;id=11341" alt=""><br>
</blockquote>
<br>
<div class="moz-cite-prefix">On 30/08/2012 11:54 PM, Raheleh N
wrote:<br>
</div>
<blockquote cite="mid:k1onfg$hdb$1@xxxxxxxxe.org" type="cite">Sorry
to bother again, but the problem is still there, I tried every
combinations of showing errors but still when I compile everything
looks fine, but when i click on individual links new errors show
up in the problems tab.
<br>
Does anyone has a solution? tnx
<br>
</blockquote>
<br>
</body>
</html>
  • Attachment: haebbbed.png
    (Size: 58.17KB, Downloaded 58 times)
Re: Additional errors when I click on a source file [message #905988 is a reply to message #905792] Fri, 31 August 2012 12:24 Go to previous messageGo to next message
Raheleh N is currently offline Raheleh N
Messages: 6
Registered: August 2012
Junior Member
tnx for your reply.
I'm using CDT. The errors are like this:
invalid arguments 'candidates are:...'
although i think based on my definitions the arguments are correct.
The link you sent doesn't open. But in the "configure contents" section I tried "show all items" on any element and on any element in the project and another time tried "show items that match any configuration checked below" and checked all/some of the items.
the problem still persists.
Re: Additional errors when I click on a source file [message #906084 is a reply to message #905988] Fri, 31 August 2012 15:25 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26141
Registered: July 2009
Senior Member
Maybe it's a CDT specific problem. I don't see this problem. What can
I say? There is a CDT forum.

On 31/08/2012 2:24 PM, Raheleh N wrote:
> tnx for your reply.
> I'm using CDT. The errors are like this:
> invalid arguments 'candidates are:...'
> although i think based on my definitions the arguments are correct.
> The link you sent doesn't open. But in the "configure contents"
> section I tried "show all items" on any element and on any element in
> the project and another time tried "show items that match any
> configuration checked below" and checked all/some of the items. the
> problem still persists.
>
Re: Additional errors when I click on a source file [message #906154 is a reply to message #906084] Fri, 31 August 2012 18:28 Go to previous message
Raheleh N is currently offline Raheleh N
Messages: 6
Registered: August 2012
Junior Member
Thanks so much. Then I can probably try the CDT forum.
tnx.

[Updated on: Fri, 31 August 2012 18:28]

Report message to a moderator

Previous Topic:eclipse document in pdf format
Next Topic:Eclipse Aero-Snap like feature not working
Goto Forum:
  


Current Time: Fri Oct 24 14:53:46 GMT 2014

Powered by FUDForum. Page generated in 0.09011 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software