Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Register user-defined ModelSnippet
Register user-defined ModelSnippet [message #903886] Mon, 27 August 2012 06:45
Eclipse UserFriend
Hi all,

I was trying to register a ModelSnippet for the NotationModel in order to
register the very same adapter for the Notation Model as it has been done
for the Uml Model. However, even though the Snippet is registered (i.e. it
is retrieved from the extension registry and associated to the Notation
Model), it is never invoked when the ModelSet starts the associated snippets
for the contained model.

Actually, it is the case that the snippets list for the Notation Model is
empty after the ModelsReader has instantiated it, although it was
successfully retrieved from the extension registry and apparantly loaded.

My plugin.xml looks like this (I'm using 0.8.2 but the way to register a
ModelSnippet has not changed in 0.9.0):

<!-- this works -->

I gave also a second try and registered a MyUmlSnippet in exactly the same
way the default UmlSnippet was registered, with the same, i.e. no, success.
So, is it possible to supplementary register model snippets? As indicated in
the XML snippet, the ModelSetSnippet worked quite well.

Thanks in advance.
Previous Topic:Control/Uncontrol menu of model explorer disappeared in Papyrus 0.9?
Next Topic:Assistance with Reply Action on Activity Diagram
Goto Forum:

Current Time: Sat Nov 28 11:40:59 GMT 2015

Powered by FUDForum. Page generated in 0.01859 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software