Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » SWT and Java 7(SWT and Java 7)
SWT and Java 7 [message #903475] Thu, 23 August 2012 18:55
Erin Ritchie is currently offline Erin Ritchie
Messages: 1
Registered: August 2012
Junior Member
I maintain a Standalone JNLP file application written in Java 1.6 with SWT. We have recently had a large number of users auto-upgrade to Java 1.7. Our application does not run on Java 1.7 and we were looking into our options since some of our users do not have the ability to downgrade back to Java 1.6. The upgrade features on Java 1.7 state they include some upgrades to Graphics and Graphics APIs. From some of the forums I have read, it sounds like AWT was changed which causes issues with SWT.

How much of this is true? If so, are there plans to upgrade SWT to run on Java 1.7? If not, which version of SWT will run on Java 1.7?
Previous Topic:[OLEAutomation]retrieving data from a VT_ARRAY
Next Topic:Is HTML 5 / CSS 3 tags supported by XULRunner Plugin
Goto Forum:
  


Current Time: Thu Oct 02 10:34:17 GMT 2014

Powered by FUDForum. Page generated in 0.02312 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software