Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Installing Papyrus(Conflicting Dependencies )
Installing Papyrus [message #903340] Thu, 23 August 2012 08:49 Go to next message
Natalie Cranston is currently offline Natalie CranstonFriend
Messages: 12
Registered: August 2012
Junior Member
Hello Everyone,

I am trying to install Papyrus for Eclipse Juno 4.2. I keep getting these errors.

Cannot complete the install because of a conflicting dependency.
Software being installed: Papyrus SDK Binaries (Incubation) 0.9.0.v201206131215 (org.eclipse.papyrus.sdk.feature.feature.group 0.9.0.v201206131215)
Software currently installed: Eclipse SDK 3.6.0.I20100608-0911 (org.eclipse.sdk.ide 3.6.0.I20100608-0911)
Only one of the following can be installed at once:
Common Navigator View 3.5.200.v20120523-1955 (org.eclipse.ui.navigator 3.5.200.v20120523-1955)
Common Navigator View 3.5.0.I20100601-0800 (org.eclipse.ui.navigator 3.5.0.I20100601-0800)
Cannot satisfy dependency:
From: Papyrus infra (Incubation) 0.9.0.v201206131215 (org.eclipse.papyrus.infra.feature.feature.group 0.9.0.v201206131215)
To: org.eclipse.papyrus.infra.hyperlink [0.9.0.v201206131215]
Cannot satisfy dependency:
From: Papyrus Hyperlink (Incubation) 0.9.0.v201206131215 (org.eclipse.papyrus.infra.hyperlink 0.9.0.v201206131215)
To: bundle org.eclipse.ui.navigator 3.5.100
Cannot satisfy dependency:
From: Papyrus SDK Binaries (Incubation) 0.9.0.v201206131215 (org.eclipse.papyrus.sdk.feature.feature.group 0.9.0.v201206131215)
To: org.eclipse.papyrus.infra.feature.feature.group [0.9.0.v201206131215]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY (org.eclipse.platform.feature.group 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
To: org.eclipse.ui.navigator [3.5.0.I20100601-0800]
Cannot satisfy dependency:
From: Eclipse Project SDK 3.6.0.v20100427-7Q7m-DPY2dP0s7TnP1vxqsprbrvrHJwHMVz0mb8mhRXmu (org.eclipse.sdk.feature.group 3.6.0.v20100427-7Q7m-DPY2dP0s7TnP1vxqsprbrvrHJwHMVz0mb8mhRXmu)
To: org.eclipse.platform.feature.group [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
Cannot satisfy dependency:
From: Eclipse SDK 3.6.0.I20100608-0911 (org.eclipse.sdk.ide 3.6.0.I20100608-0911)
To: org.eclipse.sdk.feature.group [3.6.0.v20100427-7Q7m-DPY2dP0s7TnP1vxqsprbrvrHJwHMVz0mb8mhRXmu]

Any help would be greatly appreciated!

Natalie
Re: Installing Papyrus [message #903344 is a reply to message #903340] Thu, 23 August 2012 08:58 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 510
Registered: February 2011
Senior Member
Hello Natalie,

Quote:
Software currently installed: Eclipse SDK 3.6.0.I20100608-0911 (org.eclipse.sdk.ide 3.6.0.I20100608-0911)


This line seems strange. Eclipse 3.6.0 is Eclipse Helios, and the "I2010..." means this is an Integration build ; not a release one. This doesn't look like a clean installation on an Eclipse Juno 4.2 platform.

All other errors are just consequences of this problem.

Did you try to install Papyrus on a fresh Eclipse Modeling 4.2 platform?


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Installing Papyrus [message #903346 is a reply to message #903340] Thu, 23 August 2012 08:57 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4187
Registered: July 2009
Senior Member
Hi

On 23/08/2012 09:49, Natalie Cranston wrote:
> I am trying to install Papyrus for Eclipse Juno 4.2. I keep getting
> these errors.
Using Eclipse 4.2 (or 3.8) would be a good idea.
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Papyrus SDK Binaries (Incubation)
> 0.9.0.v201206131215 (org.eclipse.papyrus.sdk.feature.feature.group
> 0.9.0.v201206131215)
> Software currently installed: Eclipse SDK 3.6.0.I20100608-0911
> (org.eclipse.sdk.ide 3.6.0.I20100608-0911)
Clearly you are using Eclipse 3.6.

Regards

Ed Willink
Re: Installing Papyrus [message #903348 is a reply to message #903344] Thu, 23 August 2012 09:07 Go to previous messageGo to next message
Natalie Cranston is currently offline Natalie CranstonFriend
Messages: 12
Registered: August 2012
Junior Member
Ah, I am so sorry for this. I have tried to install the correct Papyrus right now and now I have these errors.

Cannot complete the install because one or more required items could not be found.
Software being installed: MDT Papyrus - Profile Diagram editor (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.diagram.profile.feature.group 0.7.3.v201104270854)
Missing requirement: Papyrus Common Diagram (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.diagram.common 0.7.3.v201104270854) requires 'bundle org.eclipse.gmf.runtime.diagram.ui.actions [1.4.0,2.0.0)' but it could not be found
Cannot satisfy dependency:
From: MDT Papyrus - Profile Diagram editor (Incubation) 0.7.3.v201104270854 (org.eclipse.papyrus.diagram.profile.feature.group 0.7.3.v201104270854)
To: org.eclipse.papyrus.diagram.common 0.7.0

Sorry again, and thanks for your help!
Re: Installing Papyrus [message #903349 is a reply to message #903348] Thu, 23 August 2012 09:12 Go to previous messageGo to next message
Natalie Cranston is currently offline Natalie CranstonFriend
Messages: 12
Registered: August 2012
Junior Member
I guess I should also explain that I do not know how to find these items since I have selected all the items when trying to do an install.
Re: Installing Papyrus [message #903350 is a reply to message #903349] Thu, 23 August 2012 09:16 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 510
Registered: February 2011
Senior Member
Natalie,


Papyrus 0.7.3 is the Helios version of Papyrus. The current version is 0.9.0

The simplest way to install Papyrus for Eclipse Juno (i.e. Papyrus 0.9.0 for Eclipse 4.2.0) is to use the Eclipse Modeling Tools Juno Platform:

http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/junor

And to select "Help", "Install Modeling Components", then check Papyrus.


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Installing Papyrus [message #903375 is a reply to message #903350] Thu, 23 August 2012 11:52 Go to previous message
Natalie Cranston is currently offline Natalie CranstonFriend
Messages: 12
Registered: August 2012
Junior Member
I installed the new Eclipse, and everything has installed! Thank you for your help and patience. I was hesitant to install the new Eclipse because the older version gave me a lot of troubles inititally.

Thanks again, Natalie
Previous Topic:Extending Papyrus - adding a new command to a papyrus menu
Next Topic:Control/Uncontrol menu of model explorer disappeared in Papyrus 0.9?
Goto Forum:
  


Current Time: Fri Dec 19 09:31:22 GMT 2014

Powered by FUDForum. Page generated in 0.02510 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software