Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » config.ini, Exception launching the Eclipse Platform(config.ini, Exception launching the Eclipse Platform)
config.ini, Exception launching the Eclipse Platform [message #903302] Thu, 23 August 2012 00:31 Go to next message
RP Mar is currently offline RP Mar
Messages: 68
Registered: August 2012
Member
I modified my conig.ini file I got below errros.Please I need sample config.ini file
to run my application.Please below is my config.ini file also.
Eclipse Juno IDE,RCP.

!SESSION Thu Aug 23 09:46:39 IST 2012 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2012-08-23 09:46:39.347
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
-------------
my Config.ini file....

#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Tue Aug 21 17:00:42 IST 2012
org.eclipse.update.reconcile=false
eclipse.p2.profile=epp.package.rcp
osgi.instance.area.default=@user.home/workspace
osgi.framework=file\:plugins\\org.eclipse.osgi_3.4.2.R34x_v20080826-1230.jar
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.0.v20080604.jar@1
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator\\bundles.info
equinox.use.ds=true
eclipse.buildId=I20120608-1400
osgi.bundles=org.eclipse.core.commands,
org.eclipse.core.expressions, org.eclipse.help, org.eclipse.jface,
org.eclipse.osgi, org.eclipse.swt.win32, org.eclipse.swt,
org.eclipse.ui.workbench, org.eclipse.ui
osgi.bundles.defaultStartLevel=4
eclipse.p2.data.area=@config.dir/../p2/

Re: config.ini, Exception launching the Eclipse Platform [message #903388 is a reply to message #903302] Thu, 23 August 2012 09:02 Go to previous messageGo to next message
Joseph Carroll is currently offline Joseph Carroll
Messages: 174
Registered: May 2012
Location: Milwaukee, WI
Senior Member

Why are you changing the config.ini file?

If you just need a new file, download your version of eclipse from the downloads page:
http://eclipse.org/download

Otherwise, please post your config file *exactly* as it appears in the config.ini file.

JD
Re: config.ini, Exception launching the Eclipse Platform [message #903509 is a reply to message #903388] Thu, 23 August 2012 23:42 Go to previous message
RP Mar is currently offline RP Mar
Messages: 68
Registered: August 2012
Member
Please I download the new eclipse Juno and run my application below error,below config.ini file please also...

Exception launching the Eclipse Platform:

java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
----------------------
Here is below exact Config.ini file....

#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Thu Jun 14 14:22:50 EDT 2012
org.eclipse.update.reconcile=false
eclipse.p2.profile=epp.package.rcp
osgi.instance.area.default=@user.home/workspace
osgi.framework=file\:plugins/org.eclipse.osgi_3.8.0.v20120529-1548.jar
equinox.use.ds=true
eclipse.buildId=I20120608-1400
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.300.v20110815-1744.jar@1\:start
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.product=org.eclipse.platform.ide
osgi.splashPath=platform\:/base/plugins/org.eclipse.platform
osgi.framework.extensions=
eclipse.application=org.eclipse.ui.ide.workbench
eclipse.p2.data.area=@config.dir/../p2
osgi.bundles.defaultStartLevel=4

Previous Topic:External Image Management in RCP
Next Topic:Eclipse RCP errors
Goto Forum:
  


Current Time: Thu Jul 24 02:27:46 EDT 2014

Powered by FUDForum. Page generated in 0.01986 seconds