Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » orm:delimited-identifiers
orm:delimited-identifiers [message #903170] Wed, 22 August 2012 11:30 Go to next message
Peter Kullmann is currently offline Peter KullmannFriend
Messages: 199
Registered: July 2009
Senior Member
Hi, I upgraded to a new version of texo and was regenerating our orm.xml. I was able to change some settings in the annotations-model in order to get more or less the same orm.xml I had before. One thing is missing, though: The new texo generates
  <orm:persistence-unit-metadata>
    <orm:persistence-unit-defaults>
      <orm:delimited-identifiers/>
    </orm:persistence-unit-defaults>
  </orm:persistence-unit-metadata>

in the beginning. My application does no longer work with that option. How can I tell texo not to generate the delimited-identifiers option?

Thanks & regards,
Peter
Re: orm:delimited-identifiers [message #903292 is a reply to message #903170] Wed, 22 August 2012 21:51 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5343
Registered: July 2009
Senior Member
Hi Peter,
As a default this is always set. I will change it to work with the reserved sql word option.
Can you enter a bugzilla for this?

gr. Martin

On 08/22/2012 01:30 PM, Peter Kullmann wrote:
> Hi, I upgraded to a new version of texo and was regenerating our orm.xml. I was able to change some settings in the
> annotations-model in order to get more or less the same orm.xml I had before. One thing is missing, though: The new texo
> generates
>
> <orm:persistence-unit-metadata>
> <orm:persistence-unit-defaults>
> <orm:delimited-identifiers/>
> </orm:persistence-unit-defaults>
> </orm:persistence-unit-metadata>
>
> in the beginning. My application does no longer work with that option. How can I tell texo not to generate the
> delimited-identifiers option?
>
> Thanks & regards,
> Peter
>


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@xxxxxxxx - mtaal@xxxxxxxx
Web: www.springsite.com - www.elver.org
Re: orm:delimited-identifiers [message #903547 is a reply to message #903292] Fri, 24 August 2012 08:53 Go to previous message
Peter Kullmann is currently offline Peter KullmannFriend
Messages: 199
Registered: July 2009
Senior Member
Here it is: https://bugs.eclipse.org/bugs/show_bug.cgi?id=387954

Greetings,
Peter
Previous Topic:[texo] how to set references in json
Next Topic:[EMF Compare] opening editor programmatically results in unexpected/wrong view
Goto Forum:
  


Current Time: Mon Dec 29 08:53:11 GMT 2014

Powered by FUDForum. Page generated in 0.05001 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software