Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » mwe-file not found building with fornax-tools
mwe-file not found building with fornax-tools [message #903151] Wed, 22 August 2012 09:01 Go to next message
Markus Oley is currently offline Markus Oley
Messages: 253
Registered: July 2009
Location: Germany
Senior Member
Hi to all,

I want to use the fornax-tools to build my xtext-project with tycho.
I have the following projectlayout:

- Build
-- GenerateAllLanguages.mwe
- Project1
- Project2
-- src/vsa/....GenerateLanguage2.mwe
- Project3
- Project4
-- src/vsa/....GenerateLanguage4.mwe

With the following codesnippet I get an error Failed to execute goal org.fornax.toolsupport:fornax-oaw-m2-plugin:3.4.0:run-workflow (default) on project optimo_old: Could not find the Workflow-Descriptor "org/eclipse/xtext/xtextdoc/GenerateXTextDoc.mwe". -> [Help 1]
<!--Plugin to enable mwe2 build-->
    <plugin>
      <groupId>org.fornax.toolsupport</groupId>
        <artifactId>fornax-oaw-m2-plugin</artifactId>
        <version>3.4.0</version>
        <configuration>

          <outletSrcDir>src-gen</outletSrcDir>
          <outletSrcOnceDir>src</outletSrcOnceDir>
          <outletResOnceDir>resources</outletResOnceDir>

          <workflowEngine>mwe</workflowEngine>
          <workflowDescriptor>Build/scriptsGenerateAllLanguages.mwe</workflowDescriptor>
        </configuration>
        <executions>
          <execution>
          <phase>generate-sources</phase>
          <goals><goal>run-workflow</goal></goals>
        </execution>
      </executions>
    </plugin>


I start the build from parentpath of Build.
What do I have to configure to make this run?

Any help welcome

Best regards
Markus

[Updated on: Wed, 22 August 2012 09:02]

Report message to a moderator

Re: mwe-file not found building with fornax-tools [message #904000 is a reply to message #903151] Mon, 27 August 2012 14:28 Go to previous message
Markus Oley is currently offline Markus Oley
Messages: 253
Registered: July 2009
Location: Germany
Senior Member
Hi again,

do you need further informations?
Would be nice to get an answer Smile



Previous Topic:Help Project Wizard
Next Topic:How to create annotations with attributes
Goto Forum:
  


Current Time: Tue Sep 23 02:21:05 GMT 2014

Powered by FUDForum. Page generated in 0.02159 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software