Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Acceleo induced InvalidRegistryObjectException(Problem generating from Acceleo 3.3)
Acceleo induced InvalidRegistryObjectException [message #903019] Tue, 21 August 2012 16:24 Go to next message
Andreas Jakobik is currently offline Andreas JakobikFriend
Messages: 6
Registered: November 2011
Junior Member
Hi,

I'm using RSA 8.0.4/eclipse 3.6 with Xtext 2.3, Atl 3.2 and Acceleo 3.3.

When generating from an Acceleo main template file the exception below is thrown plus a dialog appears saying "Error notifying
registry listener
". Happens all the time in second/runtime RSA on Windows Vista. I have to restart eclipse.

Any idea what is wrong and what can be done to fix it?

Here is the exception:

org.eclipse.core.runtime.InvalidRegistryObjectException: Invalid registry object
	at org.eclipse.core.internal.registry.TemporaryObjectManager.getObject(Unknown Source)
	at org.eclipse.core.internal.registry.BaseExtensionPointHandle.getExtensionPoint(Unknown Source)
	at org.eclipse.core.internal.registry.BaseExtensionPointHandle.getUniqueIdentifier(Unknown Source)
	at org.eclipse.emf.ecore.plugin.RegistryReader$1.registryChanged(Unknown Source)
	at org.eclipse.core.internal.registry.ExtensionRegistry$2.run(Unknown Source)
	at org.eclipse.core.runtime.SafeRunner.run(Unknown Source)
	at org.eclipse.core.internal.registry.ExtensionRegistry.processChangeEvent(Unknown Source)
	at org.eclipse.core.runtime.spi.RegistryStrategy.processChangeEvent(Unknown Source)
	at org.eclipse.core.internal.registry.osgi.ExtensionEventDispatcherJob.run(Unknown Source)
	at org.eclipse.core.internal.jobs.Worker.run(Unknown Source)


There are some questions and bugs on eclipse related to this that may apply:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=324326
https://bugs.eclipse.org/bugs/show_bug.cgi?id=342294

Thanks!

/Andreas

Re: Acceleo induced InvalidRegistryObjectException [message #904405 is a reply to message #903019] Tue, 28 August 2012 11:31 Go to previous messageGo to next message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1638
Registered: July 2009
Senior Member
Hi Andreas,

We have recently fixed a bug regarding this, but unfortunately it is a really hard one to squish. If you can provide us with a workspace on which we can easily reproduce it, please attach it to a bugzilla issue against Acceleo. Other than that, I can't tell you much about this issue except that it is likely due to one of the projects you have open in your test workspace.

Laurent Goubet
Obeo
Re: Acceleo induced InvalidRegistryObjectException [message #905354 is a reply to message #904405] Thu, 30 August 2012 08:16 Go to previous message
Stephane Begaudeau is currently offline Stephane BegaudeauFriend
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

A fix for this issue has been contributed on Acceleo, it will be available in the next maintenance releases of Acceleo.

Regards,

St├ęphane B├ęgaudeau



Previous Topic:[Acceleo] select over a Set(String) object
Next Topic:[Acceleo] problem with primitive types when executed as Java application
Goto Forum:
  


Current Time: Mon Nov 24 15:15:36 GMT 2014

Powered by FUDForum. Page generated in 0.02107 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software