Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO/DAWN] Missing Constraints while trying to reproduce "Getting Started With Dawn Web&
[CDO/DAWN] Missing Constraints while trying to reproduce "Getting Started With Dawn Web& [message #902404] Fri, 17 August 2012 13:46 Go to next message
Juan Pedro Silva is currently offline Juan Pedro Silva
Messages: 258
Registered: July 2009
Senior Member
Hi everybody.
I'm trying to follow the steps in this Dawn Web tutorial.
So far, I have installed all required software (including the external
dependencies), and checkout the sources from the CDO Incubation GIT
repository. The projects build correctly, as all dependencies are satisfied.

I change the cdo-server.xml as required, and run the CDO server. It
starts with no error reports. However, when I try to run the
"DawnHTTPServer.launch", I get a Validation pop-up reporting some
Missing Constraints. In particular, it reports on:

org.eclipse.emf.cdo.dawn.util;bundle-version="[1.0.0,3.0.0)", ->
org.eclipse.emf.cdo.dawn.util 1.0.0.v20110516-1727 installed

org.eclipse.emf.cdo;bundle-version="[4.0.0,5.0.0)",
-> org.eclipse.emf.cdo 4.0.1.v20120214-1021 installed

org.eclipse.emf.cdo.dawn.examples.acore;bundle-version="[1.0.0,2.0.0)",
-> org.eclipse.emf.cdo.dawn.examples.acore 1.0.0.v20110516-1727 installed

org.prototypejs;bundle-version="[1.6.0,2.0.0)"
-> org.prototypejs 1.6.1.201102051638 installed

org.draw2d;bundle-version="0.9.14"
-> org.draw2d 0.9.14.201102051638 installed

Is not a problem of the plugin versions, as I changed the manifest to
take any version, and the problem persisted. The workbench is able to
find the plugins, as it reports no unfulfilled dependencies. I believe
the problem may be the web server not knowing where to look.

The log states:

Command-line arguments: -dev
file:SomePath/dawn_wkspc/.metadata/.plugins/org.eclipse.pde.core/DawnHTTPServer/dev.properties
-os win32 -ws win32 -arch x86 -console

but the DawnHTTPServer folder doesn't exist in
/.metadata/.plugins/org.eclipse.pde.core/, although I'm not really sure
that it is related.

Could you give me some pointers on how to solve this issue?
Thanks in advance.
Regards,
JP
Re: [CDO/DAWN] Missing Constraints while trying to reproduce "Getting Started With Dawn Web [message #902675 is a reply to message #902404] Sun, 19 August 2012 09:52 Go to previous messageGo to next message
Martin Fluegge is currently offline Martin Fluegge
Messages: 141
Registered: July 2009
Senior Member
Hi Juan,


Currently I am on the road and I can't check it myself. I'll try to do
this tomorrow. Meanwhile please check whether there are some missing
requirements from the dawn bundle.

Could you please hit the "validate bundles" button in the lauch config
and check whether something else is missing?

Cheers,

Mart


Am 17.08.2012 15:46, schrieb Juan Pedro Silva Gallino:
> Hi everybody.
> I'm trying to follow the steps in this Dawn Web tutorial.
> So far, I have installed all required software (including the external
> dependencies), and checkout the sources from the CDO Incubation GIT
> repository. The projects build correctly, as all dependencies are
> satisfied.
>
> I change the cdo-server.xml as required, and run the CDO server. It
> starts with no error reports. However, when I try to run the
> "DawnHTTPServer.launch", I get a Validation pop-up reporting some
> Missing Constraints. In particular, it reports on:
>
> org.eclipse.emf.cdo.dawn.util;bundle-version="[1.0.0,3.0.0)", ->
> org.eclipse.emf.cdo.dawn.util 1.0.0.v20110516-1727 installed
>
> org.eclipse.emf.cdo;bundle-version="[4.0.0,5.0.0)",
> -> org.eclipse.emf.cdo 4.0.1.v20120214-1021 installed
>
> org.eclipse.emf.cdo.dawn.examples.acore;bundle-version="[1.0.0,2.0.0)",
> -> org.eclipse.emf.cdo.dawn.examples.acore 1.0.0.v20110516-1727 installed
>
> org.prototypejs;bundle-version="[1.6.0,2.0.0)"
> -> org.prototypejs 1.6.1.201102051638 installed
>
> org.draw2d;bundle-version="0.9.14"
> -> org.draw2d 0.9.14.201102051638 installed
>
> Is not a problem of the plugin versions, as I changed the manifest to
> take any version, and the problem persisted. The workbench is able to
> find the plugins, as it reports no unfulfilled dependencies. I believe
> the problem may be the web server not knowing where to look.
>
> The log states:
>
> Command-line arguments: -dev
> file:SomePath/dawn_wkspc/.metadata/.plugins/org.eclipse.pde.core/DawnHTTPServer/dev.properties
> -os win32 -ws win32 -arch x86 -console
>
> but the DawnHTTPServer folder doesn't exist in
> /.metadata/.plugins/org.eclipse.pde.core/, although I'm not really sure
> that it is related.
>
> Could you give me some pointers on how to solve this issue?
> Thanks in advance.
> Regards,
> JP
Re: [CDO/DAWN] Missing Constraints while trying to reproduce "Getting Started With Dawn Web [message #902677 is a reply to message #902675] Sun, 19 August 2012 12:26 Go to previous message
Juan Pedro Silva is currently offline Juan Pedro Silva
Messages: 258
Registered: July 2009
Senior Member
Martin, thanks for your answer.
I followed your suggestion, and while I was there (in the launch
configuration) I realized that the missing bundles were not selected
among the ones in the target platform. Selecting them there solved the
issue.

Thanks again for your help.
Regards,
Juan Pedro


El 19/08/2012 11:52, Martin Flügge escribió:
> Hi Juan,
>
>
> Currently I am on the road and I can't check it myself. I'll try to do
> this tomorrow. Meanwhile please check whether there are some missing
> requirements from the dawn bundle.
>
> Could you please hit the "validate bundles" button in the lauch config
> and check whether something else is missing?
>
> Cheers,
>
> Mart
>
>
> Am 17.08.2012 15:46, schrieb Juan Pedro Silva Gallino:
>> Hi everybody.
>> I'm trying to follow the steps in this Dawn Web tutorial.
>> So far, I have installed all required software (including the external
>> dependencies), and checkout the sources from the CDO Incubation GIT
>> repository. The projects build correctly, as all dependencies are
>> satisfied.
>>
>> I change the cdo-server.xml as required, and run the CDO server. It
>> starts with no error reports. However, when I try to run the
>> "DawnHTTPServer.launch", I get a Validation pop-up reporting some
>> Missing Constraints. In particular, it reports on:
>>
>> org.eclipse.emf.cdo.dawn.util;bundle-version="[1.0.0,3.0.0)", ->
>> org.eclipse.emf.cdo.dawn.util 1.0.0.v20110516-1727 installed
>>
>> org.eclipse.emf.cdo;bundle-version="[4.0.0,5.0.0)",
>> -> org.eclipse.emf.cdo 4.0.1.v20120214-1021 installed
>>
>> org.eclipse.emf.cdo.dawn.examples.acore;bundle-version="[1.0.0,2.0.0)",
>> -> org.eclipse.emf.cdo.dawn.examples.acore 1.0.0.v20110516-1727 installed
>>
>> org.prototypejs;bundle-version="[1.6.0,2.0.0)"
>> -> org.prototypejs 1.6.1.201102051638 installed
>>
>> org.draw2d;bundle-version="0.9.14"
>> -> org.draw2d 0.9.14.201102051638 installed
>>
>> Is not a problem of the plugin versions, as I changed the manifest to
>> take any version, and the problem persisted. The workbench is able to
>> find the plugins, as it reports no unfulfilled dependencies. I believe
>> the problem may be the web server not knowing where to look.
>>
>> The log states:
>>
>> Command-line arguments: -dev
>> file:SomePath/dawn_wkspc/.metadata/.plugins/org.eclipse.pde.core/DawnHTTPServer/dev.properties
>> -os win32 -ws win32 -arch x86 -console
>>
>> but the DawnHTTPServer folder doesn't exist in
>> /.metadata/.plugins/org.eclipse.pde.core/, although I'm not really sure
>> that it is related.
>>
>> Could you give me some pointers on how to solve this issue?
>> Thanks in advance.
>> Regards,
>> JP
>
Previous Topic:Decimal precision for eStructuralFeatures
Next Topic:EMF with BeanSupport?
Goto Forum:
  


Current Time: Thu Oct 30 13:00:32 GMT 2014

Powered by FUDForum. Page generated in 0.08225 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software