Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » EngineConfig.setFontConfig does not work(EngineConfig.setFontConfig does not work)
EngineConfig.setFontConfig does not work [message #902390] Fri, 17 August 2012 12:36 Go to next message
marie abacan is currently offline marie abacanFriend
Messages: 2
Registered: August 2012
Junior Member
Hello,

Trying to override the fontsConfig.xml using org.eclipse.birt.runtime_3.7.2.v20120214-1408 by using EngineConfig.setFontConfig(URL). However, the custom fontsConfig.xml only works if we delete the other fonts*.xml file inside the birt runtime jar

If we do delete these xml files, is it ok to use the repackaged jar for commercial applications?
Re: EngineConfig.setFontConfig does not work [message #902425 is a reply to message #902390] Fri, 17 August 2012 14:25 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

This should be fine as long as you do not remove the license files.
You also may want to log a bugzilla entry for this.

Jason

On 8/17/2012 8:36 AM, marie abacan wrote:
> Hello,
>
> Trying to override the fontsConfig.xml using
> org.eclipse.birt.runtime_3.7.2.v20120214-1408 by using
> EngineConfig.setFontConfig(URL). However, the custom fontsConfig.xml
> only works if we delete the other fonts*.xml file inside the birt
> runtime jar
>
> If we do delete these xml files, is it ok to use the repackaged jar for
> commercial applications?
Re: EngineConfig.setFontConfig does not work [message #903184 is a reply to message #902425] Wed, 22 August 2012 12:54 Go to previous messageGo to next message
marie abacan is currently offline marie abacanFriend
Messages: 2
Registered: August 2012
Junior Member
Thanks for your reply Jason,

I submitted a bug 387778 for this.
I would also like to clarify - if we delete the orginal fontsConfig files and repackaged the birt runtime jar, then this means we would have to remove the jar signature (related bug - https://bugs.eclipse.org/bugs/show_bug.cgi?id=347431)

Will it be OK to distribute this repackaged jar with our commercial application???

Sorry to repeat the question, but just wanted to make sure we are not violating any license agreement.

Thanks!!!
Re: EngineConfig.setFontConfig does not work [message #903232 is a reply to message #903184] Wed, 22 August 2012 15:31 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

As long as the lic files are in it is ok.
I will get someone on the team to look at the bug.

Jason


On 8/22/2012 8:54 AM, marie abacan wrote:
> Thanks for your reply Jason,
>
> I submitted a bug 387778 for this.
> I would also like to clarify - if we delete the orginal fontsConfig
> files and repackaged the birt runtime jar, then this means we would have
> to remove the jar signature (related bug -
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=347431)
>
> Will it be OK to distribute this repackaged jar with our commercial
> application???
>
> Sorry to repeat the question, but just wanted to make sure we are not
> violating any license agreement.
>
> Thanks!!!
Previous Topic:How can i handle Exception(eg. BirtException) ?
Next Topic:How to keep date time FORMAT in column when exporting from server?
Goto Forum:
  


Current Time: Sun Dec 21 10:45:37 GMT 2014

Powered by FUDForum. Page generated in 0.01679 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software