Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [EMF Validation] Support for Eclipse 3.8?
[EMF Validation] Support for Eclipse 3.8? [message #902194] Thu, 16 August 2012 05:46 Go to next message
Wladimir Schamai is currently offline Wladimir Schamai
Messages: 47
Registered: May 2010
Member
Hi,

does anyone know if there are plans to support EMF Validation in Eclipse 3.8?

regards
Wladimir
Re: [EMF Validation] Support for Eclipse 3.8? [message #902195 is a reply to message #902194] Thu, 16 August 2012 05:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26012
Registered: July 2009
Senior Member
Wladimir,

Anthony is not so likely to answer this question. Sorry...

Did the version range for the Juno version of the validation project
change the lower bound to exclude Eclipse 3.8? (EMF itself expanded the
range for Juno to 3.5 through 4.x.)


On 16/08/2012 11:46 AM, Wladimir Schamai wrote:
> Hi,
>
> does anyone know if there are plans to support EMF Validation in
> Eclipse 3.8?
> regards
> Wladimir
Re: [EMF Validation] Support for Eclipse 3.8? [message #902224 is a reply to message #902195] Thu, 16 August 2012 08:28 Go to previous messageGo to next message
Wladimir Schamai is currently offline Wladimir Schamai
Messages: 47
Registered: May 2010
Member
Hi Ed,

thanks for your reply.

EMF is installed with the 3.8 Modeling Package. However, our plugin that worked in 3.7 doesn't validate anymore in 3.8. I found the statment
Quote:
No support, no testing on 3.8

here http://www.eclipse.org/projects/project-plan.php?projectid=modeling.emf.validation.

That is why I was asking...
Re: [EMF Validation] Support for Eclipse 3.8? [message #902226 is a reply to message #902224] Thu, 16 August 2012 08:38 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26012
Registered: July 2009
Senior Member
Wladimir,

I think that's just saying that if you have a problem that's specific to
Eclipse 3.8 and isn't reproducible in 4.x, it won't be considered a problem.

What specifically do you mean by your plugin doesn't validate? You've
written validation logic using the validation framework and it's no
longer behaving correct?


On 16/08/2012 2:28 PM, Wladimir Schamai wrote:
> Hi Ed,
>
> thanks for your reply.
> EMF is installed with the 3.8 Modeling Package. However, our plugin
> that worked in 3.7 doesn't validate anymore in 3.8. I found the
> statment Quote:
>> No support, no testing on 3.8
>
> here
> http://www.eclipse.org/projects/project-plan.php?projectid=modeling.emf.validation.
>
> That is why I was asking...
Re: [EMF Validation] Support for Eclipse 3.8? [message #902255 is a reply to message #902226] Thu, 16 August 2012 10:54 Go to previous message
Wladimir Schamai is currently offline Wladimir Schamai
Messages: 47
Registered: May 2010
Member
Ed,

finally, I found the bug that got in while migrating to Eclipse 3.8.
It works again!

Sorry and thank you for your time.
Wladimir
Previous Topic:EMF Compare - CompareServices?
Next Topic:XMI Resource to BinaryResourceImpl
Goto Forum:
  


Current Time: Thu Aug 28 05:16:18 EDT 2014

Powered by FUDForum. Page generated in 0.01747 seconds