Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Can't open some e4 classes using JDT/PDE on Eclipse 4.2
Can't open some e4 classes using JDT/PDE on Eclipse 4.2 [message #901876] Tue, 14 August 2012 21:06 Go to next message
Jeff Johnston is currently offline Jeff Johnston
Messages: 175
Registered: July 2009
Senior Member
I am trying to debug a problem whereby a short-cut set for build project does not work when the focus is in an editor (in this case the C/C++ editor).

I was looking at GlobalKeyAssistDialog and it extends KeyAssistDialog. When I try to open KeyAssistDialog which is from org.eclipse.e4.ui.bindings, it doesn't open. I have the jar and it's corresponding source jar in my plug-ins folder and the class exists.

If I try to directly open the class KeyAssistDialog via CTRL+SHIFT+T, it does not show up in the dialog.

I asked a peer to try on his Eclipse and the same behaviour occurred.

Any ideas? Is this a known bug?
Re: Can't open some e4 classes using JDT/PDE on Eclipse 4.2 [message #902265 is a reply to message #901876] Thu, 16 August 2012 16:22 Go to previous message
Jeff Johnston is currently offline Jeff Johnston
Messages: 175
Registered: July 2009
Senior Member
I opened a bug and got a reply. It appears that GlobalKeyAssistDialog is part of a package that is directly required by one of the packages I had checked out in my workspace. However, the org.eclipse.e4.ui.bindings package that it needed is not directly required by any of those packages, so the class details aren't loaded/inspected. Under the Preferences->Plug-in Development main page, there is a check-box to "Include all plug-ins from target in Java search". It's is not on by default. For me, I just set the option on and it started to work. One of my colleagues ran into a problem and we assumed it was because a Target Platform wasn't set up under the Preferences->Plug-in Development->Target Platform page. He set one up to be the default and after a restart, it started to work and KeyAssistDialog was found.
Previous Topic:Relationship between code and architecture
Next Topic:Entry point does not exist error in tomcat
Goto Forum:
  


Current Time: Fri Oct 31 23:07:19 GMT 2014

Powered by FUDForum. Page generated in 0.01678 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software