Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » JavaServer Faces » Problems with editing JSF pages on Juno
Problems with editing JSF pages on Juno [message #901847] Tue, 14 August 2012 14:37 Go to next message
Chris Joelly is currently offline Chris Joelly
Messages: 6
Registered: September 2011
Junior Member
Hello,

i recently upgraded to Juno and i have some annoying problems when editing JSF pages.
The JSF .xhtml files are associated with the "Web Page Editor".

1. performance when working with such files is very poor.
2. then i get an amazing green border around the editor when i focus the editor
(see attached screenshot)
3. keybindings seem to be seriously broken. e.g. Ctrl-C, Ctrl-X, Ctrl-V work
very seldom and i can not find a pattern why. Sometimes they work short time
when i switch between "Design" and "Preview".
_THIS_ is a real productivity killer Smile
(see second screenshot where Ctrl-C and Ctrl-V are deactivated)
The only things i get in the .log file are attached.

Has anybody same issues with editing JSF xhtml pages?




Re: Problems with editing JSF pages on Juno [message #901850 is a reply to message #901847] Tue, 14 August 2012 14:48 Go to previous messageGo to next message
Ian Trimble is currently offline Ian Trimble
Messages: 137
Registered: July 2009
Senior Member
Items 1 and 3 are certainly bug-worthy. You can log bugs against the JSF Tools project here: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Java%20Server%20Faces

Item 2 could be logged as an enhancement request, but the green border is not a bug in itself. It was always there, to differentiate between the different panes that can be displayed by the editor (for example, when you are using split design/source mode) - it just appears to be a little more significant under platform 4.x.

Thanks for your interest,
- Ian
Re: Problems with editing JSF pages on Juno [message #901957 is a reply to message #901850] Wed, 15 August 2012 06:03 Go to previous message
Chris Joelly is currently offline Chris Joelly
Messages: 6
Registered: September 2011
Junior Member
ok. thanks for your reply. for item 1 and two i added reports on Bugzilla:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=387267
https://bugs.eclipse.org/bugs/show_bug.cgi?id=387268

regarding the green border: ok, i just thought it indicates some problem to me. I saw the new UI design after the upgrade to Juno and switched back to the old theme. I assumed it is maybe an artefact of the new theme Smile
Previous Topic:Maven + JSF = ClassNotFoundException - javax.servlet.jsp.jstl.core.Config
Next Topic:Adding jar files to an old JSF project
Goto Forum:
  


Current Time: Wed Aug 20 02:50:16 EDT 2014

Powered by FUDForum. Page generated in 0.01441 seconds