Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Vex » compatibility with older Eclipse/WTP
compatibility with older Eclipse/WTP [message #901807] Tue, 14 August 2012 16:01 Go to next message
Gergely Nagy is currently offline Gergely Nagy
Messages: 6
Registered: August 2012
Junior Member
Dear Vex gurus,
Do you think I have any chance to get it working on a Eclipse 3.6.1 based RCP app?
Thanks for any ideas,
Gergo
Re: compatibility with older Eclipse/WTP [message #901856 is a reply to message #901807] Tue, 14 August 2012 19:08 Go to previous messageGo to next message
Holger Voormann is currently offline Holger Voormann
Messages: 16
Registered: July 2009
Junior Member
Hi Gergo,

Yes, why not? If the current version of Vex/WTP does not work then use an older version of Vex (e.g. Pacx is a RCP application which started with Eclipse 3.4 and an old version of Vex from SourceForge: sourceforge.net/projects/pacx/files/Pacx/).

Best regards,

Holger
Re: compatibility with older Eclipse/WTP [message #901883 is a reply to message #901856] Tue, 14 August 2012 21:24 Go to previous messageGo to next message
Gergely Nagy is currently offline Gergely Nagy
Messages: 6
Registered: August 2012
Junior Member
Thanks Holger
for the prompt response.. I forgot to mention that I'd need XSD support which appears to be a late addition (btw couldn't see it mentioned in the current user guides),
so I guess I might end up fiddling a bit more.
BTW, is the 1.0.0 still planned for the beginning of September?
thanks again,
Gergo
Re: compatibility with older Eclipse/WTP [message #902168 is a reply to message #901883] Thu, 16 August 2012 08:23 Go to previous messageGo to next message
Florian Thienel is currently offline Florian Thienel
Messages: 32
Registered: July 2009
Member
Hi Gergo,

our XSD support is based on WST 1.1.0. Unfortunately I could not find
out what exact version of the Webtools Platform this is. If you have an
RCP, just try to add the required WST bundles to your target platform.
It is very likely that this would work. The rest of Vex is based on
Eclipse 3.4.

Florian

Am 14.08.2012 23:24, schrieb Gergely Nagy:
> Thanks Holger
> for the prompt response.. I forgot to mention that I'd need XSD support
> which appears to be a late addition (btw couldn't see it mentioned in
> the current user guides),
> so I guess I might end up fiddling a bit more. BTW, is the 1.0.0 still
> planned for the beginning of September?
> thanks again,
> Gergo
Re: compatibility with older Eclipse/WTP [message #902308 is a reply to message #902168] Fri, 17 August 2012 00:02 Go to previous messageGo to next message
Gergely Nagy is currently offline Gergely Nagy
Messages: 6
Registered: August 2012
Junior Member
Hi Florian,
I finally got the current master (331829ed0b) working with Eclipse 3.6.1, WTP 3.2.5, EMF/MDT XSD 2.6.1 and few fresh Orbit plugins. Apart from jar/p2 hunting, I needed 2 simple compatibility fixes in VEX UI code, which seemed to rely on Indigo apis.

Thanks a million for your support!
Gergo
Re: compatibility with older Eclipse/WTP [message #902643 is a reply to message #902308] Fri, 17 August 2012 10:38 Go to previous message
Florian Thienel is currently offline Florian Thienel
Messages: 32
Registered: July 2009
Member
Hi Gergo,

could you please file a bug for the Vex UI code which relies on Indigo
APIs? Maybe you also want to contribute the fixes?

Florian

Am 17.08.2012 02:02, schrieb Gergely Nagy:
> Hi Florian,
> I finally got the current master (331829ed0b) working with Eclipse
> 3.6.1, WTP 3.2.5, EMF/MDT XSD 2.6.1 and few fresh Orbit plugins. Apart
> from jar/p2 hunting, I needed 2 simple compatibility fixes in VEX UI
> code, which seemed to rely on Indigo apis.
>
> Thanks a million for your support!
> Gergo
Previous Topic:Cannot edit some attributes in Docbook
Next Topic:embedding VEX editor into a Dialog
Goto Forum:
  


Current Time: Fri Oct 24 15:36:22 GMT 2014

Powered by FUDForum. Page generated in 0.04168 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software