Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Can't get TPTP Profiler working
Can't get TPTP Profiler working [message #119976] Mon, 31 December 2007 20:12 Go to next message
Eclipse UserFriend
Originally posted by: lwang.cclgroup.com

Hi I am trying to get the TPTP profiler working with Java 1.6 on Windows
XP and Eclipse 3.2.2 and I am having trouble getting it working using TPTP
version 4.3.1 and 4.4

For both versions I followed the instructions to install the TPTP plug in
runtime, the new Java profiler and the new agent controller. I run the
SampleClient.exe and it worked fine. The integrated agent controller in
Eclipse is disabled and the Host is set to port 10006 in the Profiling
section.
The JRE is set to version 1.6.

Whenever I try to profile an application using Execution Analysis I get
this error:
One of the selected launch delegate has failed.
org.eclipse.core.runtime.CoreException
An application for the process that was about to be launched is not
registered with the Agent Controller. This can be caused by a missing or
corrupted configuration file.

I have tried searching on Google and this newsgroup and the posts that I
find regarding this error message wasn't able to solve my problem. I am
pretty sure I set up everything right. One thing I did noticed is that in
my AgentControl-4.3 directory (where I installed the new Agent Controller
to) the agents directory's subdirectories' agent.xml specifies an
AgentConfig.xml file to
c:\tptp\agents\org.eclipse.tptp.TimeCollector\config\agentco nfig.xml for
example and I don't have that directory on my C:\ drive. However I can't
find any zip files that install to C:\tptp by default. All the zip files
I downloaded from the download page intalls either to Eclipse or the New
Agent Controller directory.

If anyone can help me on this it would be great! Thanks a lot.
Re: Can't get TPTP Profiler working [message #120018 is a reply to message #119976] Wed, 02 January 2008 23:12 Go to previous message
Eclipse UserFriend
Originally posted by: lwang.cclgroup.com

Hi, I upgraded to Eclipse 3.3 and the problme is solved now.
Previous Topic:stand alone java app profiling : Agent Controller is unavailable under port 10002.
Next Topic:How to user TPTP to find Perm Gen leak?
Goto Forum:
  


Current Time: Sat Dec 20 03:04:38 GMT 2014

Powered by FUDForum. Page generated in 0.02076 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software