Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Eclipse Process Manager (Stardust) » create schema in version 6.0.4 for mysql 5.5.27(create schema don't work in version 6.0.4 for mysql 5.5.27)
create schema in version 6.0.4 for mysql 5.5.27 [message #900626] Tue, 07 August 2012 20:13 Go to next message
Florian Kammermann is currently offline Florian KammermannFriend
Messages: 19
Registered: July 2012
Junior Member
When I tried directly with sysconsole:
bin/ -v -r com.mysql.jdbc.Driver -dbtype MYSQL -dbschema audittrail -l jdbc:mysql://localhost:3306/audittrail -d stardust -s stardust createschema

I got this failure:
Operation could not be performed: Invalid TX isolation level 4, requiring TRANSACTION_READ_COMMITTED (2)

So I generated the ddl manually:
bin/ -v -dbtype MYSQL ddl -file mysql_audittrail.sql -schemaName audittrail

Tried the first line:
CREATE TABLE audittrail.activity_instance (oid BIGINT AUTO_INCREMENT PRIMARY KEY, state INT, startTime BIGINT, lastModificationTime BIGINT, model BIGINT, activity BIGINT, currentPerformer BIGINT, currentUserPerformer BIGINT, performedBy BIGINT, currentDepartment BIGINT, processInstance BIGINT) TYPE=InnoDB;

I got this failure:
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=InnoDB' at line 1

Looks like TYPE=InnoDB is no longer supported:

removed then all the TYPE=InnoDB and it worked

Re: create schema in version 6.0.4 for mysql 5.5.27 [message #901582 is a reply to message #900626] Mon, 13 August 2012 14:14 Go to previous messageGo to next message
Herbert Neureiter is currently offline Herbert NeureiterFriend
Messages: 3
Registered: August 2012
Junior Member
Hi Florian,

you are right: the "TYPE=INNODB" syntax we currently use is no longer supported in the latest mySQL versions and we are aware of this issue. Our current baseline offcially supports and is regressiont tested against mySQL 5.0 and 5.1 only. On these versions, the INNODB Syntax is still valid. We are planning to migrate to more current version of mySQL in Q4 this year and will change our schema definition accordingly.

If you would like to experiment with later versions already now, the best general workaround should be to replace "TYPE=INNODB" with "ENGINE=INNODB" in the ddl script. If you are using mySQL 5.5 or if you are runing mySQL on Windows, just removing the "TYPE=INNODB" will also be fine.

Regardless of all this, the first problem you describe seems to be caused by an improper configuration of your MySQL instance. In any case you should set the mySQL variable tx_isolation to READ-COMMITTED, as otherwise the Stardust engine will not work correctly.


Re: create schema in version 6.0.4 for mysql 5.5.27 [message #902124 is a reply to message #900626] Thu, 16 August 2012 05:13 Go to previous message
Robert Emsbach is currently offline Robert EmsbachFriend
Messages: 186
Registered: October 2011
Location: Singapore
Senior Member

...what Hebert said.

See documentation on MySql setup:

Setting transaction-isolation to READ-COMMITTED:

Configure the %MYSQL_INSTALL%/mysql.ini file, to contain the following entries in the [mysqld] section:
# set basedir to your installation path
# set datadir to the location of your data directory
# set transaction isolation level to read-committed as required by Infinity
transaction-isolation = READ-COMMITTED


Previous Topic:Build the infinity portal
Next Topic:Unable to log in stardust
Goto Forum:

Current Time: Fri Jun 22 05:53:33 GMT 2018

Powered by FUDForum. Page generated in 0.01985 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top