Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Problem in generating Code
Problem in generating Code [message #900333] Mon, 06 August 2012 14:22 Go to next message
Sarath Rachakonda is currently offline Sarath Rachakonda
Messages: 16
Registered: May 2012
Junior Member
Hi Everyone,

Iam trying to generate code for simple GMF model mentioned in ttp://gmfsamples.tuxfamily.org/wiki/doku.php?id=gmf_tutorial1

Iam using eclipse juno (latest stable release - Eclipse Juno (4.2) Package)

When i try to generate diagram code iam getting following error

Problems while generating code
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 77) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 77
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 83) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 83
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 83) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 83
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 19) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 19
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 19) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 19
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 83) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 83
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 77) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 77
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 77) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 77
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 49) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 49
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 49) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 49
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 49) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 49
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18
Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in xpt::plugin::manifest, line 78) while generating code
Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in xpt::plugin::manifest, line 78

Your help is appreciated


Thanks,
Sarath
  • Attachment: file.genmodel
    (Size: 1.51KB, Downloaded 72 times)
  • Attachment: file.gmfgraph
    (Size: 2.44KB, Downloaded 75 times)
  • Attachment: file.gmfmap
    (Size: 2.41KB, Downloaded 70 times)
  • Attachment: file.gmftool
    (Size: 1.52KB, Downloaded 68 times)
  • Attachment: file.gmfgen
    (Size: 15.94KB, Downloaded 75 times)

[Updated on: Tue, 07 August 2012 12:06]

Report message to a moderator

Re: Problem in generating Code [message #900623 is a reply to message #900333] Tue, 07 August 2012 19:59 Go to previous messageGo to next message
Aurelien Pupier is currently offline Aurelien Pupier
Messages: 571
Registered: July 2009
Location: Grenoble, FRANCE
Senior Member

Hi,

Can you check that you are using OCL version shipped with Juno please?
Can you provide your .ecore file?

It seems that you are not using explicitly OCL. Can you confirm it? if you are using it, can you precise where please?

Regards,


Aurélien Pupier - Bonitasoft S.A.
My company Eclipse-related blog
Re: Problem in generating Code [message #900760 is a reply to message #900623] Wed, 08 August 2012 12:19 Go to previous messageGo to next message
Sarath Rachakonda is currently offline Sarath Rachakonda
Messages: 16
Registered: May 2012
Junior Member
Hi Aurelien ,

Iam not using OCL explicitly. Instead i have Updated OCL end user SDK through update site. Even after uninstalling OCL it is showing same error.
Please find the ecore file and list of installed updates in the attachments

Thanks,
Sarath
Re: Problem in generating Code [message #900765 is a reply to message #900760] Wed, 08 August 2012 12:27 Go to previous messageGo to next message
Ralph Gerbig is currently offline Ralph Gerbig
Messages: 697
Registered: November 2009
Senior Member
Hi,

do you have written any OCL constraint somewhere in the mapping model? If yes can you please post it? Your ecore meta-model does not seem to contain OCL.

Ralph
Re: Problem in generating Code [message #900786 is a reply to message #900765] Wed, 08 August 2012 13:27 Go to previous messageGo to next message
Sarath Rachakonda is currently offline Sarath Rachakonda
Messages: 16
Registered: May 2012
Junior Member
Hi Ralph,

I haven't written any OCL constraint

Thanks,
Sarath
Re: Problem in generating Code [message #900814 is a reply to message #900786] Wed, 08 August 2012 15:15 Go to previous messageGo to next message
Andres Alvarez Mattos is currently offline Andres Alvarez Mattos
Messages: 12
Registered: December 2011
Location: Madrid
Junior Member
I´m having the same problem with the last June version. I downloaded the Modeling Tools version.
Re: Problem in generating Code [message #900934 is a reply to message #900814] Thu, 09 August 2012 07:13 Go to previous messageGo to next message
Joel Greenyer is currently offline Joel Greenyer
Messages: 170
Registered: July 2009
Senior Member
Me too. (Juno Modeling Tools, no explicit OCL use in model or graphical mapping.)

Any solutions yet?

Joel

On 08.08.2012 17:15, Andres Alvarez Mattos wrote:
> I´m having the same problem with the last June version. I downloaded the Modeling Tools version.
Re: Problem in generating Code [message #900987 is a reply to message #900934] Thu, 09 August 2012 10:15 Go to previous messageGo to next message
Sarath Rachakonda is currently offline Sarath Rachakonda
Messages: 16
Registered: May 2012
Junior Member
Found Solution. Problem is because of Java version. Once we generate .genModel file we need to set 'Compliance level' in properties of genmodel to 6.0.
Problem is because of 7.0
Re: Problem in generating Code [message #901020 is a reply to message #900987] Thu, 09 August 2012 12:39 Go to previous messageGo to next message
Andres Alvarez Mattos is currently offline Andres Alvarez Mattos
Messages: 12
Registered: December 2011
Location: Madrid
Junior Member
Great, works fine now. Thanks !!
Re: Problem in generating Code [message #1011833 is a reply to message #901020] Wed, 20 February 2013 10:34 Go to previous message
Stephan Schmidt is currently offline Stephan Schmidt
Messages: 1
Registered: February 2013
Location: Berlin, Germany
Junior Member
A coworker and myself experienced this problem independently of each other. Problems like these are very frustrating, as it is nigh impossible to find proper documentation for these issues. At the current stage, it seems the state of the GMF documentation is quite poor. People interested in GMF still learn through the tutorials (which do a good job at introducing to GMF), but then you are on your own.

In my opinion, it would be helpful to have a central location for all documentation - API, Tutorials, Howtos, Explanation of GMFModel file properties (gmfmap, gmfgen, ...). At the moment, the wiki is in a very unorganized state. I don't know if this is due to the migration from an old wiki or what is the issue here - many dead links, empty pages and so on.

Hopefully I don't come across as overly negative here - I am truly thankful for GMF and its contributors, and it is a great tool - if you know what you are doing! But growing the userbase will be difficult if frustrations like this occur, where solutions are found only in newsgroups instead of comprehensive documentation/FAQs.

Best regards,
Stephan
Previous Topic:'diagramLabel' of 'Feature Label Mapping false'
Next Topic:Change generated DiagramFile.gif icon automatically
Goto Forum:
  


Current Time: Mon Oct 20 04:40:51 GMT 2014

Powered by FUDForum. Page generated in 0.02049 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software