Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » eclipse crashes at startup
eclipse crashes at startup [message #900224] Sun, 05 August 2012 19:00 Go to next message
kunal garg is currently offline kunal garg
Messages: 4
Registered: August 2012
Junior Member
I recently installed eclipse 4.2 on my windows xp professional sp3.
whenever i try to run eclipse it crashes back to desktop on startup. It simply shows the eclipse logo for 1 second and then crashes, nothing else happens, no error message or anything.
please help me out.
my specifications are:
1.60 GHz, 504mb ram
i have an integrated intel video card of 128mb

[Updated on: Sun, 05 August 2012 19:02]

Report message to a moderator

Re: eclipse crashes at startup [message #900280 is a reply to message #900224] Mon, 06 August 2012 10:58 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2277
Registered: July 2009
Senior Member
How did you install it? You might also need more memory in your system than that.

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: eclipse crashes at startup [message #900330 is a reply to message #900280] Mon, 06 August 2012 14:10 Go to previous messageGo to next message
kunal garg is currently offline kunal garg
Messages: 4
Registered: August 2012
Junior Member
I installed it from eclipse.org site.
are you sure that i need more memory to run eclipse. is there any other way possible through which i will be able to run it on my laptop.
Re: eclipse crashes at startup [message #900336 is a reply to message #900330] Mon, 06 August 2012 14:27 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3196
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 8/6/2012 8:10 AM, kunal garg wrote:
> I installed it from eclipse.org site.
> are you sure that i need more memory to run eclipse. is there any other
> way possible through which i will be able to run it on my laptop.

That little memory might make things very tight.

Please copy and paste what's in your eclipse.ini file so we can see it.
Re: eclipse crashes at startup [message #900583 is a reply to message #900336] Tue, 07 August 2012 16:08 Go to previous messageGo to next message
kunal garg is currently offline kunal garg
Messages: 4
Registered: August 2012
Junior Member
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20120522-1813
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Xms40m
-Xmx512m
Re: eclipse crashes at startup [message #900584 is a reply to message #900336] Tue, 07 August 2012 16:08 Go to previous messageGo to next message
kunal garg is currently offline kunal garg
Messages: 4
Registered: August 2012
Junior Member
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20120522-1813
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Xms40m
-Xmx512m
Re: eclipse crashes at startup [message #900589 is a reply to message #900584] Tue, 07 August 2012 16:17 Go to previous message
Russell Bateman is currently offline Russell Bateman
Messages: 3196
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 8/7/2012 10:08 AM, kunal garg wrote:
> -startup
> plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
> --launcher.library
> plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20120522-1813
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> --launcher.defaultAction
> openFile
> -vmargs
> -Xms40m
> -Xmx512m

Check out http://wiki.eclipse.org/Eclipse.ini. Also, as you've
downloaded 32-bit Eclipse, you must wire it up (see link) to a 32-bit JRE.
Previous Topic:Eclipse - extract data from XML file on a Server
Next Topic:Juno Update Site Problem (Win7, 64-bit)
Goto Forum:
  


Current Time: Tue Sep 23 00:36:21 GMT 2014

Powered by FUDForum. Page generated in 0.07180 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software