Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Fonts are bigger in product built with Juno
Fonts are bigger in product built with Juno [message #899441] Tue, 31 July 2012 16:23 Go to next message
Mel T. is currently offline Mel T.
Messages: 7
Registered: July 2009
Junior Member
Hi,

Since upgrading my product to using Juno/e4/4.2, I have a font problem when running the built product.
I rely on the legacy support and do not use any of the e4 new model (CSS and all) at this stage.

When running in development from the IDE (using the product as launcher), the fonts look just right.
It is only when I run as an exported product that the fonts are bigger in the dialogs, on buttons, on tabs etc...

I've been fixing many things to make our product run fine on Juno, but this issue is harder to fix.
Any pointer on what to look for?

Edit: the product target is macosx.cocoa.x86_64.
--
Mel T.

[Updated on: Tue, 31 July 2012 16:25]

Report message to a moderator

Re: Fonts are bigger in product built with Juno [message #899520 is a reply to message #899441] Wed, 01 August 2012 05:27 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5014
Registered: July 2009
Senior Member
On which platform?

Tom

Am 31.07.12 22:23, schrieb Mel T.:
> Hi,
>
> Since upgrading my product to using Juno/e4/4.2, I have a font problem
> when running the built product.
> I rely on the legacy support and do not use any of the e4 new model (CSS
> and all) at this stage.
>
> When running in development from the IDE (using the product as
> launcher), the fonts look just right.
> It is only when I run as an exported product that the fonts are bigger
> in the dialogs, on buttons, on tabs etc...
>
> I've been fixing many things to make our product run fine on Juno, but
> this issue is harder to fix.
> Any pointer on what to look for?
>
> --
> Mel T.
Re: Fonts are bigger in product built with Juno [message #899562 is a reply to message #899520] Wed, 01 August 2012 09:01 Go to previous messageGo to next message
Mel T. is currently offline Mel T.
Messages: 7
Registered: July 2009
Junior Member
Tom, I had edited my post with that info after you got the original:

> the product target is macosx.cocoa.x86_64

Thomas Schindl wrote on Wed, 01 August 2012 05:27
On which platform?

Tom

Am 31.07.12 22:23, schrieb Mel T.:
> Hi,
>
> Since upgrading my product to using Juno/e4/4.2, I have a font problem
> when running the built product.
> I rely on the legacy support and do not use any of the e4 new model (CSS
> and all) at this stage.
>
> When running in development from the IDE (using the product as
> launcher), the fonts look just right.
> It is only when I run as an exported product that the fonts are bigger
> in the dialogs, on buttons, on tabs etc...
>
> I've been fixing many things to make our product run fine on Juno, but
> this issue is harder to fix.
> Any pointer on what to look for?
>
> --
> Mel T.
Re: Fonts are bigger in product built with Juno [message #899566 is a reply to message #899562] Wed, 01 August 2012 09:08 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5014
Registered: July 2009
Senior Member
Ok - did your export set "-Dorg.eclipse.swt.internal.carbon.smallFonts"?
The name is a bit missleading but I think that's the option to make the
fonts smaller.

Tom

Am 01.08.12 15:01, schrieb Mel T.:
> Tom, I had edited my post with that info after you got the original:
>
>> the product target is macosx.cocoa.x86_64
>
> Thomas Schindl wrote on Wed, 01 August 2012 05:27
>> On which platform?
>>
>> Tom
>>
>> Am 31.07.12 22:23, schrieb Mel T.:
>> > Hi,
>> > > Since upgrading my product to using Juno/e4/4.2, I have a font
>> problem
>> > when running the built product.
>> > I rely on the legacy support and do not use any of the e4 new model
>> (CSS
>> > and all) at this stage.
>> > > When running in development from the IDE (using the product as
>> > launcher), the fonts look just right.
>> > It is only when I run as an exported product that the fonts are bigger
>> > in the dialogs, on buttons, on tabs etc...
>> > > I've been fixing many things to make our product run fine on Juno,
>> but
>> > this issue is harder to fix.
>> > Any pointer on what to look for?
>> > > -- > Mel T.
>
Re: Fonts are bigger in product built with Juno [message #899567 is a reply to message #899562] Wed, 01 August 2012 09:09 Go to previous messageGo to next message
Daniel Krügler is currently offline Daniel Krügler
Messages: 853
Registered: July 2009
Senior Member
On 2012-08-01 15:01, Mel T. wrote:
> Tom, I had edited my post with that info after you got the original:

Editing posts is no good idea, it won't be visible for most newsgroup
readers (It surely is not visible on mine). You need to repost, if you
want to change things that you wrote, typically as a reply to your
original post.

Greetings from Bremen,

Daniel Krügler
Re: Fonts are bigger in product built with Juno [message #899676 is a reply to message #899566] Wed, 01 August 2012 14:43 Go to previous message
Mel T. is currently offline Mel T.
Messages: 7
Registered: July 2009
Junior Member
Ok, that fixed it. I added this property to the product definition.

   <configurations>
      ...  
      <property name="org.eclipse.swt.internal.carbon.smallFonts" value="true" />
   </configurations>


Unclear why this was suddenly needed between Indigo and Juno products, but I am happy. Thanks!

--
Mel T

Thomas Schindl wrote on Wed, 01 August 2012 09:08
Ok - did your export set "-Dorg.eclipse.swt.internal.carbon.smallFonts"?
The name is a bit missleading but I think that's the option to make the
fonts smaller.

Tom

Am 01.08.12 15:01, schrieb Mel T.:
> Tom, I had edited my post with that info after you got the original:
>
>> the product target is macosx.cocoa.x86_64
>
> Thomas Schindl wrote on Wed, 01 August 2012 05:27
>> On which platform?
>>
>> Tom
>>
>> Am 31.07.12 22:23, schrieb Mel T.:
>> > Hi,
>> > > Since upgrading my product to using Juno/e4/4.2, I have a font
>> problem
>> > when running the built product.
>> > I rely on the legacy support and do not use any of the e4 new model
>> (CSS
>> > and all) at this stage.
>> > > When running in development from the IDE (using the product as
>> > launcher), the fonts look just right.
>> > It is only when I run as an exported product that the fonts are bigger
>> > in the dialogs, on buttons, on tabs etc...
>> > > I've been fixing many things to make our product run fine on Juno,
>> but
>> > this issue is harder to fix.
>> > Any pointer on what to look for?
>> > > -- > Mel T.
>
Previous Topic:Changing the plugin ID
Next Topic:IllegalStateException After Changing Target Platform
Goto Forum:
  


Current Time: Sun Apr 20 02:55:58 EDT 2014

Powered by FUDForum. Page generated in 0.03192 seconds