Well I think we require 1.6.0 but you can run both in the same env
because they are not singletons.
Am 27.07.12 18:45, schrieb Kevin Milburn:
> I've tried updating my Eclipse project to use the Batik 1.7.0 bundles
> from the Orbit repository (R20120526062928), but after doing so my
> application will not launch:
> !MESSAGE Missing required capability Require-Capability: osgi.ee;
> !SUBENTRY 1 org.eclipse.osgi 2 0 2012-07-27 16:53:38.846
> !MESSAGE Bundle
> was not resolved.
> !SUBENTRY 2 org.eclipse.e4.ui.css.core 2 0 2012-07-27 16:53:38.847
> !MESSAGE Missing required bundle org.apache.batik.css_[1.6.0,1.7.0).
> I've checked the target platform and the run configuration, and the
> org.apache.batik.css(1.7.0.v20100111041432) plugin is present and selected.
> However, validating the plugins also reports that
> org.eclipse.e4.ui.css.core is missing the Required Bundle
> Is it just me, or is Juno not compatible with batik from Orbit?
> Any ideas on how to get Batik 1.7.0 in Juno?
> In case your wondering, I need Batik 1.7.0 as Batik 1.6.0 throws an
> AbstractMethodError when trying to use DOM Level 3 (Core) methods (e.g.
Modifying the run configuration to use both the 1.6.0 and 1.7.0 bundles causes even more errors, so no luck there.
The only solution I've found is to use Batik bundles with different bundle names (from com.springsource).
I take it there hasn't been any further progress on Bug 189139 and its related bugs; so no chance of having Batik 1.7 officially support any time soon.
Batik 1.7.0 is in Orbit, so I assume those issues were resolved. I did briefly experiment with using Batik 1.7.0 a while back and didn't notice any issues. But it didn't fix a key issue from 1.6 that we faced with the E4 CSS (specifically vendor prefixes like '-swt-'), and it was late in the game to switch.
I'd suggest you bring in the org.eclipse.e4.ui.css.core bundle, modify it to relax the allowed versions, and give it a try. Report back on your experiences on: