Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Juno with Batik 1.7
Juno with Batik 1.7 [message #898801] Fri, 27 July 2012 16:45 Go to next message
Kevin Milburn is currently offline Kevin Milburn
Messages: 13
Registered: July 2012
Junior Member
I've tried updating my Eclipse project to use the Batik 1.7.0 bundles from the Orbit repository (R20120526062928), but after doing so my application will not launch:

!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-07-27 16:53:38.846
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.e4.ui.css.core_0.10.1.v20120523-1955.jar was not resolved.
!SUBENTRY 2 org.eclipse.e4.ui.css.core 2 0 2012-07-27 16:53:38.847
!MESSAGE Missing required bundle org.apache.batik.css_[1.6.0,1.7.0).

I've checked the target platform and the run configuration, and the org.apache.batik.css(1.7.0.v20100111041432) plugin is present and selected.

However, validating the plugins also reports that org.eclipse.e4.ui.css.core is missing the Required Bundle org.apache.batik.css.

Is it just me, or is Juno not compatible with batik from Orbit?
Any ideas on how to get Batik 1.7.0 in Juno?


In case your wondering, I need Batik 1.7.0 as Batik 1.6.0 throws an AbstractMethodError when trying to use DOM Level 3 (Core) methods (e.g. setUserData).
Re: Juno with Batik 1.7 [message #898809 is a reply to message #898801] Fri, 27 July 2012 17:28 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5327
Registered: July 2009
Senior Member
Well I think we require 1.6.0 but you can run both in the same env
because they are not singletons.

Tom

Am 27.07.12 18:45, schrieb Kevin Milburn:
> I've tried updating my Eclipse project to use the Batik 1.7.0 bundles
> from the Orbit repository (R20120526062928), but after doing so my
> application will not launch:
>
> !MESSAGE Missing required capability Require-Capability: osgi.ee;
> filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
>
> !SUBENTRY 1 org.eclipse.osgi 2 0 2012-07-27 16:53:38.846
> !MESSAGE Bundle
> initial@reference:file:plugins/org.eclipse.e4.ui.css.core_0.10.1.v20120523-1955.jar
> was not resolved.
> !SUBENTRY 2 org.eclipse.e4.ui.css.core 2 0 2012-07-27 16:53:38.847
> !MESSAGE Missing required bundle org.apache.batik.css_[1.6.0,1.7.0).
>
> I've checked the target platform and the run configuration, and the
> org.apache.batik.css(1.7.0.v20100111041432) plugin is present and selected.
>
> However, validating the plugins also reports that
> org.eclipse.e4.ui.css.core is missing the Required Bundle
> org.apache.batik.css.
>
> Is it just me, or is Juno not compatible with batik from Orbit?
> Any ideas on how to get Batik 1.7.0 in Juno?
>
>
> In case your wondering, I need Batik 1.7.0 as Batik 1.6.0 throws an
> AbstractMethodError when trying to use DOM Level 3 (Core) methods (e.g.
> setUserData).
Re: Juno with Batik 1.7 [message #899271 is a reply to message #898809] Tue, 31 July 2012 09:48 Go to previous messageGo to next message
Kevin Milburn is currently offline Kevin Milburn
Messages: 13
Registered: July 2012
Junior Member
Modifying the run configuration to use both the 1.6.0 and 1.7.0 bundles causes even more errors, so no luck there.
The only solution I've found is to use Batik bundles with different bundle names (from com.springsource).

I take it there hasn't been any further progress on Bug 189139 and its related bugs; so no chance of having Batik 1.7 officially support any time soon.
Re: Juno with Batik 1.7 [message #899302 is a reply to message #899271] Tue, 31 July 2012 12:17 Go to previous message
Brian de Alwis is currently offline Brian de Alwis
Messages: 242
Registered: July 2009
Senior Member
Batik 1.7.0 is in Orbit, so I assume those issues were resolved. I did briefly experiment with using Batik 1.7.0 a while back and didn't notice any issues. But it didn't fix a key issue from 1.6 that we faced with the E4 CSS (specifically vendor prefixes like '-swt-'), and it was late in the game to switch.

I'd suggest you bring in the org.eclipse.e4.ui.css.core bundle, modify it to relax the allowed versions, and give it a try. Report back on your experiences on:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=266174

If you need this for your own product, ship your fixed version css.core using a feature patch.

Brian.
Previous Topic:How to use or migrate Eclipse 3.x editor
Next Topic:PartDescriptor in fragments
Goto Forum:
  


Current Time: Fri Sep 19 02:01:52 GMT 2014

Powered by FUDForum. Page generated in 0.17751 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software