Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Code Recommenders » Problems updating from HEAD Updatesite
Problems updating from HEAD Updatesite [message #896986] Fri, 20 July 2012 12:37 Go to next message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

Hello,

Since 3 days i'm trying to update CodeRecommendors from:
http://download.eclipse.org/recommenders/updates/head/e42/

but i get this errors:
An error occurred while collecting items to be installed
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.calls,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.chain,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.e38,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.overrides,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.subwords,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.templates,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.doc,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.extdoc,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.extdoc.rcp,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.injection,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.jayes,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.jayes.serialization,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.rcp,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.utils,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.utils.rcp,1.0.0.v20120720-1219-b604
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.3rd.orbit,1.0.0.v20120720-1219-b604
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.3rd.rcp.nonorbit,1.0.0.v20120720-1219-b604
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.completion.rcp.chain,1.0.0.v20120720-1219-b604
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.completion.rcp.intellig,1.0.0.v20120720-1219-b604
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.completion.rcp.subwords,1.0.0.v20120720-1219-b604
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.extdoc.rcp,1.0.0.v20120720-1219-b604
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.rcp.core,1.0.0.v20120720-1219-b604
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.snipmatch.rcp,1.0.0.v20120720-1219-b604
No repository found containing: osgi.bundle,org.eclipse.recommenders.snipmatch.rcp,1.0.0.v20120720-1219-b604


Running Eclipse 4.2 64Bit on Windows7 64Bit with JDK 1.7u5 64Bit.

any solutions for this issue?

[Updated on: Fri, 20 July 2012 12:39]

Report message to a moderator

Re: Problems updating from HEAD Updatesite [message #897387 is a reply to message #896986] Mon, 23 July 2012 18:06 Go to previous messageGo to next message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

Update problem is still present!

Have test it with a clean new workspace but it doesn't help...still can't update from:
http://download.eclipse.org/recommenders/updates/head/e42/


I'm alone with this problem ? o.O
Re: Problems updating from HEAD Updatesite [message #897410 is a reply to message #897387] Mon, 23 July 2012 23:38 Go to previous messageGo to next message
Marcel Bruch is currently offline Marcel Bruch
Messages: 226
Registered: July 2009
Senior Member
Sorry for the delay. This post didn't show up in my RSS feed.

The installation works for me using these selections:
index.php/fa/10811/0/

Could you check if above selection settings would work for you? If not, I assume it's a mirror issue that needs a little more work but can be fixed. Please let me know if the installation works with the above settings.

Thanks,
Marcel



tw: @MarcelBruch
tw: @Recommenders
Re: Problems updating from HEAD Updatesite [message #897412 is a reply to message #897410] Mon, 23 July 2012 23:47 Go to previous messageGo to next message
Marcel Bruch is currently offline Marcel Bruch
Messages: 226
Registered: July 2009
Senior Member
BTW:

I just noticed you are trying to download build "b604". Head update site only contains "b607".

As this update site is filled by the build server automatically and old versions are deleted, I hope this is not a caching issue of your Eclipse. Could you make sure to restart your IDE before checking the download site again?


tw: @MarcelBruch
tw: @Recommenders
Re: Problems updating from HEAD Updatesite [message #897417 is a reply to message #897412] Tue, 24 July 2012 00:51 Go to previous messageGo to next message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

Good morning Marcel,

thanks for your reply. (Finally, my pleading is heard. Smile )

Marcel Bruch wrote on Tue, 24 July 2012 05:47
BTW:

I just noticed you are trying to download build "b604". Head update site only contains "b607".

Right, "b604" was the current version on Friday and I tried to upgrade from b598 to b604.

Yesterday and today I tried to upgrade from b598 (current installed plugin version on my Eclipse) to b607 (current version @HEAD-updatesite) with a new clean workspace and also got this error:
An error occurred while collecting items to be installed
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.calls,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.chain,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.e38,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.overrides,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.subwords,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.completion.rcp.templates,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.doc,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.extdoc,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.extdoc.rcp,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.injection,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.jayes,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.jayes.serialization,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.rcp,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.utils,1.0.0.v20120723-0339-b607
No repository found containing: osgi.bundle,org.eclipse.recommenders.utils.rcp,1.0.0.v20120723-0339-b607
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.3rd.orbit,1.0.0.v20120723-0339-b607
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.3rd.rcp.nonorbit,1.0.0.v20120723-0339-b607
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.completion.rcp.chain,1.0.0.v20120723-0339-b607
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.completion.rcp.intellig,1.0.0.v20120723-0339-b607
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.completion.rcp.subwords,1.0.0.v20120723-0339-b607
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.extdoc.rcp,1.0.0.v20120723-0339-b607
No repository found containing: org.eclipse.update.feature,org.eclipse.recommenders.feature.rcp.core,1.0.0.v20120723-0339-b607


Now, i uninstalled recommenders (b598) and tried to reinstall it (b607) with your recommended selection but i still got the same error.

I can't update or install Code-Recommender from HEAD-Updatesite and DEV-Updatesite (got the same error as on HEAD).

If i'm using STABLE-Updatesite (with b156 on it) i got this error:
An error occurred while collecting items to be installed
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.slf4j.jcl,1.6.4.v20120130-2120


Contents of my eclipse.ini:
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120522-1813
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
1024m
--launcher.defaultAction
openFile
-vm
D:/installed/Java/JDK_1.7.5_64bit/bin/javaw.exe
-vmargs
-Declipse.p2.unsignedPolicy=allow
-Xss4m
-XX:+UnlockExperimentalVMOptions
-Xms1024m
-Xmx2048m
-Dsun.lang.ClassLoader.allowArraySyntax=true

I never had a problem with this configuration since Eclipse 4.2 was released.
But in the past I've discovered that some plugins may have problems with several parameters in the eclipse.ini and could not be installed or updated.

I had no problems installing the version B598 with this eclispe.ini.

Maybe some parameters are also the cause. I don't know.

If you ever can afford some time for a solution to this problem I would be very grateful. But it is not urgent.

BTW: I'm here in Germany, maybe it is relevant for the "mirror thing" ?

Thanks alot,
Enrico
Re: Problems updating from HEAD Updatesite [message #897419 is a reply to message #897417] Tue, 24 July 2012 00:53 Go to previous messageGo to next message
Marcel Bruch is currently offline Marcel Bruch
Messages: 226
Registered: July 2009
Senior Member
Is the checkbox "contact all update sites during install to find required software" checked?

tw: @MarcelBruch
tw: @Recommenders
Re: Problems updating from HEAD Updatesite [message #897422 is a reply to message #897419] Tue, 24 July 2012 01:07 Go to previous messageGo to next message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

Yes, i have checked it every time.

index.php/fa/10815/0/

and these installations ends with:
index.php/fa/10816/0/
  • Attachment: CR_select.png
    (Size: 42.19KB, Downloaded 2906 times)
  • Attachment: CR_error.png
    (Size: 48.81KB, Downloaded 2914 times)
Re: Problems updating from HEAD Updatesite [message #897424 is a reply to message #897422] Tue, 24 July 2012 01:15 Go to previous messageGo to next message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

supplement:
Tried to install the Vaddin-Plugin and also got tis error.
Maybe you are right with the "mirror thing" ?
Re: Problems updating from HEAD Updatesite [message #897426 is a reply to message #897424] Tue, 24 July 2012 01:37 Go to previous messageGo to next message
Marcel Bruch is currently offline Marcel Bruch
Messages: 226
Registered: July 2009
Senior Member
maybe. We'll know soon Smile

I updated the server files for HEAD and DEV e42 update sites to point to other mirror locations. Please check the HEAD update site in a few hours again (better: when the listing returned here [1] is not empty anymore) and let me know if the error persists. Please make sure you restarted Eclipse before.

Thanks, Marcel

[1] http://www.eclipse.org/downloads/download.php?format=xml&file=/recommenders/updates/head/e42/


tw: @MarcelBruch
tw: @Recommenders
Re: Problems updating from HEAD Updatesite [message #897484 is a reply to message #897426] Tue, 24 July 2012 05:21 Go to previous messageGo to next message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

Okay, mirrors are listed but it dosen't work if i'm using the original HEAD-updatesite-URL for recommenders...got the same errors as before.

So i have added directly a mirror-URL for Germany as updatesite and it works! Smile

I don't know why the original HEAD-updatesite-URL dosen't work and i don't know where i can find relevant options/settings to renew caching for this.

Of course i made a restart of Eclipse and i deleted the folder ("p2/org.eclipse.equinox.p2.repository") from my Eclipse installation but it seems to have no relevant effect on this.

But anyway, i works for now.

Thank you for your time invested in this Problem, Marcel.
It's good to know that there is someone who can give professional help in case of problems with Code-Recommenders.

I love this feature and it really helps me to learn better programming with Java and Eclipse. Smile

Keep up the good work and maximum success!

Thanks and best regards.
Enrico

[Updated on: Tue, 24 July 2012 05:22]

Report message to a moderator

Re: Problems updating from HEAD Updatesite [message #897493 is a reply to message #897484] Tue, 24 July 2012 05:36 Go to previous messageGo to next message
Marcel Bruch is currently offline Marcel Bruch
Messages: 226
Registered: July 2009
Senior Member
Enrico,

I'm glad you found a workaround. I've asked the webmaster for assistance.

Regarding Code Recommenders: Thanks. Please don't hesitate to report any errors your experience or suggestions you may have.

Best,
Marcel


tw: @MarcelBruch
tw: @Recommenders
Re: Problems updating from HEAD Updatesite [message #897556 is a reply to message #897493] Tue, 24 July 2012 09:36 Go to previous messageGo to next message
Denis Roy is currently offline Denis Roy
Messages: 307
Registered: October 2004
Location: Ottawa, Ontario, Canada
Senior Member

Marcel, as I mentioned in an email: if you change the contents of content.jar, artifacts.jar or any other file under that directory, you must update the timestamp of the /recommenders/updates/head/e42/ also. Otherwise, all the mirrors will be shown despite there being changes to the contents which have not propagated.

Please let me know if you need more information.

Denis


Denis Roy
Eclipse Webmaster -- webmaster@eclipse.org
Re: Problems updating from HEAD Updatesite [message #898100 is a reply to message #897556] Wed, 25 July 2012 15:26 Go to previous message
Enrico R. is currently offline Enrico R.
Messages: 43
Registered: July 2009
Location: Germany
Member

Hello, me again with a little additional information about this problem.

I have found out that this problem was not only related to the recommenders updatesite.
I couldn't install or update any plugin where the updatesite is pointing to "download.eclipse.org/*". Updating or installing from another updatesite exept to "download.eclipse.org/*" works fine.
Maybe something went wrong in my eclipse installation but I don't know what exactly. I was able to show all plugins via the updatemanager but i was unable to download them.

Now I have setup a complete new Eclipse 4.2 installation and all updatesites pointing to "*.eclipse.org" works fine for now, also the original recommenders updatesite (download.eclipse.org/recommenders/updates/head/e42/).

I have nothing changed on my system configuration (firewall, antivirus or any network related settings).

Nevertheless, many thanks to you for your help!

best regards
Enrico
Previous Topic:Android NDK Native Development disappeared...
Next Topic:[ctrl]flow mining server - developer preview for mining your own apis
Goto Forum:
  


Current Time: Fri Aug 29 20:35:14 EDT 2014

Powered by FUDForum. Page generated in 0.02310 seconds