Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Creating a Graphiti editor on top of Xtext editor(Any news, ints, examples for this subject ?)
Creating a Graphiti editor on top of Xtext editor [message #896656] Thu, 19 July 2012 09:59 Go to next message
Maxime D is currently offline Maxime D
Messages: 27
Registered: June 2012
Junior Member
I would like to create a Graphiti editor which provides a graphic view of my file.myDSL.

I read a lot here and over here and I would like to know if any of you had any experience with this kind of use case ?

I am currently working on it, i.e working on linking my Graphiti editor to my generated EMF model in Xtext.

But I haven't found some ints or example (I exclude the GMF one provided in Xtext doc).

And I'm specially worried about the two-way synchronization when modify the file in Xtext editor and Graphiti one at the same time.

Any informations would be appreciated Smile

EDIT : I also try to build a graphiti diagram with Spray but I had some bugs which are registered in issues page in Spray Google Code page.

[Updated on: Fri, 20 July 2012 11:51]

Report message to a moderator

Re: Creating a Graphiti editor on top of Xtext editor [message #911242 is a reply to message #896656] Tue, 11 September 2012 08:25 Go to previous messageGo to next message
Alex G is currently offline Alex G
Messages: 96
Registered: January 2012
Member
Hi there!

I'm having the same issue here. I have exported the ecore DSL-model and built up the XText editor upon it. This ecore model is also used for Graphiti and the Graphiti editor shall be able to parse partial code snippets, by calling the parser generated by XText.
Have you made any progress regarding your posted issues like synchronisation etc.?

Best regards,
Alex.
Re: Creating a Graphiti editor on top of Xtext editor [message #911911 is a reply to message #911242] Wed, 12 September 2012 15:14 Go to previous message
Maxime D is currently offline Maxime D
Messages: 27
Registered: June 2012
Junior Member
Hi !
I didn't try to synchronize the all thing, for some reasons I stopped to use Graphiti pretty early in my development.
Previous Topic:Quickfixes do not appear reliably
Next Topic:Problem building with Tycho - can't resolve eclipselabs unit testing bundle - SOLVED
Goto Forum:
  


Current Time: Thu Oct 23 08:03:33 GMT 2014

Powered by FUDForum. Page generated in 0.01850 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software